7.7 Помогите пожалуйста!

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Zheleznogorsk, 8 ноя 2010.

  1. TopicStarter Overlay
    Zheleznogorsk
    Offline

    Zheleznogorsk

    Регистрация:
    29 окт 2010
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Господа професионалы! Помогите, плз!!
    Проблема: есть справочник Контрагенты, идентификатор Наименование - Полное название контрагента, Тип... Так вот, при записи нового элемента справочника нужно сделать перебор всех его элементов на проверку не существует ли он уже... Соответственно перебор нужно делать по Наименованию и вышеупомянутым реквизитам...Сделать то сделал,но проблема в том,что не проверяет при записи сочетание условий, то есть я ввожу например контрагента с одинаковыми названиями но с разными типа, он не дает записать, ниже код:
    Код:
    Процедура ПриЗаписи()
    Если Выбран()=0 Тогда 
    спрК=СоздатьОбъект("Справочник.Контрагенты");
    спрК.ВыбратьЭлементы(0); 
    Пока спрК.ПолучитьЭлемент()=1 Цикл
    Если спрК.ЭтоГруппа()=1 Тогда
    Продолжить;
    КонецЕсли;
    НашлиДубликат=0;  
    Если (ВРЕГ(СокрЛП(спрК.Наименование))= ВРЕГ(СокрЛП(Наименование)))
    или (ВРЕГ(СокрЛП(спрК.Тип)) = ВРЕГ(СокрЛП(Тип)))
    Тогда 
    НашлиДубликат=1; 
    Прервать; 
    КонецЕсли;
    КонецЦикла;
    Если НашлиДубликат=1 Тогда
    Предупреждение("Найден полностью совпадающий элемент!",6); 
    СтатусВозврата(0); 
    Возврат; 
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры
    
    
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Ошибка у вас была в условии
    + необходима проверка на текущий элемент (иначе больше вообще записать не сможете)
    Код:
    Если (ВРЕГ(СокрЛП(спрК.Наименование))= ВРЕГ(СокрЛП(Наименование)))И(ВРЕГ(СокрЛП(спрК.Тип)) = ВРЕГ(СокрЛП(Тип)))
    И(СпрК.ТекущийЭлемент()<>ТекущийЭлемент() Тогда 
    
    
  3. TopicStarter Overlay
    Zheleznogorsk
    Offline

    Zheleznogorsk

    Регистрация:
    29 окт 2010
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Спасибо,уже разобрался!
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Не забудьте про дополнительное условие... Иначе запись элемента будет возможна только 1 раз при его создании))))
Похожие темы
  1. maximarm
    Ответов:
    6
    Просмотров:
    1.102
Загрузка...

Поделиться этой страницей