7.7 Помогите пожалуйста сделать итог по колонке "Начислено"

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем kot-1012, 5 сен 2011.

  1. TopicStarter Overlay
    kot-1012
    Offline

    kot-1012

    Регистрация:
    15 июл 2011
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Не хватает ума сделать итог по колонке НАЧИСЛЕННО.
    ПОМОГИТЕ ПОЖАЛУЙСТА.
    1С 7.7

    Вложения:

    • 11.ert
      Размер файла:
      22,5 КБ
      Просмотров:
      46
  2. Именин...
    Offline

    Именин...

    Регистрация:
    1 ноя 2006
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Итог(имя реквезита)
  3. TopicStarter Overlay
    kot-1012
    Offline

    kot-1012

    Регистрация:
    15 июл 2011
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    выдает "Поле агрегатного объекта не обнаружено (Итог)"
  4. Dmitriy_76
    Offline

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.175
    Симпатии:
    13
    Баллы:
    29

    покажи что и где написал
  5. TopicStarter Overlay
    kot-1012
    Offline

    kot-1012

    Регистрация:
    15 июл 2011
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    прикрепил

    Вложения:

    • 11.ert
      Размер файла:
      22,5 КБ
      Просмотров:
      25
    • Безымянный.jpg
      Безымянный.jpg
      Размер файла:
      50,7 КБ
      Просмотров:
      247
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    так у вас уже есть итоги..... Секция ИТОГО
  7. TopicStarter Overlay
    kot-1012
    Offline

    kot-1012

    Регистрация:
    15 июл 2011
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    я знаю, но мне нужно чтоб итог был под колонкой НАЧИСЛЕНО.
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Не корректно формулируете вопрос. К тому же этих колонок (начислено) три штуки. Попробуйте более подробно описать что вам нужно
  9. TopicStarter Overlay
    kot-1012
    Offline

    kot-1012

    Регистрация:
    15 июл 2011
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    три колонки "начислено" потомучто три вида начислений, т.е. при определенных начислениях юти секции присоединяются. Вот рисунок куда нужно поставить итог

    Вложения:

  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Общий? Где у вас "всего"?
  11. TopicStarter Overlay
    kot-1012
    Offline

    kot-1012

    Регистрация:
    15 июл 2011
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Не та картинка, ИЗВИНИТЕ

    Вложения:

    • 1.JPG
      1.JPG
      Размер файла:
      157,3 КБ
      Просмотров:
      163
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Код:
    Таб.ВывестиСекцию("Итог");
    Если ТипСчетчика=Перечисление.ТипыСчетчиков.ХВС Тогда
    Таб.ПрисоединитьСекцию("Итог|ХВС");
    КонецЕсли;
    Если ТипСчетчика=Перечисление.ТипыСчетчиков.Канализация Тогда
    Таб.ПрисоединитьСекцию("Итог|КАН");
    КонецЕсли; 
    Если (ТипСчетчика<>Перечисление.ТипыСчетчиков.Канализация) И (ТипСчетчика<>Перечисление.ТипыСчетчиков.ХВС) Тогда
    Таб.ПрисоединитьСекцию("Итог|ПустойСтолбец");
    КонецЕсли; 
    
    
    В макете отчета в секции ИТОГ нужно присвоить значения ячейкам по аналогии с секцией ИТОГО
  13. TopicStarter Overlay
    kot-1012
    Offline

    kot-1012

    Регистрация:
    15 июл 2011
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    все получилось спасибо
  14. TopicStarter Overlay
    kot-1012
    Offline

    kot-1012

    Регистрация:
    15 июл 2011
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    ошибся- он выдает последнее значение из этих секций, а не их сумму
  15. TopicStarter Overlay
    kot-1012
    Offline

    kot-1012

    Регистрация:
    15 июл 2011
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Всем спасибо, сделал

Поделиться этой страницей