8.х Помогите пожалуйста с внешней печатной формой счета на оплату для КА

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем max805, 19 июн 2014.

  1. TopicStarter Overlay
    max805
    Offline

    max805

    Регистрация:
    18 дек 2007
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Добрый день. Люди можете помочь с внешней печатной формой счета на оплату для КА. Буду очень благодарен.
  2. alexburn
    Online

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Чем помочь? Что сделали? На форуме есть ветка, где это по-шагово описывается.
  3. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.980
    Симпатии:
    398
    Баллы:
    104
    Если это задание за оплату, то Вам в раздел Фриланс
  4. TopicStarter Overlay
    max805
    Offline

    max805

    Регистрация:
    18 дек 2007
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Скачал одну форму но там постоянно выскакивает ошибка. и как ее побороть я просто ума не приложу(( и пошагово делал нифига не выходит(
  5. alexburn
    Online

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Значит неправильно делали. Для халявщиков есть спец. ветка, по фрилансу:)
  6. TopicStarter Overlay
    max805
    Offline

    max805

    Регистрация:
    18 дек 2007
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Вот по этому и прошу помочь.
  7. alexburn
    Online

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Вот по-этому я и спрашивал, что сделали уже ????
  8. TopicStarter Overlay
    max805
    Offline

    max805

    Регистрация:
    18 дек 2007
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    1. Пытался написать самим по самоучителю. Но видимо либо у меня мозги заточены по другому либо есть свои ньюансы из за конфигураций. НЕПОЛУЧИЛОСЬ!
    2. Скачал с интернета но там выдается ошибка:
    {ВнешняяОбработка.ВнешняяОбработка1.МодульОбъекта(39)}: Ошибка при вызове метода контекста (Выполнить)
    Шапка = Запрос.Выполнить().Выбрать();
    по причине:
    {(19, 2)}: Неоднозначное поле "ЗаказПокупателя.Ссылка"
    <<?>>ЗаказПокупателя.Ссылка = &ТекущийДокумент
  9. alexburn
    Online

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Эта ошибка говорит о том, что используется одно и то же поле. Обычно выскакивает если выбирается из табличной части, и еще ссылка, хотя в ТЧ уже присутствует ссылка.
    Запрос сюда выкладывайте.
  10. TopicStarter Overlay
    max805
    Offline

    max805

    Регистрация:
    18 дек 2007
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    #Если Клиент Тогда
    Функция ВернутьРасчетныйСчет(СчетКонтрагента)

    БанкДляРасчетов = СчетКонтрагента.БанкДляРасчетов;
    Результат = ?(БанкДляРасчетов.Пустая(), СчетКонтрагента.НомерСчета, СчетКонтрагента.Банк.КоррСчет);

    Возврат Результат;

    КонецФункции // ВернутьРасчетныйСчет()



    Функция ПечатьСчета()

    Перем ПодразделениеОтветственныхЛиц;

    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект.Ссылка);
    Запрос.Текст ="
    |ВЫБРАТЬ
    | Номер,
    | Дата,
    | ДоговорКонтрагента,
    | Организация,
    | Контрагент КАК Покупатель,
    | Организация КАК Руководители,
    | Организация КАК Поставщик,
    | ОрганизацияПолучатель КАК Получатель,
    | СуммаДокумента,
    | ВалютаДокумента,
    | УчитыватьНДС,
    | СуммаВключаетНДС
    |ИЗ
    | Документ.СчетНаОплатуПокупателю КАК ЗаказПокупателя
    |
    |ГДЕ
    | ЗаказПокупателя.Ссылка = &ТекущийДокумент";

    Шапка = Запрос.Выполнить().Выбрать();
    Шапка.Следующий();

    ТабДокумент = Новый ТабличныйДокумент;
    ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ЗаказПокупателя_СчетЗаказ";

    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект.Ссылка);

    ЧастьЗапросаДляВыбораСодержанияУслуг = ФормированиеПечатныхФорм.ПолучитьЧастьЗапросаДляВыбораСодержанияУслуг("ЗаказПокупателя");

    Запрос.Текст =
    "ВЫБРАТЬ
    | ВложенныйЗапрос.Номенклатура КАК Номенклатура,
    | ВЫРАЗИТЬ(ВложенныйЗапрос.Номенклатура.НаименованиеПолное КАК Строка(1000)) КАК Товар,
    | ВложенныйЗапрос.Номенклатура.Код КАК Код,
    | ВложенныйЗапрос.Номенклатура.Артикул КАК Артикул,
    | ВложенныйЗапрос.Количество,
    | ВложенныйЗапрос.ЕдиницаИзмерения,
    | ВложенныйЗапрос.Цена,
    | ВложенныйЗапрос.Сумма,
    | ВложенныйЗапрос.СуммаНДС,
    | ВложенныйЗапрос.НомерСтроки КАК НомерСтроки,
    | 1 КАК ID
    |ИЗ
    | (ВЫБРАТЬ
    | ЗаказПокупателя.Номенклатура КАК Номенклатура,
    | ЗаказПокупателя.Номенклатура.БазоваяЕдиницаИзмерения.Наименование КАК ЕдиницаИзмерения,
    | ЗаказПокупателя.Цена КАК Цена,
    | СУММА(ЗаказПокупателя.Количество) КАК Количество,
    | СУММА(ЗаказПокупателя.Сумма) КАК Сумма,
    | СУММА(ЗаказПокупателя.СуммаНДС) КАК СуммаНДС,
    | МИНИМУМ(ЗаказПокупателя.НомерСтроки) КАК НомерСтроки
    | ИЗ
    | Документ.СчетНаОплатуПокупателю.Товары КАК ЗаказПокупателя
    |
    | ГДЕ
    | ЗаказПокупателя.Ссылка = &ТекущийДокумент
    |
    | СГРУППИРОВАТЬ ПО
    | ЗаказПокупателя.Номенклатура,
    | ЗаказПокупателя.Номенклатура.БазоваяЕдиницаИзмерения.Наименование,
    | ЗаказПокупателя.Цена) КАК ВложенныйЗапрос
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ
    | " + ЧастьЗапросаДляВыбораСодержанияУслуг + ",
    | " + ЧастьЗапросаДляВыбораСодержанияУслуг + ",
    | ЗаказПокупателя.Номенклатура.Код КАК Код,
    | ЗаказПокупателя.Номенклатура.Артикул КАК Артикул,
    | ЗаказПокупателя.Количество,
    | ЗаказПокупателя.Номенклатура.БазоваяЕдиницаИзмерения.Наименование,
    | ЗаказПокупателя.Цена,
    | ЗаказПокупателя.Сумма,
    | ЗаказПокупателя.СуммаНДС,
    | ЗаказПокупателя.НомерСтроки,
    | 2
    |ИЗ
    | Документ.СчетНаОплатуПокупателю.Услуги КАК ЗаказПокупателя
    |
    |ГДЕ
    | ЗаказПокупателя.Ссылка = &ТекущийДокумент
    |
    |УПОРЯДОЧИТЬ ПО
    | ID,
    | НомерСтроки";

    ЗапросТовары = Запрос.Выполнить().Выгрузить();

    Макет = ПолучитьМакет("Макет");

    // Выводим шапку накладной

    СведенияОПолучателе = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.Получатель, Шапка.Дата);
    //Если Тип = "Счет" Тогда
    ОбластьМакета = Макет.ПолучитьОбласть("ЗаголовокСчета");
    ОбластьМакета.Параметры.Заполнить(Шапка);
    ОбластьМакета.Параметры.ИННПолучателя = СведенияОПолучателе.ИНН;
    ОбластьМакета.Параметры.КПППолучателя = СведенияОПолучателе.КПП;
    Если ТипЗнч(СсылкаНаОбъект.СтруктурнаяЕдиница) = Тип("СправочникСсылка.БанковскиеСчета") Тогда
    Банк = ?(НЕ ЗначениеЗаполнено(СсылкаНаОбъект.СтруктурнаяЕдиница.БанкДляРасчетов), СсылкаНаОбъект.СтруктурнаяЕдиница.Банк, СсылкаНаОбъект.СтруктурнаяЕдиница.БанкДляРасчетов);
    БИК = Банк.Код;
    КоррСчет = Банк.КоррСчет;
    ГородБанка = Банк.Город;
    НомерСчета = ВернутьРасчетныйСчет(СсылкаНаОбъект.СтруктурнаяЕдиница);

    ОбластьМакета.Параметры.БИКБанкаПолучателя = БИК;
    ОбластьМакета.Параметры.БанкПолучателя = Банк;
    ОбластьМакета.Параметры.БанкПолучателяПредставление = СокрЛП(Банк) + " " + ГородБанка;
    ОбластьМакета.Параметры.СчетБанкаПолучателя = КоррСчет;
    ОбластьМакета.Параметры.СчетБанкаПолучателяПредставление = КоррСчет;
    ОбластьМакета.Параметры.СчетПолучателяПредставление = НомерСчета;
    ОбластьМакета.Параметры.СчетПолучателя = НомерСчета;
    КонецЕсли;

    Если ПустаяСтрока(СсылкаНаОбъект.СтруктурнаяЕдиница.ТекстКорреспондента) Тогда
    ТекстКорреспондента = СведенияОПолучателе.НаименованиеДляПечатныхФорм;
    Если ЗначениеЗаполнено(СсылкаНаОбъект.СтруктурнаяЕдиница.БанкДляРасчетов) Тогда
    ТекстКорреспондента = ТекстКорреспондента + " р/с " + СсылкаНаОбъект.СтруктурнаяЕдиница.НомерСчета
    + " в " + СсылкаНаОбъект.СтруктурнаяЕдиница.Банк + " " + СсылкаНаОбъект.СтруктурнаяЕдиница.Банк.Город;
    КонецЕсли;
    Иначе
    ТекстКорреспондента = СсылкаНаОбъект.СтруктурнаяЕдиница.ТекстКорреспондента;
    КонецЕсли;
    ОбластьМакета.Параметры.ПредставлениеПолучателя = ТекстКорреспондента;

    ТабДокумент.Вывести(ОбластьМакета);
    //КонецЕсли;

    ОбластьМакета = Макет.ПолучитьОбласть("Заголовок");
    ОбластьМакета.Параметры.ТекстЗаголовка = ОбщегоНазначения.СформироватьЗаголовокДокумента(Шапка, "Счет на оплату");

    ТабДокумент.Вывести(ОбластьМакета);

    ОбластьМакета = Макет.ПолучитьОбласть("Поставщик");
    ОбластьМакета.Параметры.Заполнить(Шапка);
    СведенияОбОрганизации = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.Организация, Шапка.Дата);
    ОбластьМакета.Параметры.ПредставлениеПоставщика = ФормированиеПечатныхФорм.ОписаниеОрганизации(
    СведенияОбОрганизации, "НаименованиеДляПечатныхФорм,ИНН,КПП,ЮридическийАдрес,Телефоны,");
    ТабДокумент.Вывести(ОбластьМакета);

    ОбластьМакета = Макет.ПолучитьОбласть("Покупатель");
    ОбластьМакета.Параметры.Заполнить(Шапка);
    СведенияОПокупателе = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.Покупатель, Шапка.Дата);
    ОбластьМакета.Параметры.ПредставлениеПокупателя = ФормированиеПечатныхФорм.ОписаниеОрганизации(
    СведенияОПокупателе, "НаименованиеДляПечатныхФорм,ИНН,КПП,ЮридическийАдрес,Телефоны,");
    ТабДокумент.Вывести(ОбластьМакета);

    ДопКолонка = Константы.ДополнительнаяКолонкаПечатныхФормДокументов.Получить();
    Если ДопКолонка = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул Тогда
    ВыводитьКоды = Истина;
    Колонка = "Артикул";
    ИначеЕсли ДопКолонка = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.Код Тогда
    ВыводитьКоды = Истина;
    Колонка = "Код";
    Иначе
    ВыводитьКоды = Ложь;
    КонецЕсли;

    ОбластьНомера = Макет.ПолучитьОбласть("ШапкаТаблицы|НомерСтроки");
    ОбластьКодов = Макет.ПолучитьОбласть("ШапкаТаблицы|КолонкаКодов");
    ОбластьДанных = Макет.ПолучитьОбласть("ШапкаТаблицы|Данные");
    ОбластьСуммы = Макет.ПолучитьОбласть("ШапкаТаблицы|Сумма");

    ТабДокумент.Вывести(ОбластьНомера);
    Если ВыводитьКоды Тогда
    ОбластьКодов.Параметры.ИмяКолонкиКодов = Колонка;
    ТабДокумент.Присоединить(ОбластьКодов);
    КонецЕсли;
    ТабДокумент.Присоединить(ОбластьДанных);
    ТабДокумент.Присоединить(ОбластьСуммы);

    ОбластьКолонкаТовар = Макет.Область("Товар");

    Если Не ВыводитьКоды Тогда
    ОбластьКолонкаТовар.ШиринаКолонки = ОбластьКолонкаТовар.ШиринаКолонки +
    Макет.Область("КолонкаКодов").ШиринаКолонки;
    КонецЕсли;

    ОбластьНомера = Макет.ПолучитьОбласть("Строка|НомерСтроки");
    ОбластьКодов = Макет.ПолучитьОбласть("Строка|КолонкаКодов");
    ОбластьДанных = Макет.ПолучитьОбласть("Строка|Данные");
    ОбластьСуммы = Макет.ПолучитьОбласть("Строка|Сумма");

    Сумма = 0;
    СуммаНДС = 0;
    ВсегоСкидок = 0;
    ВсегоБезСкидок = 0;

    Для каждого ВыборкаСтрокТовары Из ЗапросТовары Цикл

    ОбластьНомера.Параметры.НомерСтроки = ЗапросТовары.Индекс(ВыборкаСтрокТовары) + 1;
    ТабДокумент.Вывести(ОбластьНомера);

    Если ВыводитьКоды Тогда
    Если Колонка = "Артикул" Тогда
    ОбластьКодов.Параметры.Артикул = ВыборкаСтрокТовары.Артикул;
    Иначе
    ОбластьКодов.Параметры.Артикул = ВыборкаСтрокТовары.Код;
    КонецЕсли;
    ТабДокумент.Присоединить(ОбластьКодов);
    КонецЕсли;

    ОбластьДанных.Параметры.Заполнить(ВыборкаСтрокТовары);
    ОбластьДанных.Параметры.Товар = СокрЛП(ВыборкаСтрокТовары.Товар);
    ТабДокумент.Присоединить(ОбластьДанных);

    ОбластьСуммы.Параметры.Заполнить(ВыборкаСтрокТовары);
    ТабДокумент.Присоединить(ОбластьСуммы);
    Сумма = Сумма + ВыборкаСтрокТовары.Сумма;
    СуммаНДС = СуммаНДС + ВыборкаСтрокТовары.СуммаНДС;

    КонецЦикла;

    // Вывести Итого
    ОбластьНомера = Макет.ПолучитьОбласть("Итого|НомерСтроки");
    ОбластьКодов = Макет.ПолучитьОбласть("Итого|КолонкаКодов");
    ОбластьДанных = Макет.ПолучитьОбласть("Итого|Данные");
    ОбластьСуммы = Макет.ПолучитьОбласть("Итого|Сумма");

    ТабДокумент.Вывести(ОбластьНомера);
    Если ВыводитьКоды Тогда
    ТабДокумент.Присоединить(ОбластьКодов);
    КонецЕсли;
    ТабДокумент.Присоединить(ОбластьДанных);
    ОбластьСуммы.Параметры.Всего = ОбщегоНазначения.ФорматСумм(Сумма);
    ТабДокумент.Присоединить(ОбластьСуммы);

    // Вывести ИтогоНДС
    ОбластьНомера = Макет.ПолучитьОбласть("ИтогоНДС|НомерСтроки");
    ОбластьКодов = Макет.ПолучитьОбласть("ИтогоНДС|КолонкаКодов");
    ОбластьДанных = Макет.ПолучитьОбласть("ИтогоНДС|Данные");
    ОбластьСуммы = Макет.ПолучитьОбласть("ИтогоНДС|Сумма");

    ТабДокумент.Вывести(ОбластьНомера);
    Если ВыводитьКоды Тогда
    ТабДокумент.Присоединить(ОбластьКодов);
    КонецЕсли;
    Если СуммаНДС <> 0 Тогда
    ОбластьДанных.Параметры.НДС = ?(Шапка.СуммаВключаетНДС, "В том числе НДС:", "Сумма НДС:");
    ОбластьСуммы.Параметры.ВсегоНДС = ОбщегоНазначения.ФорматСумм(СуммаНДС);
    Иначе
    ОбластьДанных.Параметры.НДС = "Без налога (НДС)";
    ОбластьСуммы.Параметры.ВсегоНДС = "-";
    КонецЕсли;
    ТабДокумент.Присоединить(ОбластьДанных);

    ТабДокумент.Присоединить(ОбластьСуммы);

    // Вывести ИтогоКОплате
    ОбластьНомера = Макет.ПолучитьОбласть("ИтогоКОплате|НомерСтроки");
    ОбластьКодов = Макет.ПолучитьОбласть("ИтогоКОплате|КолонкаКодов");
    ОбластьДанных = Макет.ПолучитьОбласть("ИтогоКОплате|Данные");
    ОбластьСуммы = Макет.ПолучитьОбласть("ИтогоКОплате|Сумма");
    ТабДокумент.Вывести(ОбластьНомера);
    Если ВыводитьКоды Тогда
    ТабДокумент.Присоединить(ОбластьКодов);
    КонецЕсли;
    ТабДокумент.Присоединить(ОбластьДанных);
    СуммаКОплате = Сумма + ?(Шапка.СуммаВключаетНДС, 0, СуммаНДС);
    ОбластьСуммы.Параметры.ИтогоКОплате = ОбщегоНазначения.ФорматСумм(СуммаКОплате);
    ТабДокумент.Присоединить(ОбластьСуммы);

    // Вывести Сумму прописью
    ОбластьМакета = Макет.ПолучитьОбласть("СуммаПрописью");
    СуммаКПрописи = Сумма + ?(Шапка.СуммаВключаетНДС, 0, СуммаНДС);
    ОбластьМакета.Параметры.ИтоговаяСтрока ="Всего наименований " + ЗапросТовары.Количество()
    + ", на сумму " + ОбщегоНазначения.ФорматСумм(СуммаКПрописи, Шапка.ВалютаДокумента);
    ОбластьМакета.Параметры.СуммаПрописью = ОбщегоНазначения.СформироватьСуммуПрописью(СуммаКПрописи, Шапка.ВалютаДокумента);
    ТабДокумент.Вывести(ОбластьМакета);

    //Вывести подписи
    //Если Тип = "Счет" Тогда

    // --------------Запрос для примечания---------------------//
    ЗапросПрим=Новый запрос;
    ЗапросПрим.УстановитьПараметр("ВыбДата", СсылкаНаОбъект.Дата);
    ЗапросПрим.УстановитьПараметр("ВыбОрг", СсылкаНаОбъект.Организация);
    ЗапросПрим.Текст =
    "ВЫБРАТЬ
    | УчетнаяПолитикаОрганизацийСрезПоследних.УведомлениеДата,
    | УчетнаяПолитикаОрганизацийСрезПоследних.УведомлениеНомер
    |ИЗ
    | РегистрСведений.УчетнаяПолитикаОрганизаций.СрезПоследних(&ВыбДата, Организация = &ВыбОрг) КАК УчетнаяПолитикаОрганизацийСрезПоследних" ;

    Примечание = ЗапросПрим.Выполнить().Выбрать();
    Примечание.Следующий();
    ОбластьМакета = Макет.ПолучитьОбласть("Примечание");
    ОбластьМакета.Параметры.Дата = Примечание.УведомлениеДата;
    ОбластьМакета.Параметры.Номер = Примечание.УведомлениеНомер;
    ТабДокумент.Вывести(ОбластьМакета);

    //---------------------Конец запроса------------------------//


    Если Шапка.Получатель.ЮрФизЛицо = Перечисления.ЮрФизЛицо.ЮрЛицо Тогда
    ОбластьМакета = Макет.ПолучитьОбласть("ПодвалСчета");

    Руководители = ОбщегоНазначения.ОтветственныеЛица(Шапка.Руководители, Шапка.Дата, ПодразделениеОтветственныхЛиц);
    Руководитель = Руководители.РуководительПредставление;
    Бухгалтер = Руководители.ГлавныйБухгалтерПредставление;

    ОбластьМакета.Параметры.ФИОРуководителя = Руководитель;
    ОбластьМакета.Параметры.ФИОБухгалтера = Бухгалтер;

    Иначе
    ОбластьМакета = Макет.ПолучитьОбласть("ПодвалСчетаПредприниматель");

    ФЛ = Шапка.Получатель.ИндивидуальныйПредприниматель;
    ДанныеФЛ = РегистрыСведений.ФИОФизЛиц.СрезПоследних(СсылкаНаОбъект.Дата, Новый Структура("ФизЛицо",ФЛ));
    Если ДанныеФЛ.Количество() > 0 Тогда
    Предприниматель = СокрЛП(ДанныеФЛ[0].Фамилия) + " " + Лев(СокрЛП(ДанныеФЛ[0].Имя),1) + ". " + Лев(СокрЛП(ДанныеФЛ[0].Отчество),1) + ".";
    Иначе
    Предприниматель = "";
    КонецЕсли;

    ОбластьМакета.Параметры.ФИОПредпринимателя = Предприниматель;

    КонецЕсли;

    //Иначе
    //ОбластьМакета = Макет.ПолучитьОбласть("ПодвалЗаказа");
    //КонецЕсли;
    ОбластьМакета.Параметры.Заполнить(Шапка);
    ТабДокумент.Вывести(ОбластьМакета);


    Возврат ТабДокумент;



    КонецФункции // ПечатьСчета()


    Функция Печать() экспорт;

    ТабДокумент = ПечатьСчета();
    Возврат ТабДокумент;

    КонецФункции // Печать()


    #КонецЕсли
  11. alexburn
    Online

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Задайте другой псевдоним для Документ.СчетНаОплатуПокупателю для таб.частей Услуги и Товары
  12. TopicStarter Overlay
    max805
    Offline

    max805

    Регистрация:
    18 дек 2007
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Это как? Я не кодер и писать не умею. я сисадмин. можете поподробнее пожалуйста
  13. alexburn
    Online

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Если не кодер, то может обратиться в спец. отдел, для фриланса ? Не стоит отбирать хлеб :)
  14. TopicStarter Overlay
    max805
    Offline

    max805

    Регистрация:
    18 дек 2007
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Обратился бы. Если бы мой начальник бы выделил бы на это средства. а так вышло что дал задние а дальше е**сь сам(( и у самого с финансами напряг
  15. alexburn
    Online

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Такая ошибка получается в результате выборок из ТЧ, в вашем случае это Услуги и Товары.
  16. TopicStarter Overlay
    max805
    Offline

    max805

    Регистрация:
    18 дек 2007
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Если вам не сложно можете подключится по тиму и посмотреть?
  17. alexburn
    Online

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Извиняйте:), но не могу:)
  18. TopicStarter Overlay
    max805
    Offline

    max805

    Регистрация:
    18 дек 2007
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    спасибо. буду искать того кто может
  19. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Так попробуйте:
    Код:
    ЧастьЗапросаДляВыбораСодержанияУслуг = ФормированиеПечатныхФорм.ПолучитьЧастьЗапросаДляВыбораСодержанияУслуг("СчетНаОплату");
    
    Запрос.Текст =
    "ВЫБРАТЬ
    | ВложенныйЗапрос.Номенклатура КАК Номенклатура,
    | ВЫРАЗИТЬ(ВложенныйЗапрос.Номенклатура.НаименованиеПолное КАК Строка(1000)) КАК Товар,
    | ВложенныйЗапрос.Номенклатура.Код КАК Код,
    | ВложенныйЗапрос.Номенклатура.Артикул КАК Артикул,
    | ВложенныйЗапрос.Количество,
    | ВложенныйЗапрос.ЕдиницаИзмерения,
    | ВложенныйЗапрос.Цена,
    | ВложенныйЗапрос.Сумма,
    | ВложенныйЗапрос.СуммаНДС,
    | ВложенныйЗапрос.НомерСтроки КАК НомерСтроки,
    | 1 КАК ID
    |ИЗ
    | (ВЫБРАТЬ
    | СчетНаОплату.Номенклатура КАК Номенклатура,
    | СчетНаОплату.Номенклатура.БазоваяЕдиницаИзмерения.Наименование КАК ЕдиницаИзмерения,
    | СчетНаОплату.Цена КАК Цена,
    | СУММА(СчетНаОплату.Количество) КАК Количество,
    | СУММА(СчетНаОплату.Сумма) КАК Сумма,
    | СУММА(СчетНаОплату.СуммаНДС) КАК СуммаНДС,
    | МИНИМУМ(СчетНаОплату.НомерСтроки) КАК НомерСтроки
    | ИЗ
    | Документ.СчетНаОплатуПокупателю.Товары КАК СчетНаОплату
    |
    | ГДЕ
    | СчетНаОплату.Ссылка = &ТекущийДокумент
    |
    | СГРУППИРОВАТЬ ПО
    | СчетНаОплату.Номенклатура,
    | СчетНаОплату.Номенклатура.БазоваяЕдиницаИзмерения.Наименование,
    | СчетНаОплату.Цена) КАК ВложенныйЗапрос
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ
    | " + ЧастьЗапросаДляВыбораСодержанияУслуг + ",
    | " + ЧастьЗапросаДляВыбораСодержанияУслуг + ",
    | СчетНаОплату.Номенклатура.Код КАК Код,
    | СчетНаОплату.Номенклатура.Артикул КАК Артикул,
    | СчетНаОплату.Количество,
    | СчетНаОплату.Номенклатура.БазоваяЕдиницаИзмерения.Наименование,
    | СчетНаОплату.Цена,
    | СчетНаОплату.Сумма,
    | СчетНаОплату.СуммаНДС,
    | СчетНаОплату.НомерСтроки,
    | 2
    |ИЗ
    | Документ.СчетНаОплатуПокупателю.Услуги КАК СчетНаОплату
    |
    |ГДЕ
    | СчетНаОплату.Ссылка = &ТекущийДокумент
    |
    |УПОРЯДОЧИТЬ ПО
    | ID,
    | НомерСтроки";
  20. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.980
    Симпатии:
    398
    Баллы:
    104
    Проверьте личку чтоли уже.

Поделиться этой страницей