8.х Помогите пожалуйста найти решение по ошибке

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем sergnikel, 26 апр 2012.

  1. TopicStarter Overlay
    sergnikel
    Offline

    sergnikel

    Регистрация:
    26 апр 2012
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    При проведении документа "перемещение товаров" в УТ - выдаёт ошибку : склад не является основным.
    Выходит такая ошибка
    ------------{Справочник.Склады.Форма.ФормаВыбора(113)}: Ошибка при установке значения атрибута контекста (ТекущаяСтрока): Отсутствует ключ строки
    ЭлементыФормы.ВладельцыСписок.ТекущаяСтрока = СтрокаМагазины.Строки.Найти(НачальноеЗначениеВыбора.Магазин); ------------
    Т.е. эту ошибку выдаёт при выборке склада.


    Код:
    Процедура ПриОткрытии()
    //Закрывает открытые формы списка складов
    ФормаСпискаСклады = Справочники.Склады.ПолучитьФормуСписка();
    Если ФормаСпискаСклады.Открыта() Тогда
    ФормаСпискаСклады.Закрыть();
    КонецЕсли;
    мВладелецФормы = ВладелецФормы;
    ВладелецФормы  = Неопределено;
    ОбновитьВладельцыСписок();
    Если ЗначениеЗаполнено(МагазинДляОтбора) Тогда
    ТекущаяСтрока = РаботаСДиалогами.НайтиТекущуюСтрокуВДеревеВладельцыСписок(МагазинДляОтбора, ВладельцыСписок);
    Если ТекущаяСтрока <> Неопределено Тогда
    ЭлементыФормы.ВладельцыСписок.ТекущаяСтрока = ТекущаяСтрока;
    КонецЕсли;
    ЭлементыФормы.ПанельДереваМагазинов.УстановитьПривязку(ГраницаЭлементаУправления.Право);
    ЭлементыФормы.Разделитель1.УстановитьПривязку(ГраницаЭлементаУправления.Лево, ЭлементыФормы.ПанельДереваМагазинов, ГраницаЭлементаУправления.Право);
    ЭлементыФормы.Разделитель1.УстановитьПривязку(ГраницаЭлементаУправления.Право, ЭлементыФормы.ПанельДереваМагазинов, ГраницаЭлементаУправления.Право);
    ЭлементыФормы.СправочникСписок.УстановитьПривязку(ГраницаЭлементаУправления.Лево, ЭлементыФормы.ПанельДереваМагазинов, ГраницаЭлементаУправления.Право);
    ЭлементыФормы.ПанельДереваМагазинов.Свертка = РежимСверткиЭлементаУправления.Лево;
    КонецЕсли;
    Если ЗначениеЗаполнено(НачальноеЗначениеВыбора) Тогда
    Если НачальноеЗначениеВыбора.ТипСклада = Перечисления.ТипыСкладов.СкладЦентральногоОфиса Тогда
    ЭлементыФормы.ВладельцыСписок.ТекущаяСтрока = ВладельцыСписок.Строки.Найти("Центральный офис");
    Иначе
    СтрокаМагазины = ВладельцыСписок.Строки.Найти("Магазины");
    Если Не СтрокаМагазины = Неопределено Тогда
    ЭлементыФормы.ВладельцыСписок.ТекущаяСтрока = СтрокаМагазины.Строки.Найти(НачальноеЗначениеВыбора.Магазин);
    КонецЕсли;
    КонецЕсли;
    ЭлементыФормы.СправочникСписок.ТекущаяСтрока = НачальноеЗначениеВыбора;
    Иначе
    Если Не ЗначениеЗаполнено(МагазинДляОтбора) Тогда
    ТекущееЗначение = ВосстановитьЗначение("СправочникСклады_ФормаВыбора_ВладельцыСписок_ТекущаяСтрока");
    ТекущаяСтрока   = РаботаСДиалогами.НайтиТекущуюСтрокуВДеревеВладельцыСписок(ТекущееЗначение, ВладельцыСписок);
    Если Не ТекущаяСтрока = Неопределено Тогда
    ЭлементыФормы.ВладельцыСписок.ТекущаяСтрока = ТекущаяСтрока;
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры
  2. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    Точный релиз конфы [ver1C]
    Конфа дописана?
  3. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    говорите при выборе склада, а процедура ПриОткрытии()??? поставьте недалеко от строки с ошибкой точку останова и запустите отладчик, посмотрите что попадает в значение переменных.
  4. TopicStarter Overlay
    sergnikel
    Offline

    sergnikel

    Регистрация:
    26 апр 2012
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    благодарю за помощь, разобрались!

Поделиться этой страницей