8.х помогите новичку

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем phantomedy, 6 фев 2013.

  1. TopicStarter Overlay
    phantomedy
    Offline

    phantomedy

    Регистрация:
    6 фев 2013
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    есть текстовый документ, там вот такие строки:

    НазначениеПлатежа=Оплата за товар по акту сверки на 09.01.2013г
    В т.ч.НДС(10%) 2727-27.


    из этих строк надо сделать одну тоесть вот так:

    НазначениеПлатежа=Оплата за товар по акту сверки на 09.01.2013г В т.ч.НДС(10%) 2727-27.

    тоесть убрать энтер со второй строки чтобы получилась одна строка
  2. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    В документе найти по ASCII коду знак перевода строки и удалить его
  3. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    а если так попробовать
    Код:
    стр = СтрЗаменить(стр, символы.ПС, " ");
    
    
  4. TopicStarter Overlay
    phantomedy
    Offline

    phantomedy

    Регистрация:
    6 фев 2013
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    дак я внешнюю обработку делаю, там таких строк много будет
    протсто надо програмно прописать обьединить одну строку со след , а как сделать незнаю
  5. TopicStarter Overlay
    phantomedy
    Offline

    phantomedy

    Регистрация:
    6 фев 2013
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    я тоже так думал а как указать нужную строку которую заменить
  6. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    посмотрите в синтаксис-помошнике как работает функция СтрЗаменить. Она не одну конструкцию заменить, а все найденные.
    З.Ы. как поставили задачу, такое решение и предложено. Вам надо чтоб только у этой строки убрался Энтер или как? давайте всю задачу тогда
  7. TopicStarter Overlay
    phantomedy
    Offline

    phantomedy

    Регистрация:
    6 фев 2013
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    ПотокЧтенияНовый = Новый ТекстовыйДокумент();

    Для Ик=1 по ПотокЧтения.КоличествоСтрок() цикл
    СтрокаФайла = ПотокЧтения.ПолучитьСтроку(ик);
    Если Лев(СтрокаФайла,19)<>"НазначениеПлатежа1=" тогда
    ПотокЧтенияНовый.ДобавитьСтроку(СтрокаФайла);
    КонецЕсли;

    //Алгоритм как исправить ошибку и потом записать


    КонецЦикла;

    вообщем задача такая у меня есть файл и в некоторый строках добавле лишнии энтер чтоб человек руками этот энтер не убирал я пишу внешнюю обработку. энтер надо убрать только в определеной строке
  8. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    ну может вот так попробовать

    Код:
    ПотокЧтенияНовый = Новый ТекстовыйДокумент();
    //Для Ик=1 по ПотокЧтения.КоличествоСтрок() цикл
    Ик = 1;
    максИк = Потокчтения.КоличествоСтрок();
    Пока Ик < максИк Цикл
    СтрокаФайла = ПотокЧтения.ПолучитьСтроку(ик);
    Если Лев(СтрокаФайла,19)="НазначениеПлатежа1=" тогда
    СтрокаФайла = СтрокаФайла + ПотокЧтения.ПолучитьСтроку(ик+1);
    ик = ик + 1;
    СтрокаФайла = СтрЗаменить(СтрокаФайла, Символы.ПС, " ");
    КонецЕсли;
    ПотокЧтенияНовый.ДобавитьСтроку(СтрокаФайла);
    ик = ик + 1;
    КонецЦикла;
    вот только сдается мне, что если вот так вторую строку сразу считать и добавить к первой, то получится сразу одна строка. Это можно в отладчике посмотреть
  9. TopicStarter Overlay
    phantomedy
    Offline

    phantomedy

    Регистрация:
    6 фев 2013
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    щас гляну попробую
  10. TopicStarter Overlay
    phantomedy
    Offline

    phantomedy

    Регистрация:
    6 фев 2013
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    все спасибо помогло, нажал спасибо))
Похожие темы
  1. memphisto
    Ответов:
    1
    Просмотров:
    1.077
Загрузка...

Поделиться этой страницей