8.х Помогите новичку с строками спика!

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем BoryaPOC, 3 авг 2012.

  1. TopicStarter Overlay
    BoryaPOC
    Offline

    BoryaPOC

    Регистрация:
    3 авг 2012
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Есть Справочник "Автокомплекты" в нем есть реквизит "НаименованиякомплектаЗЧ". Табличная часть состоит из двух реквизитов "запчасть" и "Производитель". Есть форма елемента и есть форма списка. Форма списка это дерево групп и елементов списка, справа СправочникСписок. Нужно сделать так чтобы в строках списка справочника выделялись жырным шрифтом те записи табличная часть которых заполнена. ПОМОГИТЕ очент надо.!!!
  2. vartanet
    Offline

    vartanet Опытный в 1С Команда форума

    Регистрация:
    16 ноя 2010
    Сообщения:
    2.698
    Симпатии:
    15
    Баллы:
    29
    я б добавил доп реквизит в шапку справочника "табличная часть заполнена", которую бы заполнял перед записью элемента.

    потом "при выводе строк табличного поля" или "при получении данных" менял бы шрифт на жирный, в засисимости от этого реквизита.
  3. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    Укажите платформу, которую изменяете, управляемой приложение или обычное...
  4. TopicStarter Overlay
    BoryaPOC
    Offline

    BoryaPOC

    Регистрация:
    3 авг 2012
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Спасибо! Я понял логику. Главное чтобы это работало в том случае если в табличной части более 10 000 запсией и в программе работают одновременно более 10 людей. Если не трудно можно код как именно меняеться шрифт.

    обычное.
  5. vartanet
    Offline

    vartanet Опытный в 1С Команда форума

    Регистрация:
    16 ноя 2010
    Сообщения:
    2.698
    Симпатии:
    15
    Баллы:
    29
    вот пример при выводе строки:


    Код:
    Процедура РасчетПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    
    Если ДанныеСтроки.Номенклатура.ЭтоГруппа Тогда
    ОформлениеСтроки.ЦветФона   = Новый Цвет(204,255,255);
    ОформлениеСтроки.Шрифт   = Новый Шрифт(ОформлениеСтроки.Шрифт,,,истина)
    КонецЕсли;
    
    КонецПроцедуры
    вот пример при получении данных:


    Код:
    Процедура ТоварыПриПолученииДанных(Элемент, ОформленияСтрок)
    
    Для каждого ОформлениеСтроки Из ОформленияСтрок Цикл
    
    НомерМаксимум = ОформлениеСтроки.ДанныеСтроки.НомерСобственныйМаксимальный;
    НомерМинимум = ОформлениеСтроки.ДанныеСтроки.НомерМинимальный;
    
    Если НомерМинимум<>0 Тогда
    ОформлениеСтроки.Ячейки["Количество"+НомерМинимум].ЦветФона = Новый Цвет(0,255,0);
    КонецЕсли;
    
    Если НомерМаксимум<>0 Тогда
    ОформлениеСтроки.Ячейки["Количество"+НомерМаксимум].ЦветФона = Новый Цвет(255,255,0);
    КонецЕсли;
    
    КонецЦикла
    
    КонецПроцедуры
    "при получении данных" будет быстрее работать..
  6. TopicStarter Overlay
    BoryaPOC
    Offline

    BoryaPOC

    Регистрация:
    3 авг 2012
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    А как проверить заполнина ли табличная часть?
  7. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    Таблица.Количество() >0 то заполнена
  8. blackout
    Offline

    blackout Опытный в 1С

    Регистрация:
    23 янв 2013
    Сообщения:
    58
    Симпатии:
    0
    Баллы:
    26
    Где вы берете эти ПриПолученииДанных и ПриВыводеСтроки?
    У меня среди стандартных процедур в модуле формы их нет, как и в модуле объекта :(
    Так и не понял, могу ли я сделать в обычной форме списка отображения строк разным цветом, в зависимости от их наполнения?
  9. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    В свойствах табличного поля ищите.
    Посмотреть вложение 13806

    Вложения:

    • e0001.png
      e0001.png
      Размер файла:
      19,4 КБ
      Просмотров:
      10
  10. blackout
    Offline

    blackout Опытный в 1С

    Регистрация:
    23 янв 2013
    Сообщения:
    58
    Симпатии:
    0
    Баллы:
    26
    Оххххх.... мне казалось я и туда 50 раз заходил))
    Спасибо большое, увидел))

Поделиться этой страницей