8.х Помогите новенькому!

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем mari8998, 6 ноя 2007.

  1. TopicStarter Overlay
    mari8998
    Offline

    mari8998

    Регистрация:
    31 окт 2007
    Сообщения:
    30
    Симпатии:
    0
    Баллы:
    1
    Код:
    ТабДок = Новый ТабличныйДокумент;  
    Макет = ПолучитьМакет("ТабличныйДокумент1");
    Шапка = Макет.ПолучитьОбласть("Шапка");
    ТабДок.Очистить();
    ТабДок.Вывести(Шапка);
    Строка = Макет.ПолучитьОбласть("Строка");
    Для  Каждого ТекущаяСтрока   Из  ЭлементыФормы.ТабличноеПоле1.Значение  Цикл
    СтрокаТаблицы=ЭлементыФормы.ТабличноеПоле1.ТекущаяСтрока;
    ФИО=СтрокаТаблицы.Колонка1;
    Строка.Параметры.ФИО = ФИО;
    ТабДок.Вывести(Строка);
    КонецЦикла;
    ТабДок.Автомасштаб             =     Истина;
    ТабДок.ОриентацияСтраницы     =     ОриентацияСтраницы.Портрет;
    ТабДок.ТолькоПросмотр        =     Истина;
    ТабДок.Показать();
    
    В форме 2 строки с двумя фамилиями , а на печать 2 раза выводит вторую фамилию . Подскажите ,где ошибка. :unsure: B)

    Используйте тэг
    Код:
    [/color]
  2. Эмин
    Offline

    Эмин Руководитель проектов

    Регистрация:
    25 май 2007
    Сообщения:
    1.178
    Симпатии:
    1
    Баллы:
    26
    Код:
    // Опустим лишнее
    Строка = Макет.ПолучитьОбласть("Строка");
    Для  Каждого Стр Из ЭлементыФормы.ТабличноеПоле1 Цикл
    ФИО=Стр.Колонка1;
    Строка.Параметры.ФИО = ФИО;
    ТабДок.Вывести(Строка);
    КонецЦикла;
    // Опустим лишнее
    
    
    Проблема в том, что текущая строка не меняется - она в форме так и остается как активная строка, цикл вы делаете правильно, но присваивать не надо - так к Стр (у меня, а у вас счетчик цикла ТекущаяСтрока) и обращайтесь - не присваивайте лишнего.
  3. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Код:
    Для  Каждого ТекущаяСтрока   Из  ЭлементыФормы.ТабличноеПоле1.Значение  Цикл
    СтрокаТаблицы=ЭлементыФормы.ТабличноеПоле1.ТекущаяСтрока;
    ФИО=СтрокаТаблицы.Колонка1;
    Строка.Параметры.ФИО = ФИО;
    ТабДок.Вывести(Строка);
    КонецЦикла;
    
    
    Здесь ошибка :)
Похожие темы
  1. mari8998
    Ответов:
    1
    Просмотров:
    1.038
  2. thankyou
    Ответов:
    1
    Просмотров:
    397
Загрузка...

Поделиться этой страницей