8.х Помогите написать процедуру

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Panchos, 7 фев 2007.

  1. TopicStarter Overlay
    Panchos
    Offline

    Panchos Опытный в 1С

    Регистрация:
    27 окт 2006
    Сообщения:
    101
    Симпатии:
    0
    Баллы:
    26
    Я написал процедуру, которая перебирае договора контрагентов. Но при запуске выдаёт ошибку

    Вот сама процедура,что в ней не так

    Код:
    Процедура    ПереборДоговоров    (Кнопка)
    
    ВыбДоговора    =    Справочники.ДоговорыКонтрагентов;    
    
    СпрВыборка    =    Справочники.Контрагенты;
    
    Запрос    =    Новый    Запрос("
    |ВЫБРАТЬ
    |       ДоговорыКонтрагентов.Владелец    КАК        Владелец,
    |        ДоговорыКонтрагентов.Код        КАК        Код
    |ИЗ    
    |          Справочник.ДоговорыКонтрагентов        КАК        ДоговорыКонтрагентов
    |ГДЕ
    |       ДоговорыКонтрагентов.Владелец    =    &Владелец    
    |Упорядочить ПО Код Возр ");
    
    Запрос.УстановитьПараметр("Владелец",    ВыбДоговора);
    
    СпрВыборка    =    Запрос.Выполнить().Выбрать();
    
    Пока    СпрВыборка.Следующий()    Цикл
    
    СпрДоговор        =    Справочники.ДоговорыКонтрагентов.Выбрать();
    
    Пока    СпрДоговор.Следующий()    Цикл
    
    Сообщить("Договор:    "+СпрДоговор.ВидДоговора+"    Код:    "+СпрДоговор.Код+"    Контрагент:    "+СпрДоговор.Владелец);                 
    
    КонецЦикла;
    
    
    
    ОбработкаПрерыванияПользователя();
    
    КонецЦикла;
    
    КонецПроцедуры
    
  2. TopicStarter Overlay
    Panchos
    Offline

    Panchos Опытный в 1С

    Регистрация:
    27 окт 2006
    Сообщения:
    101
    Симпатии:
    0
    Баллы:
    26
    Вопрос снимается. Разобрался

Поделиться этой страницей