8.х Помогите найти ошибку!

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Сандра, 17 июл 2012.

  1. TopicStarter Overlay
    Сандра
    Offline

    Сандра Опытный в 1С

    Регистрация:
    5 июл 2010
    Сообщения:
    76
    Симпатии:
    0
    Баллы:
    26
    Доброе время суток!
    Для переноса данных между конфигурациями написала обработку:

    Код:
    КолВо=ХВ.КоличествоЗаписей();
    ХВ.Первая();
    для а=1 по КолВо Цикл 
    ОбработкаПрерыванияПользователя();
    
    Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ
    | СерииНоменклатуры.Владелец,
    | СерииНоменклатуры.Наименование,
    | СерииНоменклатуры.СрокГодности,
    | СерииНоменклатуры.НомерГТД,
    | СерииНоменклатуры.СтранаПроисхождения,
    | СерииНоменклатуры.Сертификат
    |ИЗ
    | Справочник.СерииНоменклатуры КАК СерииНоменклатуры
    |ГДЕ
    | СерииНоменклатуры.Владелец.Наименование = &Владелец
    | И СерииНоменклатуры.Наименование = &Наименование
    |";
    
    Запрос.УстановитьПараметр("Владелец",СокрЛП(ХВ.vlad));
    Запрос.УстановитьПараметр("Наименование",СокрЛП(ХВ.naim));
    
    Выборка = Запрос.Выполнить().Выбрать();
    
    Если  Выборка.Количество()>0 Тогда
    Пока Выборка.Следующий() Цикл
    Если  Лев(Строка(Выборка.СрокГодности),10)= СокрЛП(ХВ.sgodn) Тогда
    Если Выборка.Сертификат="" Тогда
    Объект=Выборка.ПолучитьОбъект();  // выдается ошибка - метод отсутствует.
    Объект.Сертификат=ХВ.sertif;
    Объект.Записать();
    конецЕсли;
    конецЕсли;		 
    КонецЦикла;
    Иначе
    Сообщить(СокрЛП(ХВ.vlad)+"   Нет данных для записи!");
    КонецЕсли;
    
    ХВ.Следующая();
    КонецЦикла;

    Подскажите, пожалуйста, в чем здесь ошибка. Что не так?
  2. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.979
    Симпатии:
    397
    Баллы:
    104
    Потому что необходимо указать объект. А Вы просто пытаетесь из выборки получить объект.
    Не так:
    Код:
    Объект=Выборка.ПолучитьОбъект();
    А так
    Код:
    Объект=Выборка.Ссылка.ПолучитьОбъект();
    Только в запросе не забудьте ссылку добавить
  3. TopicStarter Overlay
    Сандра
    Offline

    Сандра Опытный в 1С

    Регистрация:
    5 июл 2010
    Сообщения:
    76
    Симпатии:
    0
    Баллы:
    26
    Спасибо большое!! Весь день убила на поиск ошибки! Сама ведь знаю, а зарапортовалась! Видать 40 градусная жара мозги плавит!

Поделиться этой страницей