8.х Помогите код на 7.7 перевести на 8.1

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем 1Cnica, 25 мар 2009.

  1. TopicStarter Overlay
    1Cnica
    Offline

    1Cnica Опытный в 1С

    Регистрация:
    13 фев 2009
    Сообщения:
    416
    Симпатии:
    0
    Баллы:
    26
    Код:
    Процедура Сформировать()
    
    Доки=СоздатьОбъект( "Документ" );
    Доки.ВыбратьДокументы( Дата1, Дата2 );
    .....
    КонецПроцедуры
    

    с помощью Метаданных что ли?
  2. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    Ну это простая выборка документов. Если у тебя фиксированные значения используй просто метод выбрать.
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    И "Новый" вместо СоздатьОбъект
  4. TopicStarter Overlay
    1Cnica
    Offline

    1Cnica Опытный в 1С

    Регистрация:
    13 фев 2009
    Сообщения:
    416
    Симпатии:
    0
    Баллы:
    26
    в СП есть пример, но там Выбрать() только для конкретного дока, а мне надо чтобы был перебор всех доков


    вернее для списка доков одного вида
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Новый("Документ") - неопределенного типа
  6. TopicStarter Overlay
    1Cnica
    Offline

    1Cnica Опытный в 1С

    Регистрация:
    13 фев 2009
    Сообщения:
    416
    Симпатии:
    0
    Баллы:
    26
    ошибку выдает

    Вложения:

    • тупо.JPG
      тупо.JPG
      Размер файла:
      78,3 КБ
      Просмотров:
      24
  7. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    А код можно посмотреть?
  8. GvH
    Offline

    GvH Опытный в 1С

    Регистрация:
    12 авг 2008
    Сообщения:
    179
    Симпатии:
    0
    Баллы:
    26
    Код:
    МногоДокументов = Метаданные.Документы;
    
    
  9. TopicStarter Overlay
    1Cnica
    Offline

    1Cnica Опытный в 1С

    Регистрация:
    13 фев 2009
    Сообщения:
    416
    Симпатии:
    0
    Баллы:
    26
    дык особо и смотреть-то нечего (
    Код:
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    //Доки = Метаданные.Документы;
    д = Новый ("Документ");
    
    
    КонецПроцедуры
    
    хорошо, а дальше что делать с МногоДокументов? у него тип Неопределено
  10. GvH
    Offline

    GvH Опытный в 1С

    Регистрация:
    12 авг 2008
    Сообщения:
    179
    Симпатии:
    0
    Баллы:
    26
    Ну здрасьте... Неопределено.
    У него тип КоллекцияОбъектовМетаданных.

    Поэтому
    Код:
    Для Каждого ОдинДокумент Из МногоДокументов Цикл
    ИмяДок = ОдинДокумент.Имя;
    СсылкаНаДок = Документы[ИмяДок];
    КонецЦикла;
    
    
    
    Как-то так.

    Где СсылкаНаДок тип... ДокументМенеджер.

    Где потом...
    Код:
    СсылкаНаДок .Выбрать();
    
    
    
    Ну что и требовалась.. собственно в посте № 1.
  11. TopicStarter Overlay
    1Cnica
    Offline

    1Cnica Опытный в 1С

    Регистрация:
    13 фев 2009
    Сообщения:
    416
    Симпатии:
    0
    Баллы:
    26
    что-то типа такого должно получица?


    Код:
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    до = Метаданные.Документы;
    Для Каждого ОдинДокумент Из МногоДокументов Цикл    
    ИмяДок = ОдинДокумент.Имя;    
    СсылкаНаДок = Документы[ИмяДок];
    КонецЦикла;
    СсылкаНаДок.Выбрать();
    
    
    КонецПроцедуры
    
  12. GvH
    Offline

    GvH Опытный в 1С

    Регистрация:
    12 авг 2008
    Сообщения:
    179
    Симпатии:
    0
    Баллы:
    26
    Блина... типа так:
    Код:
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    МногоДокументов = Метаданные.Документы;
    Для Каждого ОдинДокумент Из МногоДокументов Цикл    
    ИмяДок = ОдинДокумент.Имя;    
    СсылкаНаДок = Документы[ИмяДок];
    СсылкаНаДок.Выбрать();
    КонецЦикла;
    КонецПроцедуры
    
    
  13. TopicStarter Overlay
    1Cnica
    Offline

    1Cnica Опытный в 1С

    Регистрация:
    13 фев 2009
    Сообщения:
    416
    Симпатии:
    0
    Баллы:
    26
    спасибо :unsure:

Поделиться этой страницей