7.7 Помогите исправить ошибку при выводе счет-фактуры

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем НатахаБ, 14 мар 2007.

  1. TopicStarter Overlay
    НатахаБ
    Offline

    НатахаБ Опытный в 1С

    Регистрация:
    24 янв 2007
    Сообщения:
    92
    Симпатии:
    0
    Баллы:
    26
    При выводе на печать счет фактуры система выдает ошибку: Таб.ВывестСекцию ("Дополн")
    {Документ.СчетФактура.Форма.Модуль (1213)}. В чем может быть причина этого "ругательства".
    P.S. Другие счет фактуры выводятся без ошибок
  2. Tiger
    Offline

    Tiger Опытный в 1С

    Регистрация:
    12 июл 2006
    Сообщения:
    489
    Симпатии:
    0
    Баллы:
    26
    Ну вообще то уже здесь видно синтаксическую ошибку
  3. TopicStarter Overlay
    НатахаБ
    Offline

    НатахаБ Опытный в 1С

    Регистрация:
    24 янв 2007
    Сообщения:
    92
    Симпатии:
    0
    Баллы:
    26
    Опечатка. Другие же нормально выводятся. Может быть другое?
  4. Tiger
    Offline

    Tiger Опытный в 1С

    Регистрация:
    12 июл 2006
    Сообщения:
    489
    Симпатии:
    0
    Баллы:
    26
    А что ещё пишет? После номера строки....
  5. TopicStarter Overlay
    НатахаБ
    Offline

    НатахаБ Опытный в 1С

    Регистрация:
    24 янв 2007
    Сообщения:
    92
    Симпатии:
    0
    Баллы:
    26
    Все больше нечего.
  6. Tiger
    Offline

    Tiger Опытный в 1С

    Регистрация:
    12 июл 2006
    Сообщения:
    489
    Симпатии:
    0
    Баллы:
    26
    Какая конфигурация? Бухгалтерия, Торговля?
  7. TopicStarter Overlay
    НатахаБ
    Offline

    НатахаБ Опытный в 1С

    Регистрация:
    24 янв 2007
    Сообщения:
    92
    Симпатии:
    0
    Баллы:
    26
    Бухгалтерия 7.7 релиз 486
  8. Tiger
    Offline

    Tiger Опытный в 1С

    Регистрация:
    12 июл 2006
    Сообщения:
    489
    Симпатии:
    0
    Баллы:
    26
    Нет в типовой конфигурации секции "Дополн". Вероятно вам её дописывали для вывода чего то там.
    Давайте сюда текст процедуры Печать()
  9. TopicStarter Overlay
    НатахаБ
    Offline

    НатахаБ Опытный в 1С

    Регистрация:
    24 янв 2007
    Сообщения:
    92
    Симпатии:
    0
    Баллы:
    26
    Код:
     // Печать()
    //
    // Вызывается из формул элементов диалога:
    //  Кнопка "Печать".
    //
    // Описание:
    //  Формирует и таблицу печатной формы документа.
    //
    Процедура Печать()
    
    НомерДокПечатнойФормы = глПреобразоватьНомерДок(НомерДок, 0, 0);
    
    // В зависимости от даты документа используются разные шаблоны печатной формы.
    // При наличии в каталоге информационной базы файла с именем
    // "ExtFormsPrnFormscbsf*.mxl", будет использоваться шаблон печатной формы
    // размещенный в данном файле.
    Таб = СоздатьОбъект("Таблица");
    Если ДатаДок >= '30.05.2006' Тогда
    ИмяФайлаПечатнойФормы = КаталогИБ() + "ExtFormsPrnFormscsf283_.mxl";
    ИмяТаблицы = "СФ283";
    ИначеЕсли ДатаДок >= '30.07.2002' Тогда
    ИмяФайлаПечатнойФормы = КаталогИБ() + "ExtFormsPrnFormscbsf84.mxl";
    ИмяТаблицы = "СФ84";
    
    ИначеЕсли ДатаДок >= '21.03.2001' Тогда
    ИмяФайлаПечатнойФормы = КаталогИБ() + "ExtFormsPrnFormscbsf189.mxl";
    ИмяТаблицы = "СФ189";
    
    Иначе
    ИмяФайлаПечатнойФормы = КаталогИБ() + "ExtFormsPrnFormscbsf.mxl";
    ИмяТаблицы = "Таблица";
    КонецЕсли;
    
    Если ФС.СуществуетФайл(ИмяФайлаПечатнойФормы) = 1 Тогда
    Таб.ИсходнаяТаблица(ИмяФайлаПечатнойФормы);
    Иначе
    Таб.ИсходнаяТаблица(ИмяТаблицы);
    КонецЕсли;
    
    Если ВариантОтправки=1 Тогда
    ПечГрузоотправитель = "-----";
    ПечГрузополучатель = "-----";
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    Если ТипЗначенияСтр(Товар) = "Справочник" Тогда
    Если Товар.Вид() = "Номенклатура" Тогда
    Если (Товар.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Услуга) или
    (Товар.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Работа) или
    (Товар.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.ПосредническаяУслуга) или 
    (Товар.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.УслугаЕНВД) Тогда
    Продолжить;
    КонецЕсли;
    КонецЕсли;
    ПечГрузоотправитель = "Он же";
    ПечГрузополучатель = СокрП(Грузополучатель.ПолнНаименование)+", "+СокрП(Грузополучатель.ПочтовыйАдрес);
    Прервать;
    КонецЕсли;
    КонецЦикла;
    Иначе
    ПечГрузополучатель = СокрП(Грузополучатель.ПолнНаименование)+", "+СокрП(Грузополучатель.ПочтовыйАдрес);
    ПечГрузоотправитель = СокрП(Грузоотправитель.ПолнНаименование)+", "+СокрП(Грузоотправитель.ПочтовыйАдрес);
    КонецЕсли;
    
    // Определим валюту оплаты.
    ВалютаПечати = ?(Договор.ВалютаДоговора.Выбран() = 1, Договор.ВалютаДоговора, "руб.");
    Если Аванс = 1 Тогда
    Если Договор.ВалютаДоговора.Выбран() = 1 Тогда
    ВалютаПечати = ?(Договор.ОплатаДоговора <> 1, Договор.ВалютаДоговора, "руб.");
    КонецЕсли;
    КонецЕсли;
    
    Таб.ВывестиСекцию("Шапка");  
    
    // Печать строк документа.
    ВыбратьСтроки();
    Ном=0;
    Пока ПолучитьСтроку()=1 Цикл
    Ном=Ном+1;
    Если ТипЗначения(Товар) = 2 Тогда
    Наименование = Товар;
    ЕдиницаИзмерения = "";
    
    ИначеЕсли Товар.Вид() = "Номенклатура" Тогда
    Наименование = ?(ПустаяСтрока(Товар.ПолнНаименование)=1, Товар.Наименование, Товар.ПолнНаименование);
    ЕдиницаИзмерения = Товар.ЕдиницаИзмерения;
    
    ИначеЕсли Товар.Вид() = "ОсновныеСредства" Тогда
    Наименование = Товар.Наименование;
    ЕдиницаИзмерения = "";
    
    ИначеЕсли Товар.Вид() = "НематериальныеАктивы" Тогда
    Наименование = Товар.Наименование;
    ЕдиницаИзмерения = "";
    
    ИначеЕсли Товар.Вид() = "Материалы" Тогда
    Наименование = Товар.Наименование;
    ЕдиницаИзмерения = Товар.ЕдиницаИзмерения;
    КонецЕсли;
    
    Если ПустоеЗначение(ГТД) = 1 Тогда
    НомерГТД_Н = "-----";
    СтранаН = "-----";
    Иначе
    НомерГТД_Н = ГТД;
    Если ПустаяСтрока(ГТД.СтранаПроисхождения) = 1 Тогда
    СтранаН = "-----";
    Иначе
    СтранаН = ГТД.СтранаПроисхождения;
    КонецЕсли;
    КонецЕсли;
    Если НДСпоСтавкеНольПроцентов = 1 Тогда
    ПредставлениеСтавкиНДС = "0%";
    Иначе
    Если (СтавкаНДС.Выбран() = 1) и (СтавкаНДС.Ставка > 0) Тогда
    ПредставлениеСтавкиНДС = "" + СтавкаНДС.Ставка + "%";
    
    Если СуммаНДСопределяетсяРасчетнымМетодом = 1 Тогда
    ПредставлениеСтавкиНДС = ПредставлениеСтавкиНДС + " / 1" + СтавкаНДС.Ставка + "%";
    КонецЕсли;
    
    Иначе
    ПредставлениеСтавкиНДС = "Без НДС";
    КонецЕсли;
    КонецЕсли;
    Таб.ВывестиСекцию("Строка");
    КонецЦикла;
    
    Таб.ВывестиСекцию("Подвал");
    Если Фл_Инф=1 Тогда
    Таб.ВывестиСекцию("Дополн");
    КонецЕсли;
    
    Таб.Опции(0, 0, 0, 0, "ОпцииПечатиСчетаФактуры", "ОкноСчетаФактуры");
    Таб.ПовторятьПриПечатиСтроки( 15, 15 );
    Таб.ТолькоПросмотр(1);
    Таб.ПараметрыСтраницы(2,,,,,,,,,1,,);
    Таб.Показать("Печать счета-фактуры","");
    
    КонецПроцедуры // Печать()
    
  10. Tiger
    Offline

    Tiger Опытный в 1С

    Регистрация:
    12 июл 2006
    Сообщения:
    489
    Симпатии:
    0
    Баллы:
    26
    Какая дата этого счета фактуры и остальных?
  11. TopicStarter Overlay
    НатахаБ
    Offline

    НатахаБ Опытный в 1С

    Регистрация:
    24 янв 2007
    Сообщения:
    92
    Симпатии:
    0
    Баллы:
    26
    14.03.2007
  12. Tiger
    Offline

    Tiger Опытный в 1С

    Регистрация:
    12 июл 2006
    Сообщения:
    489
    Симпатии:
    0
    Баллы:
    26
    Секция "Дополн" выводится у всех документов?
  13. TopicStarter Overlay
    НатахаБ
    Offline

    НатахаБ Опытный в 1С

    Регистрация:
    24 янв 2007
    Сообщения:
    92
    Симпатии:
    0
    Баллы:
    26
    Нет ее вообще можно исключить.
  14. Tiger
    Offline

    Tiger Опытный в 1С

    Регистрация:
    12 июл 2006
    Сообщения:
    489
    Симпатии:
    0
    Баллы:
    26
    Тогда вообще всё просто!!!
    Закомментировать строки
    Код:
        Если Фл_Инф=1 Тогда
    Таб.ВывестиСекцию("Дополн");
    КонецЕсли;
    
    
    А так то похоже на то что секция "Дополн" есть не во всех вариантах печатной формы. Их там три.
  15. TopicStarter Overlay
    НатахаБ
    Offline

    НатахаБ Опытный в 1С

    Регистрация:
    24 янв 2007
    Сообщения:
    92
    Симпатии:
    0
    Баллы:
    26
    Если закоментировать, то все получается. А в случае если нет, что можно сделать?
  16. Tiger
    Offline

    Tiger Опытный в 1С

    Регистрация:
    12 июл 2006
    Сообщения:
    489
    Симпатии:
    0
    Баллы:
    26
    Надо посмотреть, есть ли секция "Дополн" в печатных формах
  17. TopicStarter Overlay
    НатахаБ
    Offline

    НатахаБ Опытный в 1С

    Регистрация:
    24 янв 2007
    Сообщения:
    92
    Симпатии:
    0
    Баллы:
    26
    Во всех трех печатных формах данная секция присутствует.
  18. Lucifer
    Offline

    Lucifer Опытный в 1С

    Регистрация:
    27 фев 2007
    Сообщения:
    91
    Симпатии:
    0
    Баллы:
    26
    Надо посмотреть формулы в секции и чего туда передаётся в переменных, хотя название ошибки она обычно выдает(1эСка).

    Например деление на 0 определяет

Поделиться этой страницей