8.х Помогите доработать код Прикрепление внешних файлов к документам

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Demonxp, 5 мар 2017.

  1. TopicStarter Overlay
    Demonxp
    Offline

    Demonxp

    Регистрация:
    5 мар 2017
    Сообщения:
    2
    Симпатии:
    2
    Баллы:
    1
    [​IMG]
    Код:
    //*************************************Загрузка Коммерческих Предложений 1*******************************
    &НаКлиенте
    Процедура ВыбратьФайлСДискаИЗаписать()
    Перем ВыбранноеИмя;
    Перем АдресВременногоХранилища;
    НовыйОбъект = Объект.Ссылка.Пустая();
    Если ПоместитьФайл(АдресВременногоХранилища, "", ВыбранноеИмя, Истина) Тогда
    Объект.ИмяКП1 = ВыбранноеИмя;
    ПоместитьФайлОбъекта(АдресВременногоХранилища);
    Если НовыйОбъект Тогда
    ОтобразитьИзменениеДанных(Объект.Ссылка, ВидИзмененияДанных.Добавление);
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры
    
    &НаКлиенте
    Процедура ПрочитатьФайлИСохранитьНаДиск()
    Если Объект.Ссылка.Пустая() Тогда
    Предупреждение(НСтр("ru = 'Данные не записаны'", "ru"));
    Возврат;
    КонецЕсли;
    Если ПустаяСтрока(Объект.ИмяКП1) Тогда
    Предупреждение(НСтр("ru = 'Имя не задано'", "ru"));
    Возврат;
    КонецЕсли;
    Адрес = ПолучитьНавигационнуюСсылку(Объект.Ссылка, "КПФайл1");
    ПолучитьФайл(Адрес, Объект.ИмяКП1, Истина);
    КонецПроцедуры
    
    &НаСервере
    Процедура ПоместитьФайлОбъекта(АдресВременногоХранилища)
    ТекущийДокумент = РеквизитФормыВЗначение("Объект");
    ДвоичныеДанные = ПолучитьИзВременногоХранилища(АдресВременногоХранилища);
    ТекущийДокумент.КПФайл1 = Новый ХранилищеЗначения(ДвоичныеДанные);
    Файл = Новый Файл(ТекущийДокумент.ИмяКП1);
    ТекущийДокумент.ИмяКП1 = Файл.Имя;
    ТекущийДокумент.Записать();
    Модифицированность = Истина;
    УдалитьИзВременногоХранилища(АдресВременногоХранилища);
    ЗначениеВРеквизитФормы(ТекущийДокумент, "Объект");
    КонецПроцедуры
    
    &НаКлиенте
    Процедура ЗагрузитьКП1(Команда)
    ВыбратьФайлСДискаИЗаписать();
    Возврат;
    КонецПроцедуры
    
    &НаКлиенте
    Процедура ПоказатьКП1(Команда)
    ПрочитатьФайлИСохранитьНаДиск();
    Возврат;
    КонецПроцедуры
    
    //*************************************Конец Загрузка Коммерческих Предложений***************************
    
    //*************************************Загрузка Комерческих Предложений*************************************
    
    Как сделать загрузку второго КП2
    
    //*************************************Конец Загрузка Коммерческих Предложений ****************************
    [​IMG]
    скачать конфигурация​
    Последнее редактирование модератором: 6 мар 2017