7.7 Помоги новичку

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем SashaR, 17 апр 2007.

Статус темы:
Закрыта.
  1. TopicStarter Overlay
    SashaR
    Offline

    SashaR

    Регистрация:
    17 апр 2007
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Надо создать обработку, выводящую в визуальную таблицу значений структуру папок и файлов диска C с колонками:
    должно отображаться наименование папок и файлов, размер файлов, дата последней модификации...

    Ну саму таблицу сделал ничего сложного в этом нет...
    А как сделать чтоб папки и файлы диска С появлялись, что не как не могу догодаться...

    Подскажите как это сделать...
    Что не так???
    заранее благодарю за помощь!!!


    Вот есть вот такой вот код:

    Функция ПрочитатьКаталог(ИмяКаталога)

    Перем ТекКат;
    ФС.УстТекКаталог("c:\");
    ФС.НайтиПервыйФайл("c:\");
    Каталог="C:\";
    флВозврат=0;
    Пока ФлВозврат=0 Цикл
    ТекКат = ФС.ТекКаталог();
    ТекИмяФайла = ФС.НайтиСледующийФайл();



    ФС.АтрибутыФайла(1,1,1,0,0,1,1);



    Если Каталог=1 Тогда
    Таблица.НоваяСтрока();
    Таблица.ИмяФайла = ТекИмяФайла;

    //тут заносим атрибуты

    ПрочитатьКаталог(ТекИмяФайла);
    Иначе
    Таблица.НоваяСтрока();
    Таблица.ИмяФайла = ТекИмяФайла;
    КонецЕсли;
    КонецЦикла;
    КонецФункции
  2. zeek
    Offline

    zeek

    Регистрация:
    18 апр 2007
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Объясни людям что для этого есть проводник или еще что-то, а 1С предназначена для автоматизации ведения хозяйственной и финановой деятельности предприятия, а не файлы показывать! :unsure:
Статус темы:
Закрыта.

Поделиться этой страницей