8.х Получить значение реквизита с типом Хранилище Значения

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем grand1k, 9 апр 2013.

  1. TopicStarter Overlay
    grand1k
    Offline

    grand1k

    Регистрация:
    4 апр 2013
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Ребят объясните пожалуйста.Вот у меня есть справочник с реквизитом ДанныеФайлаКартинки тип ХранилищеЗначения.Вот код находиться в модуле "ФормаЭлемента";

    &НаСервере
    Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    АдресКартинки = ПолучитьНавигационнуюСсылку(Объект.Ссылка, "ДанныеФайлаКартинки");
    КонецПроцедуры

    &НаКлиенте
    Процедура ЗагрузитьКартинку(Команда)

    Перем ВыбранноеИмя;
    АдресКартинки = "";
    Если ПоместитьФайл(АдресКартинки, "", ВыбранноеИмя, Истина) Тогда
    Объект.ИмяФайла = ВыбранноеИмя;
    ПоместитьФайлКартинки(АдресКартинки);
    КонецЕсли;
    АдресКартинки = ПолучитьНавигационнуюСсылку(Объект.Ссылка, "ДанныеФайлаКартинки");

    КонецПроцедуры

    &НаСервере
    Процедура ПоместитьФайлКартинки(АдресВременногоХранилища)

    ЭлементСправочника = РеквизитФормыВЗначение("Объект");
    ДвоичныеДанные = ПолучитьИзВременногоХранилища(АдресВременногоХранилища);
    ЭлементСправочника.ДанныеФайлаКартинки = Новый ХранилищеЗначения(ДвоичныеДанные, Новый СжатиеДанных());
    ЭлементСправочника.Записать();

    УдалитьИзВременногоХранилища(АдресВременногоХранилища);
    ЗначениеВРеквизитФормы(ЭлементСправочника, "Объект");

    КонецПроцедуры
    В модуле объекта, в отчете, у меня есть код для вывода картинки при формировании.Картинку выводит, проверено на элементарном примере, а вот теперь нужно как то подязаться к картинкам в справочнике.
  2. leemuar
    Offline

    leemuar Опытный в 1С

    Регистрация:
    21 окт 2010
    Сообщения:
    310
    Симпатии:
    0
    Баллы:
    26
    Не совсем понятно что вы хотите сделать. Опишите другими словами
  3. TopicStarter Overlay
    grand1k
    Offline

    grand1k

    Регистрация:
    4 апр 2013
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    в справочнике есть картинки товара их нужно вытащить в отчет.

Поделиться этой страницей