7.7 Получить значение перечисления по его представляния...

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем VIPOS, 11 янв 2013.

  1. TopicStarter Overlay
    VIPOS
    Offline

    VIPOS Опытный в 1С

    Регистрация:
    12 сен 2012
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    29
    Доброго всем уважаемые форумчане!!!!

    Скажите пож. как можно по представлению перечисления получить значение (ссылку) на само перечисление..

    Т.е
    Перечисление по оплате труда
    Наименование Синоним Представление
    Сдельно -\\\\- Сдельно-премиально
    Повременно Повременно-премиальное

    Вот по третьему столбцу получить первый
  2. TopicStarter Overlay
    VIPOS
    Offline

    VIPOS Опытный в 1С

    Регистрация:
    12 сен 2012
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    29
    Люди....хелпните!
  3. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    я писал когда-то через функцию (обход по метаданным)
  4. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    Код:
    Функция ВернутьПеречислениеПоПредставлению(ИдентификаторПеречисления, ПредставлениеЗначения)
    Для i = 1 По Metadata.Перечисление(ИдентификаторПеречисления).Значение() Цикл
    Если Metadata.Перечисление(ИдентификаторПеречисления).Значение(i).Представление = ПредставлениеЗначения Тогда
    
    Возврат Metadata.Перечисление(ИдентификаторПеречисления).Значение(i);
    
    КонецЕсли;
    
    КонецЦикла;
    
    Возврат "";
    
    КонецФункции
    
    Процедура Main()
    
    
    ЗначениеПеречисления = ВернутьПеречислениеПоПредставлению("ВидыДолга","Долг за товары принятые") ;
    
    Если ЗначениеПеречисления = "" Тогда
    Сообщить("что-то пошло не так");
    Иначе
    Сообщить(ЗначениеПеречисления);
    КонецЕсли;
    
    
    
    КонецПроцедуры
  5. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    [off]ИМХО, задача поставлена не корректно.
    Перечисление - это объект конфигурации, следовательно, все его значения известны при составлении программного кода. Отсюда, получение элемента перечисления по его представлению - сомнительная операция.[/off]
  6. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    [off] всякое бывает, я когда-то использовал, в связи с тем, что во внешнюю таблицу в определенное поле у меня писалось представление [/off]

Поделиться этой страницей