8.х получить ссылку на выбранный элемент

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Emiliya_Emili, 23 май 2015.

  1. TopicStarter Overlay
    Emiliya_Emili
    Offline

    Emiliya_Emili

    Регистрация:
    10 май 2015
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Подскажите как получить ссылку на выбранный элемент? Необходимо при нажатии на элемент получать его ссылку, предавать в форму, и открывать ее
    действие происходит в отчете "рабочий стол"
    1) расписание занятий в котором хранятся ссылки на документы, мне нужно при нажатии на одну из них открывать форму выбранного документа
    пытаюсь использовать функцию но он пишет "объект не обнаружен"

    &НаКлиенте
    Процедура ДокументРасписаниеВыбор(Элемент, СтандартнаяОбработка)
    СтандартнаяОбработка=Ложь;


    ОткрытьФорму("Документ.ЗаписьНаЗанятия.Форма.ФормаДокумента");
    КонецПроцедуры

    &НаСервере
    Функция ПолучитьСсылкуДокумента ()
    Обьект=Документы.ЗаписьНаЗанятия.ПолучитьСсылку();
    Возврат Обьект;
    КонецФункции

    2)есть задачи пользователю, которые отражаются на рабочем столе, когда я пытаюсь открыть форму, он открывает пустую форму а не выбранной задачи

    &НаКлиенте
    Процедура ЗадачиВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
    //Выборка = Задачи.ЗадачаДляПоручения.Выбрать();

    //Пока Выборка.Следующий() Цикл
    //Задача = Выборка.Ссылка;
    //КонецЦикла;
    ОткрытьФорму("Задача.ЗадачаДляПоручения.Форма.ФормаЗадачи");
    КонецПроцедуры

    я не могу открывать формы документов и задач из отчета (не знаю как получить на них ссылку)

    Подскажите наиболее простой способ, так как в кодах я не сильна

    Вложения:

    • 5278263753267.JPG
      5278263753267.JPG
      Размер файла:
      70 КБ
      Просмотров:
      5
    • 5635838.JPG
      5635838.JPG
      Размер файла:
      217,8 КБ
      Просмотров:
      5
  2. Николаич87
    Offline

    Николаич87 Опытный в 1С

    Регистрация:
    1 апр 2015
    Сообщения:
    122
    Симпатии:
    4
    Баллы:
    29
    1. в обработчике при выборе пишете
    Код:
    ОткрытьЗначение(Элемент.[посмотрите, в нем должна быть ссылка]);
    2. аналогично

Поделиться этой страницей