[РЕШЕНО] Получить итог из другой документ

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Эмиль0690, 22 ноя 2014.

  1. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    -Woot-печалька...
    А он мне нравится... особенно Реальный куб и Реальный кг))) настроение поднялось..
    Эмиль.. я Вам объясню или по крайней мере постараюсь некоторую истину..
    Вы пишите некий функционал который оперирует арифметическими функциями(сложение, деление и т.д. и т.п.) С чем можно производить данные функции? Правильно с некими переменными содержащими значениями.

    Что это за переменная у Вас ОбщийКуб? и ОбщийКг? Где то выше было написано что вы читаете что Вам пишут?

    Я вам уже писал не думайте и не проводите ассоциаций. Если у вас и есть переменная ОбщаяСумма, то она объявлена
    ОбщаяСумма=ПромежуточнаяСумма;
    и имеет некое значение, а общий куб и общий кг откуда это у вас взято?
  2. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    :)оооолле оле оле все работает Всем спасибо!
    да читаю что Вы все пишите!
    общий куб и общий кг взято из другого документа который поступет груз
    э тот документ загружает в машину товар
    допустим поступило 10 коробок а загрузили 6 коробок поэтому мне нужно реальный куб и кг
    всем спасибо все работает но баланса не и ошибки нет
    Код:
    Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
       
        // общая сумма
        ПромежуточнаяСумма=0;
        Для Каждого ТекСтрока Из Товары Цикл
            ПромежуточнаяСумма=ПромежуточнаяСумма+ТекСтрока.РеальнаяСумма;
            //ПромежуточнаяСумма=ПромежуточнаяСумма+ТекСтрока.РеальныйКуб;
            //ПромежуточнаяСумма=ПромежуточнаяСумма+ТекСтрока.РеальныйКг;
        КонецЦикла;
        ОбщаяСумма=ПромежуточнаяСумма;
        Прибыль = ОбщаяСумма - Перевозчик.ОбщийРасход;
        //РеальныйОбщийКуб=ПромежуточнаяСумма;
        //РеальныйОбщийКг=ПромежуточнаяСумма;
    
        // общий куб
        ПромежуточнаяСумма=0;
        Для Каждого ТекСтрока Из Товары Цикл
            ПромежуточнаяСумма=ПромежуточнаяСумма+ТекСтрока.РеальныйКуб;
        КонецЦикла;
        РеальныйОбщийКуб=ПромежуточнаяСумма;
           
        // общий кг
        ПромежуточнаяСумма=0;
        Для Каждого ТекСтрока Из Товары Цикл
            ПромежуточнаяСумма=ПромежуточнаяСумма+ТекСтрока.РеальныйКг;
        КонецЦикла;
        РеальныйОбщийКг=ПромежуточнаяСумма;
        Баланс = РеальныйОбщийКуб/РеальныйОбщийКг;
    
             
    КонецПроцедуры
    
  3. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    Как Вы определили, что баланса нет??
  4. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    С начало кода проверил синтаксис ошибок нет!
    затем сам док изменил и сохранил через отладчиком результат 0
    а как нужно проверить?
  5. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    И почему я в него такой влюблённый)))

    ну проверка ошибок проверяет только ошибки на синтаксис.
    А результат ноль в чем? Результат нужно проверять так , что получили то что хотели или не получили?
  6. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    upload_2014-11-26_18-18-33.png
    --- Объединение сообщений, 26 ноя 2014 ---
    то что хотел не получил
  7. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    хм.. если вспомнить совсем низшую математику , то результат деления одного числа на другое может быть равен нулю при условии что числитель равен нулю.
    т.е. твой результат РеальныйОбщийКуб = 0, а дальше думай правильно это или нет?
  8. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    ну строка то еще не выполнена в коде, при переходе на следующую результат может появиться
  9. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
  10. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    Яна вопрос тут не в том где отладчик стоит , вопрос в методологии. Человек считает что баланс в конце выполнения равен нулю, возникает вопрос это реально тот результат который он должен получить?
  11. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    Саша, если отладчик на этой строке, то значение выражения не присвоено переменной. Следовательно Эмиль видит предыдущее значение. Не путайте его
  12. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    )))))))))))))))))))))))

    116,41/30236.76 = 0 )))))))))))
    Хороший метод приближений...
    Эмиль можете словами объяснить что у вас означают три переменные из этого выражения?

    Баланс, РеальныйОбщийКуб и РеальныйОбщийКг
  13. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.781
    Симпатии:
    509
    Баллы:
    204
    Еще шаг сделайте, у вас не произошла математическая операция. Ильдар, заканчивайте морозить.........
  14. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    в данном случае правда вычислений, но если Баланс не целое число, то не 0 и получит если еще шаг в отладчике сделает, но число да..0,003...
  15. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    Да я не про то, что вы привязались к этому отладчику, я хочу понять человек знает что он вообще делает?

    Какие исходные данные у него есть, какой расчет он хочет произвести, что он хочет получить в результате? Вот что я хочу понять.
  16. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    ну отладчиком научиться пользоваться - это хороший плюс, чтоб вот такие множественные скрины не бросать
  17. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    люди добрые извините меня дурака я ошибся в деление
    upload_2014-11-27_9-50-30.png
    баланс означает что в одном КУБ сколько кг поместилось
    всем спасибо! что я без вас делал бы:)

Поделиться этой страницей