8.х Получить цвет RGB в диалоге 1С 8.3 (такси)

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем prof-net, 29 ноя 2014.

  1. TopicStarter Overlay
    prof-net
    Offline

    prof-net

    Регистрация:
    13 фев 2013
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте

    Никак не могу разобратьс :(


    В форме создаю диалог выбора цвета, и выбраный цвет записываю в реквизит как строку. Но потом работать с названием этого цвета у меня не очень получается. Хочу получить цвет в виде RGB, но в передоваемом параметре “Результат”– красный, синий, зеленый имеют знгачение “-1”

    Код:
    &НаКлиенте
    Процедура ВыборЦветаФона(Команда) Экспорт
      ДиалогВыбораЦвета = Новый ДиалогВыбораЦвета;
      Оповещение = Новый ОписаниеОповещения("ВыборЦветаЗавершение", ЭтотОбъект);
    ДиалогВыбораЦвета.Показать(Оповещение);
    КонецПроцедуры
    
    
    &НаКлиенте
    Процедура ВыборЦветаЗавершение(Результат, ДополнительныеПараметры) Экспорт
    Если НЕ Результат = Неопределено Тогда
      Элементы.Наименование.ЦветФона = Результат;
      Объект.ЦветФона = Результат;
      КонецЕсли;
    КонецПроцедуры
    Последнее редактирование модератором: 1 дек 2014
  2. TopicStarter Overlay
    prof-net
    Offline

    prof-net

    Регистрация:
    13 фев 2013
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    Помогли решить на другом форуме... немного странным образом, но работает
    Код:
    Функция ПолучитьАбсолютныйЦвет(ИсходныйЦвет) Экспорт
    
    Если ИсходныйЦвет.Вид = ВидЦвета.Абсолютный Тогда
    Возврат ИсходныйЦвет;
    КонецЕсли;
    
    ТабДок = Новый ТабличныйДокумент;
    ТабДок.Область("R1C1").ЦветФона = ИсходныйЦвет;
    ТабДок.Записать("ПреобразованиеЦвета.mxl", ТипФайлаТабличногоДокумента.MXL7);
    ТабДок.Прочитать("ПреобразованиеЦвета.mxl");
    
    АЦвет = ТабДок.Область("R1C1").ЦветФона;
    
    Возврат АЦвет;
    
    КонецФункции
    Последнее редактирование модератором: 1 дек 2014
  3. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    пользуйтесь тегами для фоормления кода
    похвально, что поделились решением...
Похожие темы
  1. ras
    Ответов:
    0
    Просмотров:
    1.139
  2. Dima2008
    Ответов:
    2
    Просмотров:
    1.167
  3. Komich
    Ответов:
    10
    Просмотров:
    3.997
  4. iva77ru
    Ответов:
    0
    Просмотров:
    541
  5. consol
    Ответов:
    10
    Просмотров:
    635
Загрузка...

Поделиться этой страницей