7.7 Получить Цену

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Peroman, 21 май 2010.

  1. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Код:
     
    Процедура Сформировать()
    СпрН = СоздатьОбъект("Справочник.Номенклатура");
    СпрН.ВыбратьЭлементы();
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
    Таб.ВывестиСекцию("Шапка");
    Цена="";
    Цена = глПолучитьЦену(СпрН.ТекущийЭлемент(),ТипыЦен,РабочаяДата());
    Пока СпрН.ПолучитьЭлемент() = 1 Цикл
    Если СпрН.ЭтоГруппа() = 0 Тогда
    //Сообщить(СпрН.Текущийэлемент());
    Таб.ВывестиСекцию("Строка");
    КонецЕсли;
    КонецЦикла;
    Таб.Показать(1);
    КонецПроцедуры
    
    
    Выдает цену = 0 почему?
  2. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    Код:
    Цена = глПолучитьЦену(СпрН.ТекущийЭлемент(),ТипыЦен,РабочаяДата());
    
    эта фигулька в цикле должна быть
  3. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Логично.Спасибо.

Поделиться этой страницей