7.7 Получить цену товара

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем invisible, 2 окт 2009.

  1. TopicStarter Overlay
    invisible
    Offline

    invisible

    Регистрация:
    2 окт 2009
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Есть код
    Код:
    Товар = СоздатьОбъект("Справочник.Номенклатура");
    Товар.ВыбратьЭлементы();
    Э = СоздатьОбъект("Текст");
    Э.ДобавитьСтроку("<?xml version=""1.0"" encoding=""windows-1251""?>");
    Э.ДобавитьСтроку("<items>");
    
    Пока Товар.ПолучитьЭлемент() = 1 Цикл
    Если Товар.ЭтоГруппа()=0 Тогда
    Э.ДобавитьСтроку("  <item code="""+Товар.Код + """>");
    Э.ДобавитьСтроку("    <name>"+Товар.Наименование+"</name>");
    Э.ДобавитьСтроку("    <category>"+Товар.Родитель+"</category>");
    Э.ДобавитьСтроку("  </item>");
    КонецЕсли;  
    КонецЦикла;
    
    
    Все это работает, но никак не могу получить розничную цену для товара. Пробовал и так, и сяк - ни в какую. Прошу помощи :)
  2. ANDRE
    Offline

    ANDRE Опытный в 1С

    Регистрация:
    12 мар 2008
    Сообщения:
    456
    Симпатии:
    0
    Баллы:
    26
    Пример:
    Код:
    СпрТипЦен = СоздатьОбъект("Справочник.ТипыЦен");
    СпрТипЦен.НайтиПоКоду("00001");
    ЗакупЦены = СпрТипЦен.ТекущийЭлемент();
    СпрЦены = СоздатьОбъект("Справочник.Цены");
    СпрЦены.ИспользоватьВладельца(Номенклатура);
    СпрЦены.ВыбратьЭлементы();
    Пока СпрЦены.ПолучитьЭлемент() = 1 Цикл
    Если СпрЦены.ТипЦен = ЗакупЦены Тогда
    Цена = СпрЦены.Цена.Получить();
    КонецЕсли;
    КонецЦикла;
    
    
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Цена - периодический реквизит . Забыли указать дату.

    Код:
    Цена = СпрЦены.Цена.Получить(ДатаЦены);
    
    
    Так правильно
  4. ANDRE
    Offline

    ANDRE Опытный в 1С

    Регистрация:
    12 мар 2008
    Сообщения:
    456
    Симпатии:
    0
    Баллы:
    26

    все может быть:
    из справочника
    <Дата> - необязательный параметр. Выражение типа дата или значение типа документ или позиция документа. Этот параметр задает момент времени, на который требуется получить значение периодического реквизита. Значение по умолчанию: ТА - если используется компонента ''Оперативный учет'', Рабочая дата - если компонента ''Оперативный учет'' не используется.

Поделиться этой страницей