8.х Получение значения формы документа

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Bambr, 2 июл 2009.

  1. TopicStarter Overlay
    Bambr
    Offline

    Bambr

    Регистрация:
    1 июл 2009
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Добрый день!
    Возникла небольшая проблемка - есть документ, который имеет форму списка и форму документа. В форме документа есть поле "примечание", зачастую примечание бывает довольно объемным и выводить его в столбце формы списка крайне неудобно. Возможно ли сделать так, чтобы при выборе строки формы списка в отдельном поле ввода появлялось примечание к данной строке? Я так понимаю нужно использовать ДокументСписокПриАктивизацииСтроки(Элемент), но как правильно описать получение значения не могу понять. Заранее спасибо!
  2. ASh
    Offline

    ASh Опытный в 1С

    Регистрация:
    10 сен 2008
    Сообщения:
    568
    Симпатии:
    0
    Баллы:
    26
    Поле "примечание" нужно связать с реквизитом документа, иначе смысла в нем нет, т.к. жить его значение будет только до закрытия формы. А получить значение реквизита можно уже так:
    Код:
    //ПолеВводаПримечание - поле ввода на форме списка
    //Примечание - реквизит документа
    Процедура ДокументСписокПриАктивизацииСтроки(Элемент)
    ПолеВводаПримечание = Элемент.ТекущаяСтрока.Примечание;
    КонецПроцедуры
    
    
  3. TopicStarter Overlay
    Bambr
    Offline

    Bambr

    Регистрация:
    1 июл 2009
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Спасибо большое, всё получилось! Только есть небольшая загвоздка - если повторно редактировать "примечание" во второй форме, то после её сохранения и закрытия поле "примечание" в первой форме сохраняет старое значение до тех пор, пока не выбрать какую-нибудь другую строку и снова вернуться на эту же. Можно ли как-то сделать, чтобы поле в первой форме обновлялось сразу после закрытия второй? Я так понимаю, что тут нужно использовать Оповестить(), только вот как именно и где не совсем понятно.
  4. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26
    Которую закрываешь - Оповестить о выборе
    В той в которой должно ихмениться
    ОбработкаВыбора
    Обновить...
  5. TopicStarter Overlay
    Bambr
    Offline

    Bambr

    Регистрация:
    1 июл 2009
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Что-то не получается, я делаю так, может что-то неправильно:
    В закрываемой форме:
    Код:
    Процедура ПриЗакрытии()
    ОповеститьОВыборе(Примечание);
    КонецПроцедуры
    
    
    
    В первой форме:
    Код:
    Процедура ОбработкаВыбора(ЗначениеВыбора, Источник)
    Обновить();
    КонецПроцедуры
    
    
    
  6. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26

Поделиться этой страницей