7.7 Получение закупочной цены ТИС

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем SerzhM, 11 дек 2014.

  1. TopicStarter Overlay
    SerzhM
    Offline

    SerzhM Опытный в 1С

    Регистрация:
    26 окт 2009
    Сообщения:
    511
    Симпатии:
    3
    Баллы:
    29
    Доброй ночи.
    Давно не кодил по 1с, да тут попросили что бы в документе "переоценка розница" была галочка которая отражает закупочную цену.
    Колонку добавил назвал "Закуп" добавил галочку "показать закупку"
    Далее в модуле получаем закупочные цены
    Код:
    Процедура ПоказыватьЗакуп()
        Перем ЦенаЦены, ТипЦен;
        Перем ОбЦена;
      Перем ВалЦены;
      Перем ЕдИзм;
       
      Цены       = СоздатьОбъект("Справочник.Цены");   
      ТипыЦен    = СоздатьОбъект("Справочник.ТипыЦен");   
      //Товары     = СоздатьОбъект("Справочник.Номенклатура");
     
      Если ТипыЦен.НайтиПонаименованию("Закупочные",0,1) = 1 тогда
        РознЦена = ТипыЦен.ТекущийЭлемент()
      КонецЕсли;
          
          ВыбратьСтроки();
         
          Пока ПолучитьСтроку()=1 Цикл  
           //Цены.ИспользоватьВладельца(Товары.ТекущийЭлемент());
           глВернутьЦену(Номенклатура.ТекущийЭлемент(),РознЦена,РабочаяДата(),ОбЦена, ЕдИзм, ВалЦены);
          Если ПустоеЗначение(ОбЦена) = 0 Тогда
           Закуп = ОбЦена;
          Иначе
           Закуп = 0;
          КонецЕсли;
          Сообщить(Номенклатура.Наименование);
          Сообщить(Закуп);
       // КонецЕсли;
      КонецЦикла;
    проблема в том что в строку Закуп не записываются данные.
    Что то уже часа 1,5 сижу и не могу записать данные, позабывал я уже большую часть по лайт коддингу.
    Помогите кто чем может :)
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Это делается не так....

    В поле формула вашей текстовой колонки
    пропишите вызов ФУНКЦИИ

    Код:
    Функция ПоказыватьЗакуп()
    Если флПоказатьЦену=0 Тогда //это ваш флаг на форме по которому мы понимаем что колонка видна и нужно выводить цену
    Возврат "";
    КонецЕсли;
    //этот вообще лучше вынести из процедуры чтобы в цикле не дублировать код   
      ТипыЦен    = СоздатьОбъект("Справочник.ТипыЦен");  
      Если ТипыЦен.НайтиПонаименованию("Закупочные",0,1) = 1 тогда
        РознЦена = ТипыЦен.ТекущийЭлемент()
      КонецЕсли;
         
    Возврат       глВернутьЦену(Номенклатура,РознЦена,ДатаДок,ОбЦена, Единица);
      КонецФункции
    
    Ну а видимостью колонки рулите в отдельной процедуре.
    SerzhM нравится это.
  3. TopicStarter Overlay
    SerzhM
    Offline

    SerzhM Опытный в 1С

    Регистрация:
    26 окт 2009
    Сообщения:
    511
    Симпатии:
    3
    Баллы:
    29
    Спасибо.
    Решил мелкую проблемку :)
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104

Поделиться этой страницей