7.7 Получение табличной части документа

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Log1c, 26 июл 2007.

  1. TopicStarter Overlay
    Log1c
    Offline

    Log1c Опытный в 1С

    Регистрация:
    18 май 2007
    Сообщения:
    74
    Симпатии:
    0
    Баллы:
    26
    Код:
    Дкм=СоздатьОбъект("Документ.Заявка");
    Дкм.ВыбратьДокументы(Дата1, Дата2);
    Пока Дкм.ПолучитьДокумент() > 0 Цикл
    Дкм.ВыбратьСтроки();
    Пока Дкм.ПолучитьСтроку() > 0 Цикл
    переменная1=Дкм.Реквизит;//получает значение т.к. реквизит в шапке.
    переменная2=Дкм.РеквизитТабличнойЧасти;//не получает значения, а должно.
    //записую эти переменные куда мне нужно;
    КонецЦикла;
    КонецЦикла;
    
    Из формы документа создаю объект другого документа, выбираю все "Заявки" в интервале, далее хочу получить значение реквизита многострочной части, возращается пустое значение, подскажите что не так.

    Реквизиты шапки "берутся" нормально.
  2. Snake-84
    Offline

    Snake-84 Опытный в 1С

    Регистрация:
    28 янв 2007
    Сообщения:
    110
    Симпатии:
    0
    Баллы:
    26
    А "переменная2" случайно не является реквизитом документа из формы которого ты выборку делаешь? Проверь в отладчике значение не "переменная2" а именно "Дкм.РеквизитТабличнойЧасти".
  3. TopicStarter Overlay
    Log1c
    Offline

    Log1c Опытный в 1С

    Регистрация:
    18 май 2007
    Сообщения:
    74
    Симпатии:
    0
    Баллы:
    26
    Дкм=СоздатьОбъект("Документ.Заявка");
    Дкм.ВыбратьДокументы(Дата1, Дата2);
    Пока Дкм.ПолучитьДокумент() > 0 Цикл
    Дкм.ВыбратьСтроки();
    Пока Дкм.ПолучитьСтроку() > 0 Цикл
    Сообщить(Дкм.Реквизит);//получает значение т.к. реквизит в шапке.
    Сообщить(Дкм.РеквизитТабличнойЧасти);//не получает значения, а должно.
    КонецЦикла;
    КонецЦикла;


    Вот так я думаю не будет вопросов.
    В отладчике через СШИФТ+Ф9 проверяю Дкм., реквизиты табличной части не читает и строка всегда нулевая, хотя значения перебираются.
    Проблему решил, хоть значения и возвращаются пустыми но при сравнении этого значения с другим всё ок, вообщем просмотреть не могу, а сравнивает правильно.
  4. Snake-84
    Offline

    Snake-84 Опытный в 1С

    Регистрация:
    28 янв 2007
    Сообщения:
    110
    Симпатии:
    0
    Баллы:
    26
    тупой вопрос но может "Дкм.РеквизитТабличнойЧасти" это справочник с пустым наименованием?
  5. TopicStarter Overlay
    Log1c
    Offline

    Log1c Опытный в 1С

    Регистрация:
    18 май 2007
    Сообщения:
    74
    Симпатии:
    0
    Баллы:
    26
    ну как же так, в коде же ясно видно что "Дкм" это документ
    "" Дкм=СоздатьОбъект("Документ. ""
    если про тип спрашивать то тип реквизита этого документа это строка, но если бы даже наименование было пустым как оно может сравниватся с текстом и возвращать 1 ???

    получается что

    Если ""="тапки" Тогда
    //невозможно сюда попасть
    КонецЕсли;

    выполняется, вот у меня оно выполняется =)

    Вообщем что попало, найду ошибку отпишу, наверника в чём-то загнался.
  6. Steel Rain
    Offline

    Steel Rain Опытный в 1С

    Регистрация:
    29 сен 2006
    Сообщения:
    408
    Симпатии:
    2
    Баллы:
    29
    1. Зачем перебирать реквизиты шапки в цикле по строкам табличной части?
    2. Попробуй сделать безусловный цикл по строкам.

Поделиться этой страницей