7.7 Получение шкалы северной надбавки (ЗиК)

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем Korovay, 20 авг 2012.

  1. TopicStarter Overlay
    Korovay
    Offline

    Korovay Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Подскажите плз, каким образом программно можно получить шкалу северной надбавки.
    Код:
    СпрСотрудники = СоздатьОбъект ("Справочник.Сотрудники");
    СпрСотрудники.ВыбратьЭлементы();
    
    Пока СпрСотрудники.ПолучитьЭлемент() = 1 Цикл
    
    Если СпрСотрудники.ЭтоГруппа() = 0 Тогда
    
    Если СокрЛП(СпрСотрудники.Код) = "ЯХ001716" Тогда
    
    ШкалаСтажа = СоздатьОбъект("Справочник.ШкалыПроцентныхНадбавок");
    ШкалаСтажа.ИспользоватьВладельца(СпрСотрудники.ПроцентыСевернойНадбавки);
    
    
    КонецЕсли;
    
    КонецЕсли;
    
    КонецЦикла;
    
    таким образом (ШкалаСтажа.ВыбратьЭлементы() = 0), что то не получается, может где то ошибка?
    Спасибо
  2. TopicStarter Overlay
    Korovay
    Offline

    Korovay Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Вопрос снят, затупил.
    Ни тот справочник указал, должно быть:

    Код:
    ШкалаСтажа = СоздатьОбъект("Справочник.ПроцентныеНадбавкиПоСтажуШкала");

Поделиться этой страницей