7.7 Получение почты

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем alp, 7 май 2014.

  1. TopicStarter Overlay
    alp
    Offline

    alp Опытный в 1С

    Регистрация:
    8 янв 2009
    Сообщения:
    432
    Симпатии:
    0
    Баллы:
    26
    Доброго времени суток , не получается подключиться к почет яндекса.

    Код:
        Попытка
            //Почта = СоздатьОбъект("AddIn.POP3");
            Почта               = СоздатьОбъект("AddIn.AddInMail");
        Исключение
            Предупреждение("Не удалось создать объект Addin.AddInMail!");
            Возврат;
        КонецПопытки;
                    
      
        
        Почта.СерверПриема  = "pop.yandex.ru";
        Почта.ПортПриема    = "110";
        Почта.Логин         = "alpasha21@yandex.ru";
        Почта.Пароль        = "********";
        Почта.ОставлятьНаСервере    = 1;
        Почта.КаталогВложений="C:\";
          
      
      
        Если Почта.Соединение = 0 Тогда
            Если Почта.Подключиться("Прием")<>1 Тогда
                Сообщить("Ошибка подключения","!");
                Почта.Отключиться();
                Возврат;
            КонецЕсли;
        КонецЕсли;
    не подключается к яндексу, а к майлу все норм подключается, пробовал 2-мя компонентами Dialmail и Rom-mail , в обоих случаях маил читает, а yandex нет ((

    Помогите разобраться.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Если ЗагрузитьВнешнююКомпоненту(ПутьКПримеру + "DialMail.dll")=0 Тогда
    Сообщить("Не удалось обнаружить компоненту DialMail.dll!");
    Возврат 0;
    КонецЕсли;
    Почта = СоздатьОбъект("AddIn.POP3");
    Почта.ИспользоватьПрокси=0
    Почта.ИспользоватьSSL=0;
    Если Почта.Подключиться("pop.yandex.ru", 110,"alpasha21",ВашПароль)=0 Тогда
    Сообщить("Не смог подключиться");
    КонецЕсли;
    alp нравится это.
  3. GlukAl
    Offline

    GlukAl Опытный в 1С

    Регистрация:
    4 окт 2012
    Сообщения:
    187
    Симпатии:
    7
    Баллы:
    29
    А в настройках ящика включено разрешение на подключение по протоколу РОР ??
    alp и Бухгалтерский угодник нравится это.
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Точно... Там настройки-почтовые программы-С сервера pop.yandex.ru по протоколу POP3 должен стоять флаг
  5. TopicStarter Overlay
    alp
    Offline

    alp Опытный в 1С

    Регистрация:
    8 янв 2009
    Сообщения:
    432
    Симпатии:
    0
    Баллы:
    26
    а это где посмотреть ?
    --- Объединение сообщений, 8 май 2014 ---

    Все равно не подключается...
    --- Объединение сообщений, 8 май 2014 ---

    Нашел, всем спасибо за помощь !
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104

Поделиться этой страницей