7.7 Получение почты

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем mazza, 12 окт 2010.

  1. TopicStarter Overlay
    mazza
    Offline

    mazza Опытный в 1С

    Регистрация:
    4 фев 2009
    Сообщения:
    138
    Симпатии:
    0
    Баллы:
    26
    Подскажите, как запускать эту процедуру каждые две минуты. Если можно пример.
    Код:
    Процедура ПолучитьПочту()   
    
    //Пытаемся подключить компоненту
    Если ЗагрузитьВнешнююКомпоненту("ROM-Mail.dll")=0 Тогда
    Сообщить("Не удалось загрузить внешнюю компоненту ROM-Mail.dll");
    Возврат;
    Конецесли;
    
    //Подключаемся к почте с указанными параметрами
    Почта          = СоздатьОбъект("AddIn.AddInMail");   
    Почта.СерверПриема  = "pop.yandex.ru";
    Почта.ПортПриема    = "110";  
    Почта.Логин        = "magazin.tkprodukty@yandex.ru"; //при необходимости
    Почта.Пароль      = "*******";//при необходимости
    Почта.ОставлятьНаСервере    = 1; //необходимо ли оставлять письма в ящике
    Почта.КаталогВложений="C:\";
    
    //Если подключение не удачное прерываем обработку
    Если Почта.Соединение = 0 Тогда
    Если Почта.Подключиться("Прием")=0 Тогда
    Сообщить("Не удалось подключиться к почтовому серверу","!");
    Возврат;
    Конецесли;
    Конецесли;  
    
    ПринятыйФайл = "";
    Для й = 1 По Почта.КоличествоСообщений() Цикл  
    
    //Читаем заголовки писем    
    Если Почта.ПолучитьЗаголовок(й) = 1 Тогда
    
    //Читаем тексты писем        
    Если Почта.ПолучитьТело(й)=1 Тогда     
    
    Если Почта.ИмяОтправителя = "ТК Продукты" Тогда  
    Для ф = 1 По Почта.КоличествоФайлов() Цикл            
    Файл=Почта.КаталогВложений+Почта.ПолучитьФайл(ф);
    Сообщить("Получен файл: "+Файл);
    //сохраняем вложение
    Почта.СохранитьФайл(ф,);                      
    Конеццикла;
    КонецЕсли;
    Конецесли;  
    Конецесли; 
    Сообщить(Почта.ИмяОтправителя);
    Если Почта.ИмяОтправителя = "ТК Продукты" Тогда
    Почта.ПометитьНаУдаление(й);    	
    КонецЕсли;
    Конеццикла;
    //Отключаемся
    Почта.Отключиться(); 
    
    КонецПроцедуры
    
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Используйте процедуру ОбработкаОжидания

Поделиться этой страницей