8.х Получение и проверка заполнения ресурса регистра сведений

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Reclaim, 14 ноя 2015.

  1. TopicStarter Overlay
    Reclaim
    Offline

    Reclaim

    Регистрация:
    13 ноя 2015
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте! Задача стоит такая: Колонка "L"(Номер л.счета в экселе) - проверить, есть ли для физ лица полученного ранее на этапе №1 запись в РС "ЛицевыеСчетаРаботниковОрганизации" (Ресурс РС).
    Если есть но не совпадает со значением лицевого счета из файла, перезаписать запись, обновив только ресурс "НомерЛицевогоСчета".
    Если нет - создать документ "ЗаявкаНаОткрытиеСчетов" (документ должен быть в разрезе Банков, сколько уникальных БИК в файле загрузки, столько документов на выходе.)
    Заполнить реквизиты документа:
    Дата - период из реквизита обработки
    Организация - Организация из реквизита обработки
    Ответственный - текущий пользователь системы (глЗначениеПеременной("глТекущийПользователь"))
    ВводНачальныхСведений = Истина
    ------------------------------------------------------------------
    Вот такой код уже прописан:
    ------------------------------------------------------------------
    Для НомерСтроки = 2 ПО КоличествоСтрок Цикл

    ОбработкаПрерыванияПользователя();

    ФизЛицоСсылка = Справочники.ФизическиеЛица.НайтиПоНаименованию(СокрЛП(Excel.Cells(НомерСтроки,2).Text) + " " + СокрЛП(Excel.Cells(НомерСтроки,3).Text) + " " + СокрЛП(Excel.Cells(НомерСтроки,4).Text));
    ИНН = СокрЛП(Excel.Cells(НомерСтроки,5).Text);
    ДатаРождения = СокрЛП(Excel.Cells(НомерСтроки,14).Text);
    МестоРождения = СокрЛП(Excel.Cells(НомерСтроки,15).Text);
    //Этап №3
    НомерСчета = СокрЛП(Excel.Cells(НомерСтроки,12).Text);

    Если НЕ ЗначениеЗаполнено(ФизЛицоСсылка) Тогда
    Сообщить("Не найдено физлицо: " + СокрЛП(Excel.Cells(НомерСтроки,2).Text) + " " + СокрЛП(Excel.Cells(НомерСтроки,3).Text) + " " + СокрЛП(Excel.Cells(НомерСтроки,4).Text));
    Продолжить;
    КонецЕсли;

    Попытка
    Если ДатаРождения = СокрЛП(Excel.Cells(НомерСтроки,14).Text) <> 0 Тогда
    ДатаРождения = Дата(Сред(ДатаРождения,7,4),Сред(ДатаРождения,4,2),Сред(ДатаРождения,1,2));
    Продолжить;
    КонецЕсли;
    Исключение
    КонецПопытки;

    ФизЛицоОбъект = ФизЛицоСсылка.ПолучитьОбъект();
    Если НЕ ЗначениеЗаполнено(ФизЛицоОбъект.ИНН) ИЛИ ЗначениеЗаполнено(ФизЛицоОбъект.ИНН) <> ИНН Тогда
    ФизЛицоОбъект.ИНН = ИНН;
    КонецЕсли;

    Если НЕ ЗначениеЗаполнено(ФизЛицоОбъект.ДатаРождения) ИЛИ ЗначениеЗаполнено(ФизЛицоОбъект.ДатаРождения) <> ДатаРождения Тогда
    ФизЛицоОбъект.ДатаРождения = ДатаРождения;
    КонецЕсли;

    Если НЕ ЗначениеЗаполнено(ФизЛицоОбъект.МестоРождения) ИЛИ ЗначениеЗаполнено(ФизЛицоОбъект.МестоРождения) <> МестоРождения Тогда
    ФизЛицоОбъект.МестоРождения = МестоРождения;
    КонецЕсли;

    ФизЛицоОбъект.Наименование = ФизЛицоСсылка;
    //Этап №3


    ФизЛицоОбъект.Записать();
    КонецЦикла;
    ------------------------------------------------------------------
    Подскажите, как мне обратиться к РС, чтобы проверить запись ресурса. Смотрел СП, и если правильно понял, то нужно как то обращаться через НаборЗаписей, но не могу понять как это сделать.

    И еще такой вопрос: "(Документ должен быть в разрезе Банков, сколько уникальных БИК в файле загрузки, столько документов на выходе)" - не совсем понимаю суть того, что тут нужно прописывать.

    P.S. Если можно, то направьте на то, что именно нужно почитать.

Поделиться этой страницей