7.7 Получение данных документа через счет

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем solnce, 15 фев 2010.

  1. TopicStarter Overlay
    solnce
    Offline

    solnce Опытный в 1С

    Регистрация:
    16 июл 2009
    Сообщения:
    61
    Симпатии:
    0
    Баллы:
    26
    Доброе время суток. у меня вот какая проблема,есть обработка,которая формирует файл выгрузки
    Код:
    //-----------------------выбытие        
    Если не(БИ.КорКО()=0) и (не(СЗСчетаВыбытияОС.НайтиЗначение(БИ.КорСчет.Код)=0) 
    или не(СЗСчетаНалУчетаОС.НайтиЗначение(БИ.Счет.Код)=0)) Тогда  
    УчестьНалоговуюПремиюПриВыбытии(ОС,НалоговаяПремия);
    
    ДобавитьСтроку(Табл4,ОС);
    
    Если (БИ.Счет.Код="01") или (БИ.Счет.Код="03")  Тогда  
    Табл4.Сумма=БИ.КорКО();                      
    Табл4.СчетУчета=БИ.Счет.Код; 									
    Иначе 
    Табл4.СуммаНалог=БИ.КорКО(); 
    КонецЕсли;
    КонецЕсли;
    Иначе                             
    
    но в этом коде не предусмотрена бух.справка, а мне нужно чтобы из бух.справка в которой СчетДт=83,3 и СчетКд=01,1 сумма попадала в Табл4.Сумма
    Как это сделать?
    пробовала так:
    Код:
    //----------------------------------------------------------------------------------------------ирина
    Если Док.Вид()="Бухгалтерская справка" Тогда
    Если (Док.СчетДт("83.3")=1) И (Док.СчетКт("01.1")=1) Тогда 
    а= Док.Сумма;
    КонецЕсли;	
    КонецЕсли;/----------------------------------------------------------------------------------------------
    
    Но не вышло, подскажите пожалуйста!
    Заранее благодарю!!!
  2. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    сомнительное условие

    "Если (Док.СчетДт("83.3")=1) И (Док.СчетКт("01.1")=1) Тогда "

    Возможно так:
    Код:
    Если (Док.СчетДт=СчетПоКоду("83.3") и (Док.СчетКт = СчетПоКоду("01.1")) Тогда 
    

Поделиться этой страницей