7.7 получаемая строка превысит допустимые размеры

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Svet42, 28 фев 2014.

  1. TopicStarter Overlay
    Svet42
    Offline

    Svet42 Опытный в 1С

    Регистрация:
    19 окт 2013
    Сообщения:
    200
    Симпатии:
    1
    Баллы:
    29
    Здравствуйте пишу обработку на выгрузку справочника номенклатуры из КА-7 в БП-8, вылетает ошибка получаемая строка превысит допустимые размеры, как с этим бороться не знаю, подскажите, если есть идеи или кто то с этим сталкивался. Если что кину обработку на мыло.
  2. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    смотрите в сторону типов реквизитов справочника. скорее всего они разные, не?
    Svet42 нравится это.
  3. TopicStarter Overlay
    Svet42
    Offline

    Svet42 Опытный в 1С

    Регистрация:
    19 окт 2013
    Сообщения:
    200
    Симпатии:
    1
    Баллы:
    29
  4. TopicStarter Overlay
    Svet42
    Offline

    Svet42 Опытный в 1С

    Регистрация:
    19 окт 2013
    Сообщения:
    200
    Симпатии:
    1
    Баллы:
    29
    вот код

    Процедура Сформировать()
    ТекстовыйФайл = СоздатьОбъект("Текст");
    Спр = СоздатьОбъект("Справочник.Номенклатура");
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
    Если Спр.ПометкаУдаления() = 0 Тогда
    ПолныйКод = Спр.ПолныйКод();
    ЭтоГруппа = Строка(Спр.ЭтоГруппа());
    НаимПолн = Строка(Спр.ПолнНаименование);
    НаимПолн = СокрЛП(СТрЗаменить(НаимПолн,РазделительСтрок," "));
    НаимПолн = СокрЛП(СТрЗаменить(НаимПолн,СимволТабуляции," "));
    Артикул = Строка(Спр.Артикул);
    Артикул = СокрЛП(СТрЗаменить(Артикул,РазделительСтрок," "));
    Артикул = СокрЛП(СТрЗаменить(Артикул,СимволТабуляции," "));
    ВидНом = СокрЛП(Строка(Спр.ВидНоменклатуры));
    СтавкаНДС = СокрЛП(Строка(Спр.СтавкаНДС));
    Если Спр.Уровень() = 1 Тогда
    КодРодителя = "ПервыйУровень";
    Иначе
    КодРодителя = Спр.Родитель.Код;
    КонецЕсли;
    Если ПустоеЗначение(Спр.БазоваяЕдиница) = 1 Тогда
    ЕИн = "шт";
    ЕИпн = "Штука";
    ЕИк = "796";
    //код=??? - помечен на удаление, обработка при загрузке в 1с 8
    Иначе
    ЕИн = СокрЛП(Строка(Спр.БазоваяЕдиница.ОКЕИ.Наименование));
    ЕИпн = СокрЛП(Строка(Спр.БазоваяЕдиница.ОКЕИ.ПолнНаименование));
    ЕИк = СокрЛП(Строка(Спр.БазоваяЕдиница.ОКЕИ.Код));
    КонецЕсли;
    Комм = СокрЛП(Строка(Спр.Комментарий));
    Если ПустоеЗначение(Спр.НомерГТД) = 1 Тогда
    ГТД = "нет";
    Иначе
    ГТД = СокрЛП(Строка(Спр.НомерГТД.Наименование));
    КонецЕсли;
    Если ПустоеЗначение(Спр.СтранаПроисхождения) = 1 Тогда
    СтранаК = "нет";
    СтранаН = "нет";
    Иначе
    СтранаК = СокрЛП(Строка(Спр.СтранаПроисхождения.Код));
    СтранаН = СокрЛП(Строка(Спр.СтранаПроисхождения.Наименование));
    КонецЕсли;



    ТекстовыйФайл.ДобавитьСтроку(Строка(ЭтоГруппа)
    +"#"+Строка(Спр.Код)
    +"#"+Лев(ПолныйКод,СтрДлина(ПолныйКод)-СтрДлина(Строка(Спр.Код))-1)
    +"#"+Строка(Спр.Наименование)
    +"#"+Строка(НаимПолн)
    +"#"+Строка(Артикул)
    +"#"+Строка(ВидНом)
    +"#"+Строка(ЕИн)
    +"#"+Строка(ЕИпн)
    +"#"+Строка(ЕИк)
    +"#"+Строка(СтавкаНДС)
    +"#"+Строка(КодРодителя)
    +"#"+Строка(Комм)
    +"#"+Строка(ГТД)
    +"#"+Строка(СтранаК)
    +"#"+Строка(СтранаН));
    Сообщить(Строка(Спр.ВидНоменклатуры)+": "+Спр.ПолнНаименование);
    КонецЕсли;
    КонецЦикла;
    ТекстовыйФайл.Записать("c:\СпрНом.txt");
    КонецПроцедуры
  5. TopicStarter Overlay
    Svet42
    Offline

    Svet42 Опытный в 1С

    Регистрация:
    19 окт 2013
    Сообщения:
    200
    Симпатии:
    1
    Баллы:
    29
    я извиняюсь, если вопрос глупый, но че то у меня не получается(((
  6. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    вопросов глупых не бывает, вы только не забыайте код тегами на форуме оформлять, а то нечитабельно получилось
    Svet42 нравится это.
  7. TopicStarter Overlay
    Svet42
    Offline

    Svet42 Опытный в 1С

    Регистрация:
    19 окт 2013
    Сообщения:
    200
    Симпатии:
    1
    Баллы:
    29
    спасибо за замечание, в следующий раз учту.
  8. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    Где ошибка вылетает?? В 7.7 или 8.2. Скрин ошибки сможете выложить??
    Svet42 нравится это.
  9. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Это стандартная ошибка 7.7
    Поверьте все вызовы оператора <Сообщить ()>. Можете в качестве параметра передавать обрезанную строку (там лимит примерно 450 символов)
    Лев(параметр, 450)
    Svet42 нравится это.
  10. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    бери все строковые в сокрЛП()
    ПолнНаименование, например
    Svet42 нравится это.
  11. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Если все равно не получится - придется разбивать на подстроки
    Svet42 нравится это.
  12. TopicStarter Overlay
    Svet42
    Offline

    Svet42 Опытный в 1С

    Регистрация:
    19 окт 2013
    Сообщения:
    200
    Симпатии:
    1
    Баллы:
    29
    Ошибка вылетает когда я запускаю выгрузку в режиме 1с Предприятие 7.7, до загрузке в 8.2 еще не дошла, ну как обработку написала, но еще не тестила, так как еще пока выгрузить номенклатуру не могу((( Вот скрин

    Вложения:

  13. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    Вам ответили в посту #8-10... Пробуйте
    Svet42 нравится это.
  14. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    можно вообще убрать из кода сообщить
    Svet42 нравится это.
  15. TopicStarter Overlay
    Svet42
    Offline

    Svet42 Опытный в 1С

    Регистрация:
    19 окт 2013
    Сообщения:
    200
    Симпатии:
    1
    Баллы:
    29
    ребят всем спасибочки большое,разбила на подстроки, получилось. Сори, что вчера не отписалась, еще вчера получилось)) Жаль что нет той кнопочки спасибо, но это уже в отдельной ветке. И еще вопрос по загрузке есть, но тоже отдельная тема.. СПАСИБО ВСЕМ ОГРОМНОЕ ПРИ ОГРОМНОЕ!!!!!
  16. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Вместо спасибо - жмите Мне нравится.
    Svet42 нравится это.
  17. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Не за что. Обращайтесь!

Поделиться этой страницей