8.х ПолеСписка-ТабличныйДокумент

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем herosmart, 23 июн 2013.

  1. TopicStarter Overlay
    herosmart
    Offline

    herosmart

    Регистрация:
    22 июн 2013
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Помогите, пожалуйста! Как сделать, чтобы только текущая строка поля списка попадала в табличный документ? Поле списка без пометки.
  2. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.980
    Симпатии:
    398
    Баллы:
    104
    А теперь еще раз и более развернуто?
  3. TopicStarter Overlay
    herosmart
    Offline

    herosmart

    Регистрация:
    22 июн 2013
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    В текстовый документ выводится информация из справочника номенклатуры. Также есть поле списка, в которое бухгалтер может добавить определенные товары. Так вот нужно, чтобы в текстовый документ выводились ТОЛЬКО ЭТИ товары, а не все содержимое справочника номенклатуры. Вот код:
    Макет = ПолучитьМакет("ОсновнойМакет");
    ТабДок = Новый ТабличныйДокумент;
    Область = Макет.ПолучитьОбласть("Шапка|База");
    ТабДок.Вывести(Область);
    Область = Макет.ПолучитьОбласть("Шапка|Типы_цен");
    Для Каждого ЭлементСписка из ПолеСписка1 Цикл
    Если ЭлементСписка.Пометка=Истина Тогда
    Область.Параметры.Тип_цены=ЭлементСписка.Значение;
    ТабДок.Присоединить(Область);
    КонецЕсли;
    КонецЦикла;
    СпрНом = Справочники.Номенклатура;
    СпрОтпЦены=Справочники.ОтпускныеЦены;
    ВыборкаСпрНом = СпрНом.Выбрать();
    Номер=1;
    Если ВыбратьТовары=Ложь Тогда
    Пока ВыборкаСпрНом.Следующий()=Истина Цикл
    Область = Макет.ПолучитьОбласть("Строка|База");
    Область.Параметры.Наименование = ВыборкаСпрНом.Наименование;
    Область.Параметры.Ном = Номер;
    ТабДок.Вывести(Область);
    Номер = Номер + 1;
    Область = Макет.ПолучитьОбласть("Строка|Типы_цен");
    Для каждого ЭлементСписка Из ПолеСписка1 Цикл
    Если ЭлементСписка.Пометка=Истина Тогда
    СсылкаСпрОтпЦены = СпрОтпЦены.НайтиПоРеквизиту("ТипЦены",ЭлементСписка.Значение,,ВыборкаСпрНом.Ссылка);
    Область.Параметры.Цена=СсылкаСпрОтпЦены.Цена;
    ТабДок.Присоединить(Область);
    КонецЕсли;
    КонецЦикла;
    КонецЦикла;

Поделиться этой страницей