7.7 Поле ввода

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем igorekkrav, 26 июл 2010.

  1. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Подскажите есть Поле ввода (ВыбМенеджера) через которое мы можем провалиться в справочник Менеджеров. Как реализовать чтобы работало
    Код:
    ВыбМенеджера=глПользователь
    
    Спасибо
  2. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26
    Код:
    Процедура ВводНового()
    ВыбМенеджера=глПользователь;
    КонецПроцедуры
    
    может так?
  3. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Следующий вопрос будет: "Как сделать, что бы работало как я хочу", потом: "Как сделать, что бы работало правильно"....
    Все это уже проходили.

    http://www.1c-pro.ru/index.php?act=announce&id=8
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    ВыбМенеджера должен быть реквизитом формы
  5. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    ВыбМенеджер реквизит формы. Делаю этот код
    Код:
    Процедура ПриОткрытии()  	
    ВыбМенеджер=глПользователь;	
    КонецПроцедуры
    
    
    Не выбирает =( Делаю это в Журнале - > Формы -> ФормыСписка
    :unsure:
  6. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26
    ыыы... а на хрена ты это в журнале делаешь? че ты хочешь добиться-то?
  7. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Ну у меня в этом журнале , можно менеджера выбрать и по нему отчет построить . Вот я и хочу чтобы по умолчанию он выбирался.
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Скорее всего не совпадают типы.
    Какой тип имеет реквизит формы и переменная глПользователь?
  9. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Да наверное не совпадает . У ВыбМенеджер (Тип Справочник.Менеджер) А у глПользователь Справочник.Пользователи. А можно как нибудь привести их к единому?
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    У одного из справочников завести ссылку на другой
  11. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Оказывается ссылка есть . В справочнике менеджеры есть реквизит Менеджер который ссылается на справочник пользователи
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Приведите в соответствие присвоение в процедуре ПриОткрытии
  13. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    То есть прописать в процедуре ПриОткрытии ссылку с одного справочника на другой?
  14. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Поскольку в спр.Менеджер есть ссылка на спр.Пользователи надо:

    Код:
    Процедура ПриОткрытии()      
    Спр=СоздатьОбъект("Справочник.Менеждеры");
    Если Спр.НайтиПоРеквизиту("Пользователь",глПользователь,1)=1 Тогда
    ВыбМенеджер=Спр.ТекущийЭлемент();    
    КонецЕслИ;
    КонецПроцедуры
    
    
    
    Для того чтобы поиск работал необходимо установить признак ''Сортировка'' у реквизита Пользователь
  15. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Все здорово! Заработало . Не думал вроде такая не сложная вещь , а заставит попатеть =) Бухгалтерский угодник спасибо огромное :unsure:

Поделиться этой страницей