8.х Поле табличной части

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем PsyTech, 21 апр 2008.

  1. TopicStarter Overlay
    PsyTech
    Offline

    PsyTech Опытный в 1С

    Регистрация:
    4 янв 2008
    Сообщения:
    198
    Симпатии:
    0
    Баллы:
    26
    В табличных частях документов встречаются поля без данных и без элемента управления.
    Как в них вывести информацию.
    У меня получилось как-то на половину: Для всех строк в этой колонке выводится овно и тоже значение, которое должно быть только в текущей строке данной колонки. И при выборе другой строки, уже другое значение выводится для всей колонки.
    Надеюсь кто-нибудь понял о чем я. Заранее спасибо.
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Через ОформлениеСтроки, доступно в ПриВыводеСтроки и ПриПолученииДанных.
  3. Stack_G
    Offline

    Stack_G Опытный в 1С

    Регистрация:
    10 дек 2007
    Сообщения:
    786
    Симпатии:
    2
    Баллы:
    26
    Что-нибудь вроде:

    Код:
    Процедура ТоварыПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    ПоказатьКодАртикул(мКолонкиТовары, ОформлениеСтроки.Ячейки, ДанныеСтроки.Номенклатура);
    КонецПроцедуры
    
    
    Код:
    // Процедура добавляет информацию о коде и/или артикуле в ячейки табличного поля
    // при выводе очередной строки
    //
    // Параметры:
    //  КолонкиТабПоля - коллекция колонок табличного поля
    //  ЯчейкиСтрокиТабПоля - коллекция ячеек строки табличного поля
    //  Номенклатура - СправочникСсылка.Номенклатура, товар, по которому надо вывести код и/или артикул
    //
    Процедура ПоказатьКодАртикул(КолонкиТабПоля, ЯчейкиСтрокиТабПоля, Номенклатура) Экспорт
    
    Если КолонкиТабПоля.Код.Видимость
    ИЛИ КолонкиТабПоля.Артикул.Видимость Тогда
    
    Если КолонкиТабПоля.Код.Видимость Тогда
    Если Номенклатура <> Неопределено Тогда
    ЯчейкиСтрокиТабПоля.Код.УстановитьТекст(Номенклатура.Код);
    Иначе
    ЯчейкиСтрокиТабПоля.Код.УстановитьТекст("");
    КонецЕсли;
    КонецЕсли;
    
    Если КолонкиТабПоля.Артикул.Видимость Тогда
    Если ТипЗнч(Номенклатура) = Тип("СправочникСсылка.Номенклатура") Тогда
    ЯчейкиСтрокиТабПоля.Артикул.УстановитьТекст(Номенклатура.Артикул);
    Иначе
    ЯчейкиСтрокиТабПоля.Артикул.УстановитьТекст("");
    КонецЕсли;
    КонецЕсли;
    
    КонецЕсли;
    
    КонецПроцедуры // ПоказатьКодАртикул()
    
    
  4. TopicStarter Overlay
    PsyTech
    Offline

    PsyTech Опытный в 1С

    Регистрация:
    4 янв 2008
    Сообщения:
    198
    Симпатии:
    0
    Баллы:
    26
    Спасибо.
    Тема закрыта.

Поделиться этой страницей