7.7 Поле со списков типов документов

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Jyravlik, 18 янв 2011.

  1. TopicStarter Overlay
    Jyravlik
    Offline

    Jyravlik Опытный в 1С

    Регистрация:
    9 авг 2010
    Сообщения:
    98
    Симпатии:
    0
    Баллы:
    26
    Добрый день, возникла необходимость сделать обработку, в которой одни и те же действия будут производиться с каждым типом документа. Чтобы не прописывать одинаковый код для каждого типа документа, хочу сделать поле со списком, где будут указаны все типы документа, что есть в конфигурации. Помогите пожалуйста!
  2. sergejk74
    Offline

    sergejk74 Опытный в 1С

    Регистрация:
    15 ноя 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Добавь на форму обработки поле со списком с идентификатором ВсеДокументы
    В модуле добавь процедуру
    Код:
    Процедура ПриОткрытии()
    ВидыДокументов.УдалитьВсе();
    Для Индекс=1 По Метаданные.Документ() Цикл
    Значение = Метаданные.Документ(Индекс).Идентификатор;
    Представление = Метаданные.Документ(Индекс).Представление();
    Комментарий = Метаданные.Документ(Индекс).Комментарий;
    Если ПустаяСтрока(Комментарий) = 0 Тогда
    Представление = Представление + " (" + Комментарий +")";
    КонецЕсли;
    ВидыДокументов.ДобавитьЗначение(Значение, Представление);
    КонецЦикла;
    КонецПроцедуры // ПриОткрытии
    
    Тебе это было нужно?
  3. TopicStarter Overlay
    Jyravlik
    Offline

    Jyravlik Опытный в 1С

    Регистрация:
    9 авг 2010
    Сообщения:
    98
    Симпатии:
    0
    Баллы:
    26
    О да!! Именно это, вот только у меня появляется первый тип документа, а разворачивающего списка нет:(
    Хотя если добавить не поле со списком, а просто список, все ок.
  4. TopicStarter Overlay
    Jyravlik
    Offline

    Jyravlik Опытный в 1С

    Регистрация:
    9 авг 2010
    Сообщения:
    98
    Симпатии:
    0
    Баллы:
    26
    Все получилось, спасибо огромное, sergejK74!!!
  5. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Ну так жми кнопу "СПАСИБО".

Поделиться этой страницей