8.х Поле объекта не обнаружено...

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем vetalker, 24 окт 2008.

  1. TopicStarter Overlay
    vetalker
    Offline

    vetalker

    Регистрация:
    24 окт 2008
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Код:
    Процедура ОбработкаПроведения(Отказ, Режим)
    //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    Для Каждого ТекСтрокаПереченьНоменклатуры Из ПереченьНоменклатуры Цикл
    Если ТекСтрокаПереченьНоменклатуры.Номенклатура.
    ВидыНоменклатуры <> Перечисления.ВидыНоменклатуры.Материал Тогда Продолжить;
    КонецЕсли;
    // регистр ОстаткиМатериалов Расход
    Движение = Движения.ОстаткиМатериалов.Добавить();
    Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
    Движение.Период = Дата;
    Движение.Материал = ТекСтрокаПереченьНоменклатуры.Номенклатура;
    Движение.Склад = Склад;
    Движение.Количество = ТекСтрокаПереченьНоменклатуры.Количество;
    КонецЦикла;
    // записываем движения регистров
    Движения.ОстаткиМатериалов.Записать();
    //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
    КонецПроцедуры
    
    -------------------------------------------------------------------------------------------------------------------
    Служебные сообщения:
    {Документ.ОказаниеУслуги(7)}: Поле объекта не обнаружено (ВидыНоменклатуры)
    Если ТекСтрокаПереченьНоменклатуры.Номенклатура.ВидыНоменклатуры <> Перечисления.ВидыНоменклатуры.Материал Тогда Продолжить;
    -------------------------------------------------------------------------------------------------------------------
    ...помогите пожалуйста, я в этом деле новичок!!!
  2. GvH
    Offline

    GvH Опытный в 1С

    Регистрация:
    12 авг 2008
    Сообщения:
    179
    Симпатии:
    0
    Баллы:
    26
    Код:
    Если ТекСтрокаПереченьНоменклатуры.Номенклатура.ВидНоменклатуры <>
    
    
  3. Fire Boy
    Offline

    Fire Boy

    Регистрация:
    24 окт 2008
    Сообщения:
    13
    Симпатии:
    0
    Баллы:
    1
    Посмотри название полей у таблицы "Перечень номенклатуры". И проверь Перечисление ВидыНоменклатуры.

    В конфе через "Текст" - "Синтаксический контроль" ошибку выдает? Если да, то скорее всего ошибка в написании. Если нет - то возможно ошибка при создании виртуальной таблицы или при проведении данная переменная обнуляется.

Поделиться этой страницей