8.х Поле объекта не обнаружено

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Euronymous, 9 мар 2015.

  1. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    повторю вопрос, вы в одинаковых режимах запускаете? в смысле управляемого приложения или толстого клиента?
    Euronymous нравится это.
  2. Дмитрий Игоревич
    Offline

    Дмитрий Игоревич Опытный в 1С

    Регистрация:
    11 апр 2013
    Сообщения:
    152
    Симпатии:
    0
    Баллы:
    26
    а стек вызовов? может попытка,где-то в другом месте? код может вообще фоновым выполняться? короче была такая ситуация, не помню в чем, точно дело было, но все оказалось элементарно)

    но судя по коду, тут ситуация когда передается объект, у которого просто нет поля исходящий документ, проверку воткнуть на либо вид документа, или наличие метаданных.
    Последнее редактирование: 10 мар 2015
  3. TopicStarter Overlay
    Euronymous
    Offline

    Euronymous Опытный в 1С

    Регистрация:
    19 фев 2014
    Сообщения:
    206
    Симпатии:
    0
    Баллы:
    26
    Да, через конфиг запускался толстый клиент, поэтому работает все отлично. А предприятие в режиме автомат запускало тонкий. Управляемое приложение в обоих случаях
  4. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    ну вот, как Вадим и сказал вам, где то что не определилось по причине что код в толстом клиенте не всегда правильно работает в УП, копайте в эту сторону
  5. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.581
    Симпатии:
    717
    Баллы:
    204
    /offtop on/
    на приеме у ЛОРа:
    - сижу я, значит, на диване, в ухе гвоздиком ковыряю, и вдруг звук пропал....
    /offtop off/

    В управляемом режиме некоторые методы/свойства работают совсем не так, как в режиме обычного приложения. Необходимо с этим разобраться.
  6. Дмитрий Игоревич
    Offline

    Дмитрий Игоревич Опытный в 1С

    Регистрация:
    11 апр 2013
    Сообщения:
    152
    Симпатии:
    0
    Баллы:
    26
    уникальный случай ;)
  7. TopicStarter Overlay
    Euronymous
    Offline

    Euronymous Опытный в 1С

    Регистрация:
    19 фев 2014
    Сообщения:
    206
    Симпатии:
    0
    Баллы:
    26
    Не надо издеваться! -Yuck-
    Проверку по типу вбил - ошибка та же
  8. Дмитрий Игоревич
    Offline

    Дмитрий Игоревич Опытный в 1С

    Регистрация:
    11 апр 2013
    Сообщения:
    152
    Симпатии:
    0
    Баллы:
    26
    а можете скинуть всю процедуру, где этот код? с указанием контекстов, если такие имеются?
  9. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.581
    Симпатии:
    717
    Баллы:
    204
    ага, было бы не плохо увидеть контекст выполнения данного кода.
  10. TopicStarter Overlay
    Euronymous
    Offline

    Euronymous Опытный в 1С

    Регистрация:
    19 фев 2014
    Сообщения:
    206
    Симпатии:
    0
    Баллы:
    26
    Код:
    &НаКлиенте
    Процедура ПриОткрытии(Отказ)
      
        Если Объект.ЭтоИнтеркампани Тогда
          
            Отказ = Истина;
            Параметр = Новый Структура("Ключ", Объект.Ссылка);
            ОткрытьФорму("Справочник.СоглашенияОбИспользованииЭД.Форма.ФормаЭлементаИнтеркампани", Параметр);
          
        ИначеЕсли Объект.СпособОбменаЭД = ПредопределенноеЗначение("Перечисление.СпособыОбменаЭД.ЧерезОператораЭДОТакском") Тогда
          
            Отказ = Истина;
            Параметр = Новый Структура("Ключ", Объект.Ссылка);
            ОткрытьФорму("Справочник.СоглашенияОбИспользованииЭД.Форма.ФормаЭлементаЧерезОЭДО", Параметр);
          
        ИначеЕсли Объект.СпособОбменаЭД = ПредопределенноеЗначение("Перечисление.СпособыОбменаЭД.ЧерезВебРесурсБанка") Тогда
          
            Отказ = Истина;
            Параметр = Новый Структура("Ключ", Объект.Ссылка);
            ОткрытьФорму("Справочник.СоглашенияОбИспользованииЭД.Форма.ФормаЭлементаБанк", Параметр);
          
        КонецЕсли;
      
        #Если ВебКлиент Тогда
            Элементы.КаталогВходящихДокументов.КнопкаВыбора  = Ложь;
            Элементы.КаталогИсходящихДокументов.КнопкаВыбора = Ложь;
            Элементы.КаталогВходящихСообщений.КнопкаВыбора   = Ложь;
            Элементы.КаталогИсходящихСообщений.КнопкаВыбора  = Ложь;
        #КонецЕсли
      
        ИзменитьНадписьНаправлениеДокументов();
        Если ТипЗнч(Объект.Ссылка) = Тип("СправочникСсылка.СоглашенияОбИспользованииЭД") Тогда
            Попытка
                ТЗИсходящих = Объект.Ссылка.ИсходящиеДокументы.Выгрузить();
                НайденнаяСтрока = ТЗИсходящих.Найти(ПредопределенноеЗначение("Перечисление.ВидыЭД.ЗапросКаталогаТоваров"),"ИсходящийДокумент");
                Если ТипЗнч(НайденнаяСтрока) <> Тип("Неопределено") И НЕ НайденнаяСтрока.Формировать Тогда
                    ЭтаФорма.КоманднаяПанель.ПодчиненныеЭлементы.ФормаЭД.ПодчиненныеЭлементы.ФормаЗапросПрайса.Видимость = Ложь;
                КонецЕсли;
            Исключение
            КонецПопытки;
        КонецЕсли;
        Элементы.ЗаполнитьПоТиповомуСоглашению.Видимость = Ложь;
      
    КонецПроцедуры
    
  11. Дмитрий Игоревич
    Offline

    Дмитрий Игоревич Опытный в 1С

    Регистрация:
    11 апр 2013
    Сообщения:
    152
    Симпатии:
    0
    Баллы:
    26
    Найти -
    Доступность:

    Сервер, толстый клиент, внешнее соединение, мобильное приложение(сервер).
  12. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.581
    Симпатии:
    717
    Баллы:
    204
    В управляемом режиме данные через точку тока на сервере доступны, Объект.Ссылка в данном контексте, однако, будет НЕОПРЕДЕЛЕНО, и, как уже заметили, метод Найти() для ТЗ доступен только на сервере.
    Дмитрий Игоревич нравится это.
  13. TopicStarter Overlay
    Euronymous
    Offline

    Euronymous Опытный в 1С

    Регистрация:
    19 фев 2014
    Сообщения:
    206
    Симпатии:
    0
    Баллы:
    26
    Всем спасибо. Стало стыдно, пойду почитаю СП -Sorry- -Wacky-

    Кстати по поводу Объект.Ссылка:
    Если ТипЗнч(Объект.Ссылка) = Тип("СправочникСсылка.СоглашенияОбИспользованииЭД") Тогда .......

    это условие срабатывает, следовательно Объект.Ссылка <> Неопределено
    Последнее редактирование: 10 мар 2015
  14. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    смотря что у вас в Объект
  15. LordMaverick
    Online

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    376
    Баллы:
    104
    так он и есть самый простой, пользование единой версией ПО
    в серверном это сам сервер проверяет и банально не пускает, а в файловом следить надо, а то так и ИБ запросто можно в мир иной отправить

    ну это уже выяснили, разные клиенты, толстый/тонкий
    можно было и предприятия настроить запуск нужного вида
  16. TopicStarter Overlay
    Euronymous
    Offline

    Euronymous Опытный в 1С

    Регистрация:
    19 фев 2014
    Сообщения:
    206
    Симпатии:
    0
    Баллы:
    26
    Объект - ДанныеФормыСтруктура
    Объект.Ссылка - http://gyazo.com/9b6800a45f7f24b4e8fd05759e387e06

    Оказывается таких косяков много) Придется работать только в режиме толстого клиента) :D

Поделиться этой страницей