7.7 Поле агрегатного объекта не обнаружено

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем MajaHeD, 9 дек 2011.

  1. TopicStarter Overlay
    MajaHeD
    Offline

    MajaHeD

    Регистрация:
    9 дек 2011
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Добрый день!
    Помогите пожалуйста! Имеется комплексная конфигурация "Бухгалтерия+Торговля+Склад+Зарплата+Кадры". Редакция 4.5 (7.70.496). В документе "Реализация" при выборе печатной формы ТОРГ12+СчФакт появляется ошибка:
    СуммаПеч = ДокСФ.СуммаПеч - ДокСФ.СуммаНППеч;
    {E:\БАЗА 3КВ-ЗЕЛЕНОГОРСК\EXTFORMS\PRNFORMS\АКТ_ТОРГ12_СФ.ERT(275)}: Поле агрегатного объекта не обнаружено (СуммаПеч)
    и печатная форма не выводится.
    Не могу разобраться... Вот модуль с этими функциями:


    Код:
    Процедура СкорректироватьТаблицуОснования(ДокСФ, ТаблицаОснования, ВидОсн)
    
    Если (ВидОсн = "Реализация") ИЛИ (ВидОсн = "РеализацияПрочее") Тогда
    
    ПечВалюта = Константа.ВалютаБухУчета;
    
    // корретируем табличную часть по регистру "Книга продаж"
    СуммыПоУчету = СоздатьОбъект("ТаблицаЗначений");
    СуммыПоУчету.НоваяКолонка("СуммаПоУчету",    "Число", 15, 2);	
    СуммыПоУчету.НоваяКолонка("СуммаНДСПоУчету", "Число", 15, 2);	
    СуммыПоУчету.НоваяКолонка("СуммаНППоУчету",  "Число", 15, 2);	
    
    ВсегоСтрок = ТаблицаОснования.КоличествоСтрок();
    
    ОбщаяСуммаДокумента = ТаблицаОснования.Итог("Сумма");
    Сумма0Стр    = 0;
    СуммаНДС0Стр = 0;
    СуммаНП0Стр  = 0;
    
    Для Сч = 1 По ВсегоСтрок Цикл
    СуммыПоУчету.НоваяСтрока();
    КонецЦикла;
    
    РегистрКнигиПродаж = СоздатьОбъект("Регистр.КнигаПродаж");
    Если РегистрКнигиПродаж.ВыбратьДвиженияДокумента(ДокСФ.ДокОснование) = 1 Тогда
    Пока РегистрКнигиПродаж.ПолучитьДвижение() = 1 Цикл
    Если РегистрКнигиПродаж.Приход = 1 Тогда
    Если РегистрКнигиПродаж.НомерСтроки() = 0 Тогда
    Сумма0Стр    = Сумма0Стр    + РегистрКнигиПродаж.СуммаРуб;
    СуммаНДС0Стр = СуммаНДС0Стр + РегистрКнигиПродаж.СуммаНДС;
    СуммаНП0Стр  = СуммаНП0Стр  + РегистрКнигиПродаж.СуммаНП;
    
    Иначе
    СуммыПоУчету.УстановитьЗначение(РегистрКнигиПродаж.НомерСтроки(), "СуммаПоУчету", РегистрКнигиПродаж.СуммаРуб + 
    СуммыПоУчету.ПолучитьЗначение(РегистрКнигиПродаж.НомерСтроки(), "СуммаПоУчету"));			
    СуммыПоУчету.УстановитьЗначение(РегистрКнигиПродаж.НомерСтроки(), "СуммаНДСПоУчету", РегистрКнигиПродаж.СуммаНДС + 
    СуммыПоУчету.ПолучитьЗначение(РегистрКнигиПродаж.НомерСтроки(), "СуммаНДСПоУчету"));			
    СуммыПоУчету.УстановитьЗначение(РегистрКнигиПродаж.НомерСтроки(), "СуммаНППоУчету", РегистрКнигиПродаж.СуммаНП + 
    СуммыПоУчету.ПолучитьЗначение(РегистрКнигиПродаж.НомерСтроки(), "СуммаНППоУчету"));			
    КонецЕсли;
    КонецЕсли;
    КонецЦикла;
    КонецЕсли;
    
    ТаблицаОснования.ВыбратьСтроки();
    
    Пока ТаблицаОснования.ПолучитьСтроку() = 1 Цикл
    
    СуммаПеч    = СуммыПоУчету.ПолучитьЗначение(ТаблицаОснования.НомерСтроки, "СуммаПоУчету");
    СуммаНДСПеч = СуммыПоУчету.ПолучитьЗначение(ТаблицаОснования.НомерСтроки, "СуммаНДСПоУчету");
    СуммаНППеч  = СуммыПоУчету.ПолучитьЗначение(ТаблицаОснования.НомерСтроки, "СуммаНППоУчету");
    // распределяем общие суммы по строкам документа
    Если ОбщаяСуммаДокумента <> 0 Тогда
    СуммаПеч    = СуммаПеч    + Сумма0Стр * ТаблицаОснования.Сумма / ОбщаяСуммаДокумента;
    СуммаНДСПеч = СуммаНДСПеч + СуммаНДС0Стр * ТаблицаОснования.Сумма / ОбщаяСуммаДокумента;
    СуммаНППеч  = СуммаНППеч  + СуммаНП0Стр * ТаблицаОснования.Сумма / ОбщаяСуммаДокумента;
    КонецЕсли;
    
    Если глЕстьРеквизитШапки("СуммаВклНДС", ДокСФ.ДокОснование.Вид()) = 1 Тогда
    Если ДокСФ.ДокОснование.СуммаВклНДС = 0 Тогда
    СуммаПеч = ДокСФ.СуммаПеч - ДокСФ.СуммаНДСПеч;
    КонецЕсли;
    КонецЕсли;
    
    Если глЕстьРеквизитШапки("СуммаВклНП", ДокСФ.ДокОснование.Вид()) = 1 Тогда
    Если ДокСФ.ДокОснование.СуммаВклНП = 0 Тогда
    [b]СуммаПеч = ДокСФ.СуммаПеч - ДокСФ.СуммаНППеч;[/b]
    КонецЕсли;
    КонецЕсли;
    
    ТаблицаОснования.Сумма = СуммаПеч;
    ТаблицаОснования.СуммаНДС = СуммаНДСПеч;
    ТаблицаОснования.СуммаНП = СуммаНППеч;
    
    КонецЦикла;
    
    КонецЕсли;
    
    КонецПроцедуры // СкорректироватьТаблицуОснования()
    
    
    Заранее спасибо!!!
  2. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    судя по всему ДокСФ это документ должен быть, соответственно проверьте есть ли у данного документа поле СуммаПеч
Похожие темы
  1. Алёна
    Ответов:
    3
    Просмотров:
    1.232
  2. Eugene_V
    Ответов:
    4
    Просмотров:
    1.600
  3. mironsoft
    Ответов:
    24
    Просмотров:
    6.727
  4. Аваська
    Ответов:
    1
    Просмотров:
    1.259
  5. himera
    Ответов:
    14
    Просмотров:
    807
Загрузка...

Поделиться этой страницей