7.7 ПоКнопкеПечать()

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем ya-wanes, 21 дек 2006.

  1. TopicStarter Overlay
    ya-wanes
    Offline

    ya-wanes

    Регистрация:
    21 дек 2006
    Сообщения:
    23
    Симпатии:
    0
    Баллы:
    1
    :unsure: Процедура Печать(Докум, Устройство=0, КолвоКопий=1)
    Перем НачПовт, КонПовт;

    ИсхТабл = СоздатьОбъект("Таблица");
    НачПовт = 0; КонПовт = 0;

    // секция Заголовок

    ИсхТабл.ВывестиСекцию("Заголовок");
    НачПовт = НачПовт + ИсхТабл.ВысотаСекции("Заголовок");

    // Секция Шапка таблицы
    ИсхТабл.ВывестиСекцию("ШапкаТаблицы");
    КонПовт = НачПовт + ИсхТабл.ВысотаСекции("ШапкаТаблицы");
    ИсхТабл.ПовторятьПриПечатиСтроки(НачПовт + 1, КонПовт);

    // выводим табличную часть
    НомСтроки = 0;
    Докум.ВыбратьСтроки();

    Пока Докум.ПолучитьСтроку() = 1 Цикл
    НомСтроки = НомСтроки + 1;
    //ЛС карточка
    Если Докум.Карточка.Выбран()=1 Тогда
    ПечТовар = СокрЛП(Докум.ДопОбраб.Наименование);
    Иначе
    ПечТовар = СокрЛП(Докум.ДопОбраб.ПолнНаименование);
    КонецЕсли;
    ИсхТабл.ВывестиСекцию("Строка");
    КонецЦикла;

    СуммаИтог = Докум.Итог("Сумма");

    // секция Итого
    ИсхТабл.ВывестиСекцию("Итого");

    // секция ИтогоНДС
    Если Докум.УчитыватьНДС = 1 Тогда
    СуммаНДСИтог = Докум.Итог("СуммаНДС");
    Если Докум.СуммаВклНДС = 0 Тогда
    СуммаИтог = СуммаИтог + СуммаНДСИтог;
    КонецЕсли;
    ИсхТабл.ВывестиСекцию("ИтогоНДС");
    КонецЕсли;

    // секция СуммаПрописью
    ИсхТабл.ВывестиСекцию("СуммаПрописью");

    // секция Подписи
    ИсхТабл.ВывестиСекцию("Подписи");



    КонецПроцедуры // Печать()

    Процедура ПоКнопкеПечать()
    Таб=СоздатьОбъект("Документ.Таблица");
    Таб.ИсходнаяТаблица("Карточка");
    Документ.ВыбратьСтроки();
    Пока Документ.ПолучитьСтроку()>0 Цикл
    Номер = Документ.НомерДок;
    Таб.ВывестиСекцию ("СекцСтрока");
    КонецЦикла;
    Таб.ТолькоПросмотр(0);
    Таб.Показать();
    КонецПроцедуры B)
  2. 77dpi
    Offline

    77dpi Опытный в 1С

    Регистрация:
    17 окт 2006
    Сообщения:
    66
    Симпатии:
    0
    Баллы:
    26
    надо: Таб=СоздатьОбъект("Таблица");
    Если печатаеш открытый документ
    убери все "Документ." в коде.
Похожие темы
  1. alinkaZ
    Ответов:
    12
    Просмотров:
    4.202
Загрузка...

Поделиться этой страницей