7.7 Поиск где учитывается товар в номенклатуре по нормам расходов?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем webresurs, 24 сен 2009.

  1. TopicStarter Overlay
    webresurs
    Offline

    webresurs

    Регистрация:
    22 июл 2009
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Ситуация:
    В спаравочнике "номенклатура" заведена "номенклатурная единица":
    - хлеб, булка, вода.
    для каждой из них есть материал(полуфабрикат) справочник "нормативы расходов"
    -хлеб состоит - мука, соль, вода;
    -булка - мука, соль, сахар, вода;
    -вода - тара.

    Цель: Найти в каких нормах расходов по номенклатуре используется материал(полуфабрикат)

    Результат напр., надо узнать где используется "мука" в - хлеб, булка



    с какой стороны подойти к решению данной задачи, даже не представляю!??
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    "нормативы расходов" - подчиненный справочник.

    Не озвучена конфигурация, поэтому не знаю структуры метаданных. Но делать приблизительно так:
    Код:
    Спр=СоздатьОбъект("Справочник.Номерклатура");
    Норм=СоздатьОбъект("Справочник.НормыРасходов");
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
    Если Спр.ЭтоГруппа()=1 Тогда
    продолжить;
    КонецЕсли;
    Норм.ИспользоватьВладельца(Спр.ТекущийЭлемент());
    Норм.ВыбратьЭлемент();
    Пока Норм.ПолучитьЭлемент()=1 Цикл
    //получли элемент состава - сравнивай или вычисляй что хочешь
    //но учти - числовые значения (сами нормы) на 99% это периодический реквизит.
    //нужно будет использовать метод Получить()
    КонецЦикла;
    КонецЦикла;
    
    

Поделиться этой страницей