7.7 Поиск документа по товару

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем OrenLiTo, 11 окт 2012.

  1. TopicStarter Overlay
    OrenLiTo
    Offline

    OrenLiTo

    Регистрация:
    23 авг 2012
    Сообщения:
    48
    Симпатии:
    0
    Баллы:
    1
    Прошу прошу прощения за глупый вопрос, в 7.7 никогда не работал. а сказали сделать срочно.. пытаюсь сам разобраться, но не получается(((

    Подскажите, мне надо найти строчку в табличной части документа, в которой имеется определенный товар... причем надо, чтобы это был самый свежий документ, где фигурирует этот товар..

    заранее спасибо!!
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Так что нужно найти? Документ, содержащий номенклатуру, или номер строки по конкретному документу?
  3. TopicStarter Overlay
    OrenLiTo
    Offline

    OrenLiTo

    Регистрация:
    23 авг 2012
    Сообщения:
    48
    Симпатии:
    0
    Баллы:
    1
    Номер строки в конкретном документе
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    проще всего запросом.
  5. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Если номер строки в документе - то перебором строк, не нужно городить огород.

    В крайнем случае, если предполагается, что в документе в среднем от 50 строк и более, то можно через ТЗ: выгружаем табличную часть, ищем по колонке ТЗ, найденный номер и есть номер строки.
  6. Vertex
    Offline

    Vertex Опытный в 1С

    Регистрация:
    14 июн 2011
    Сообщения:
    468
    Симпатии:
    4
    Баллы:
    29
    Код:
    Док = СоздатьОбъект("Документ.<ВидДокумента>");
    Док.ВыбратьДокументы(НачДата,КонДата);
    Док.ОбратныйПорядок(1);
    Пока Док.ПолучитьДокумент()=1 Цикл
    Док.ВыбратьСтроки();
    Пока Док.ПолучитьСтроку()=1 Цикл
    Если СокрЛП(Док.<Реквизит Табличной части>) = "Наименование для поиска" Тогда
    Сообщить(Док+"  "+Док.НомерСтроки);
    КонецЕсли;	  
    КонецЦикла;
    КонецЦикла;
    Типа этого можно.
    Если искомая позиция товара имеет тип "Справочник" можно
    Код:
    Если Док.<Реквизит Табличной части> = [Имя переменной содержащей значение] Тогда
    Сообщить(Док);
    КонецЕсли;   

Поделиться этой страницей