8.х ЗУП Поиск документа по номеру в зуп2.5 обработкой

Тема в разделе ""1С:Зарплата и управление персоналом ЗУП"", создана пользователем Nik02071, 1 окт 2012.

  1. TopicStarter Overlay
    Nik02071
    Offline

    Nik02071 Опытный в 1С

    Регистрация:
    12 ноя 2008
    Сообщения:
    347
    Симпатии:
    1
    Баллы:
    29
    создан документ приема на работу в зуп2.5 с номером "777", не ищется в чем ошибка?

    Процедура КнопкаВыполнитьНажатие(Кнопка)


    Перем ДокПр;

    ДокПр= Документы.ПриемНаРаботу.НайтиПоНомеру("777",);

    Если не ДокПр.Пустая() Тогда

    Сообщить("Найден");

    КонецЕсли;

    КонецПроцедуры
  2. abelly
    Offline

    abelly

    Регистрация:
    30 сен 2012
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    дату (период ) поиска нужно указывать кроме номера
  3. TopicStarter Overlay
    Nik02071
    Offline

    Nik02071 Опытный в 1С

    Регистрация:
    12 ноя 2008
    Сообщения:
    347
    Симпатии:
    1
    Баллы:
    29

    В справке говорится, что дата- параметр необязательный

    Пробовал и с датой, не помогает.
  4. abelly
    Offline

    abelly

    Регистрация:
    30 сен 2012
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    необязательный - это если нумерация непериодическая - в большинстве случаев она все таки периодическая и указывать нужно. Смотря как пробовали...
  5. TopicStarter Overlay
    Nik02071
    Offline

    Nik02071 Опытный в 1С

    Регистрация:
    12 ноя 2008
    Сообщения:
    347
    Симпатии:
    1
    Баллы:
    29
    Вот так пробовал

    ДатДОк=Дата("20120801");

    ДокПр= Документы.ПриемНаРаботу.НайтиПоНомеру("777",ДатДОк);
  6. abelly
    Offline

    abelly

    Регистрация:
    30 сен 2012
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    посмотрите в конфигураторе - у вас в этом доке Номер - это строка? ну и сколько знаков -
    вот пример работающего кода:
    Код:
    Номер = "00000035024";
    Дата = "20120918";
    ДокументСсылка = Документы.ЧекККМ.НайтиПоНомеру(Номер, Дата);
    Сообщить (""+ДокументСсылка.Дата);
  7. TopicStarter Overlay
    Nik02071
    Offline

    Nik02071 Опытный в 1С

    Регистрация:
    12 ноя 2008
    Сообщения:
    347
    Симпатии:
    1
    Баллы:
    29

    строка 11знаков
  8. abelly
    Offline

    abelly

    Регистрация:
    30 сен 2012
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    ну дык подправьте по примеру, что выше - док найдется
  9. TopicStarter Overlay
    Nik02071
    Offline

    Nik02071 Опытный в 1С

    Регистрация:
    12 ноя 2008
    Сообщения:
    347
    Симпатии:
    1
    Баллы:
    29
    ввел документ приемНаРаботу с таким номером и датой.

    Появилось сообщение 01.01.0001 Непонятная дата

    после запуска обработки
  10. abelly
    Offline

    abelly

    Регистрация:
    30 сен 2012
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    в номере нули проставьте перед 777 - дата должна выровняться

    Код:
    Номер = "00000000777";
    Дата = "20120801";
    ДокументСсылка = Документы.ПриемНаРаботу.НайтиПоНомеру(Номер, Дата);
    Если НЕ  ДокументСсылка.Пустая() Тогда
    Сообщить ("Найден Док от "+ДокументСсылка.Дата);
    Иначе
    Сообщить ("Не было таких.");
    КонецЕсли;
    
  11. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    Дата заключается в одинарные кавычки.
    Код:
    Дата = '20120801';
  12. abelly
    Offline

    abelly

    Регистрация:
    30 сен 2012
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    точно , ...
    я часто замечал, что торопливость не лучший помощник.

Поделиться этой страницей