8.х Подстановка значения из базы, во внешнюю печатную форму.

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем litome, 22 сен 2012.

  1. TopicStarter Overlay
    litome
    Offline

    litome

    Регистрация:
    22 сен 2012
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Добрый день, есть внешняя печатная форма, которая подключается к конфигурации Альфа-авто, необходимо добавить в нее электронный адрес контрагента. Как правильно составить запрос к базе, что бы получить электронный адрес?

    Код:
    Перем ЗапросНабораТелефонов;
    Функция СформироватьЗапросПоШапке()
    Запрос = Новый Запрос;
    Если СсылкаНаОбъект.ВидЗаказа <> "Гарантийный" Тогда
    Запрос.Текст =
    "ВЫБРАТЬ
    | РеализацияТоваровУслуг.Ссылка,
    | РеализацияТоваровУслуг.ПометкаУдаления,
    | РеализацияТоваровУслуг.Номер,
    | РеализацияТоваровУслуг.Дата КАК ДатаВыдачи,
    | РеализацияТоваровУслуг.Проведен,
    | РеализацияТоваровУслуг.ВидОперации,
    | РеализацияТоваровУслуг.Организация,
    | РеализацияТоваровУслуг.БанковскийСчетОрганизации,
    | РеализацияТоваровУслуг.ОтражатьВУправленческомУчете,
    | РеализацияТоваровУслуг.ОтражатьВБухгалтерскомУчете,
    | РеализацияТоваровУслуг.ОтражатьВНалоговомУчете,
    | РеализацияТоваровУслуг.Подразделение,
    | РеализацияТоваровУслуг.Комментарий КАК Комментарии,
    | РеализацияТоваровУслуг.Сделка,
    | РеализацияТоваровУслуг.Склад,
    | РеализацияТоваровУслуг.ДоговорКонтрагента,
    | РеализацияТоваровУслуг.Контрагент,
    | РеализацияТоваровУслуг.ТипЦен,
    | РеализацияТоваровУслуг.ВалютаДокумента,
    | РеализацияТоваровУслуг.УчитыватьНДС,
    | РеализацияТоваровУслуг.СуммаВключаетНДС,
    | РеализацияТоваровУслуг.КурсВзаиморасчетов,
    | РеализацияТоваровУслуг.СуммаДокумента,
    | РеализацияТоваровУслуг.КратностьВзаиморасчетов,
    | РеализацияТоваровУслуг.Ответственный,
    | РеализацияТоваровУслуг.ВидПередачи,
    | РеализацияТоваровУслуг.АдресДоставки,
    | РеализацияТоваровУслуг.Грузополучатель,
    | РеализацияТоваровУслуг.Грузоотправитель,
    | РеализацияТоваровУслуг.Проект,
    | РеализацияТоваровУслуг.ДисконтнаяКарта,
    | РеализацияТоваровУслуг.УсловиеПродаж,
    | РеализацияТоваровУслуг.ОтключитьКонтрольВзаиморасчетов,
    | РеализацияТоваровУслуг.ОтпускРазрешил,
    | РеализацияТоваровУслуг.ОтпускПроизвел,
    | РеализацияТоваровУслуг.ДоверенностьНомер,
    | РеализацияТоваровУслуг.ДоверенностьДата,
    | РеализацияТоваровУслуг.ДоверенностьВыдана,
    | РеализацияТоваровУслуг.ДоверенностьЧерезКого,
    | РеализацияТоваровУслуг.ДополнениеКАдресуДоставки,
    | РеализацияТоваровУслуг.МастерКонсультант,
    | РеализацияТоваровУслуг.Заказчик,
    | РеализацияТоваровУслуг.Автомобиль,
    | РеализацияТоваровУслуг.ВидЗаказа,
    | РеализацияТоваровУслуг.Пробег,
    | РеализацияТоваровУслуг.Представление,
    | РеализацияТоваровУслуг.МоментВремени,
    | РеализацияТоваровУслуг.Автомобиль.НомернойЗнак,
    | РеализацияТоваровУслуг.Автомобиль.Тип,
    | РеализацияТоваровУслуг.Автомобиль.VIN,
    | РеализацияТоваровУслуг.Автомобиль.ДатаПродажи,
    | РеализацияТоваровУслуг.Автомобиль.МодельИНомерДвигателя,
    | РеализацияТоваровУслуг.Автомобиль.GKB,
    | РеализацияТоваровУслуг.Автомобиль.Рекомендации,
    | РеализацияТоваровУслуг.ОбращениеКлиента,
    | РеализацияТоваровУслуг.Заказчик КАК ПодписывающееЛицо,
    | ТелефонДомашний.Представление КАК ТелефонКонтрагентаДомашний,
    | ТелефонСлужебный.Представление КАК ТелефонКонтрагентаСлужебный,
    | АдресФактическийКонтрагент.Представление КАК АдресКонтрагентаФактический,
    | АдресФактическийЗаказчик.Представление КАК АдресЗаказчикаФактический,
    | РеализацияТоваровУслуг.Сделка.Дата КАК ДатаПриема
    |ИЗ
    | Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
    |  ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.КонтактнаяИнформация КАК ТелефонДомашний
    |  ПО РеализацияТоваровУслуг.Заказчик = ТелефонДомашний.Объект
    |   И (ТелефонДомашний.Тип = &Телефон)
    |   И (ТелефонДомашний.Вид = &Домашний)
    |  ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.КонтактнаяИнформация КАК ТелефонСлужебный
    |  ПО РеализацияТоваровУслуг.Заказчик = ТелефонСлужебный.Объект
    |   И (ТелефонСлужебный.Тип = &Телефон)
    |   И (ТелефонСлужебный.Вид = &Служебный)
    |  ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.КонтактнаяИнформация КАК АдресФактическийКонтрагент
    |  ПО РеализацияТоваровУслуг.Контрагент = АдресФактическийКонтрагент.Объект
    |   И (АдресФактическийКонтрагент.Тип = &Адрес)
    |   И (АдресФактическийКонтрагент.Вид = &Фактический)
    |  ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.КонтактнаяИнформация КАК АдресФактическийЗаказчик
    |  ПО РеализацияТоваровУслуг.Заказчик = АдресФактическийЗаказчик.Объект
    |   И (АдресФактическийКонтрагент.Тип = &Адрес)
    |   И (АдресФактическийКонтрагент.Вид = &Фактический)
    |ГДЕ
    | РеализацияТоваровУслуг.Ссылка = &Ссылка";
    Иначе
    Запрос.Текст =
    "ВЫБРАТЬ
    | РеализацияТоваровУслуг.Ссылка,
    | РеализацияТоваровУслуг.ПометкаУдаления,
    | РеализацияТоваровУслуг.Номер,
    | РеализацияТоваровУслуг.Дата КАК ДатаВыдачи,
    | РеализацияТоваровУслуг.Проведен,
    | РеализацияТоваровУслуг.ВидОперации,
    | РеализацияТоваровУслуг.Организация,
    | РеализацияТоваровУслуг.БанковскийСчетОрганизации,
    | РеализацияТоваровУслуг.ОтражатьВУправленческомУчете,
    | РеализацияТоваровУслуг.ОтражатьВБухгалтерскомУчете,
    | РеализацияТоваровУслуг.ОтражатьВНалоговомУчете,
    | РеализацияТоваровУслуг.Подразделение,
    | РеализацияТоваровУслуг.Комментарий КАК Комментарии,
    | РеализацияТоваровУслуг.Сделка,
    | РеализацияТоваровУслуг.Склад,
    | РеализацияТоваровУслуг.ДоговорКонтрагента,
    | РеализацияТоваровУслуг.Контрагент КАК Заказчик,
    | РеализацияТоваровУслуг.ТипЦен,
    | РеализацияТоваровУслуг.ВалютаДокумента,
    | РеализацияТоваровУслуг.УчитыватьНДС,
    | РеализацияТоваровУслуг.СуммаВключаетНДС,
    | РеализацияТоваровУслуг.КурсВзаиморасчетов,
    | РеализацияТоваровУслуг.СуммаДокумента,
    | РеализацияТоваровУслуг.КратностьВзаиморасчетов,
    | РеализацияТоваровУслуг.Ответственный,
    | РеализацияТоваровУслуг.ВидПередачи,
    | РеализацияТоваровУслуг.АдресДоставки,
    | РеализацияТоваровУслуг.Грузополучатель,
    | РеализацияТоваровУслуг.Грузоотправитель,
    | РеализацияТоваровУслуг.Проект,
    | РеализацияТоваровУслуг.ДисконтнаяКарта,
    | РеализацияТоваровУслуг.УсловиеПродаж,
    | РеализацияТоваровУслуг.ОтключитьКонтрольВзаиморасчетов,
    | РеализацияТоваровУслуг.ОтпускРазрешил,
    | РеализацияТоваровУслуг.ОтпускПроизвел,
    | РеализацияТоваровУслуг.ДоверенностьНомер,
    | РеализацияТоваровУслуг.ДоверенностьДата,
    | РеализацияТоваровУслуг.ДоверенностьВыдана,
    | РеализацияТоваровУслуг.ДоверенностьЧерезКого,
    | РеализацияТоваровУслуг.ДополнениеКАдресуДоставки,
    | РеализацияТоваровУслуг.МастерКонсультант,
    | РеализацияТоваровУслуг.Заказчик КАК Контрагент,
    | РеализацияТоваровУслуг.Автомобиль,
    | РеализацияТоваровУслуг.ВидЗаказа,
    | РеализацияТоваровУслуг.Пробег,
    | РеализацияТоваровУслуг.Представление,
    | РеализацияТоваровУслуг.МоментВремени,
    | РеализацияТоваровУслуг.Автомобиль.НомернойЗнак,
    | РеализацияТоваровУслуг.Автомобиль.Тип,
    | РеализацияТоваровУслуг.Автомобиль.VIN,
    | РеализацияТоваровУслуг.Автомобиль.ДатаПродажи,
    | РеализацияТоваровУслуг.Автомобиль.МодельИНомерДвигателя,
    | РеализацияТоваровУслуг.Автомобиль.GKB,
    | РеализацияТоваровУслуг.Автомобиль.Рекомендации,
    | РеализацияТоваровУслуг.ОбращениеКлиента,
    | РеализацияТоваровУслуг.Заказчик Как ПодписывающееЛицо,
    | ТелефонДомашний.Представление КАК ТелефонКонтрагентаДомашний,
    | ТелефонСлужебный.Представление КАК ТелефонКонтрагентаСлужебный,
    | АдресФактическийКонтрагент.Представление КАК АдресКонтрагентаФактический,
    | АдресФактическийЗаказчик.Представление КАК АдресЗаказчикаФактический,
    | РеализацияТоваровУслуг.Сделка.Дата КАК ДатаПриема
    |ИЗ
    | Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
    |  ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.КонтактнаяИнформация КАК ТелефонДомашний
    |  ПО РеализацияТоваровУслуг.Заказчик = ТелефонДомашний.Объект
    |   И (ТелефонДомашний.Тип = &Телефон)
    |   И (ТелефонДомашний.Вид = &Домашний)
    |  ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.КонтактнаяИнформация КАК ТелефонСлужебный
    |  ПО РеализацияТоваровУслуг.Заказчик = ТелефонСлужебный.Объект
    |   И (ТелефонСлужебный.Тип = &Телефон)
    |   И (ТелефонСлужебный.Вид = &Служебный)
    |  ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.КонтактнаяИнформация КАК АдресФактическийКонтрагент
    |  ПО РеализацияТоваровУслуг.Заказчик = АдресФактическийКонтрагент.Объект
    |   И (АдресФактическийКонтрагент.Тип = &Адрес)
    |   И (АдресФактическийКонтрагент.Вид = &Фактический)
    |  ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.КонтактнаяИнформация КАК АдресФактическийЗаказчик
    |  ПО РеализацияТоваровУслуг.Контрагент = АдресФактическийЗаказчик.Объект
    |   И (АдресФактическийКонтрагент.Тип = &Адрес)
    |   И (АдресФактическийКонтрагент.Вид = &Фактический)
    |ГДЕ
    | РеализацияТоваровУслуг.Ссылка = &Ссылка";
    КонецЕсли;
    Запрос.УстановитьПараметр("Ссылка",СсылкаНаОбъект);
    Запрос.УстановитьПараметр("Телефон",Перечисления.ТипыКонтактнойИнформации.Телефон);
    Запрос.УстановитьПараметр("Адрес",Перечисления.ТипыКонтактнойИнформации.Адрес);
    Запрос.УстановитьПараметр("Домашний",Справочники.ВидыКонтактнойИнформации.НайтиПоКоду("000000026"));
    Запрос.УстановитьПараметр("Служебный",Справочники.ВидыКонтактнойИнформации.НайтиПоКоду("000000025"));
    Запрос.УстановитьПараметр("Фактический",Справочники.ВидыКонтактнойИнформации.ФактАдресКонтрагента);
    Возврат Запрос.Выполнить().Выбрать();
    КонецФункции
    
    Функция СформироватьЗапросПоУслугам(СсылкаНаОбъект,ВидРаботы)
    
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    | ЗаказНарядРаботы.Работа.Артикул КАК НоменклатураКод,
    | ЗаказНарядРаботы.Работа.Наименование КАК НоменклатураНаименование,
    | ЗаказНарядРаботы.Коэффициент как Количество,
    | ЗаказНарядРаботы.СуммаНДС,
    | ЗаказНарядРаботы.СуммаВсего КАК Сумма,
    | ЗаказНарядРаботы.ИдентификаторРаботы
    |ИЗ
    |  РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
    |
    | Документ.ЗаказНаряд.Работы КАК ЗаказНарядРаботы
    |ГДЕ
    |   КонтактнаяИнформация.Тип = &E-MAil
    | ЗаказНарядРаботы.Ссылка = &Ссылка
    | И ЗаказНарядРаботы.ВидРаботы = &ВидРаботы";
    
    Запрос.УстановитьПараметр("Ссылка",СсылкаНаОбъект.Ссылка);
    Запрос.УстановитьПараметр("ВидРаботы",ВидРаботы);
    Запрос.УстановитьПараметр("Email", Справочники.ВидыКонтактнойИнформации.АдресЭлектроннойПочтыРабочий);
    
    Возврат Запрос.Выполнить().Выгрузить();
    
    КонецФункции
    Функция УслугиБезРекомендацийСервиса()
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    | ЗаказПокупателяУслуги.Сумма
    |ИЗ
    | Документ.ЗаказПокупателя.Услуги КАК ЗаказПокупателяУслуги
    |ГДЕ
    | ЗаказПокупателяУслуги.Ссылка = &Ссылка
    | И ЗаказПокупателяУслуги.ВидРаботы <> Значение(Перечисление.ВидыРабот.ПоРекомендацииСервиса)";
    Запрос.УстановитьПараметр("Ссылка",СсылкаНаОбъект);
    Возврат Запрос.Выполнить().Выгрузить();
    КонецФункции
    Функция СформироватьЗапросПоТоварам(СсылкаНаОбъект,ВидРаботы)
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    | ЗаказНарядТовары.Номенклатура.Артикул КАК НоменклатураКод,
    | ЗаказНарядТовары.Номенклатура.Наименование КАК НоменклатураНаименование,
    | ЗаказНарядТовары.Количество,
    | ЗаказНарядТовары.СуммаНДС,
    | ЗаказНарядТовары.Цена,
    | ЗаказНарядТовары.СуммаВсего КАК Сумма
    |ИЗ
    | Документ.ЗаказНаряд.Товары КАК ЗаказНарядТовары
    |ГДЕ
    | ЗаказНарядТовары.Ссылка = &Ссылка
    | И ЗаказНарядТовары.ВидРаботы = &ВидРаботы";
    
    Запрос.УстановитьПараметр("Ссылка",СсылкаНаОбъект.Ссылка);
    Запрос.УстановитьПараметр("ВидРаботы",ВидРаботы);
    
    Возврат Запрос.Выполнить().Выгрузить();
    
    КонецФункции
    Функция ТоварыБезРекомендацийСервиса()
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    | ЗаказПокупателяТовары.Сумма
    |ИЗ
    | Документ.ЗаказПокупателя.Товары КАК ЗаказПокупателяТовары
    |ГДЕ
    | ЗаказПокупателяТовары.Ссылка = &Ссылка
    | И ЗаказПокупателяТовары.ВидРаботы <> Значение(Перечисление.ВидыРабот.ПоРекомендацииСервиса)";
    Запрос.УстановитьПараметр("Ссылка",СсылкаНаОбъект);
    Возврат Запрос.Выполнить().Выгрузить();
    КонецФункции
    
    
    Функция Печать(СсылкаНаОбъект,ТД,КоличествоЭкземпляров = 1 ,НаПринтер = ложь) Экспорт
    ФормСтрока = "Л = ru_RU; ДП = Истина";
    ПарПредмета=") рубль,) рубля,) рублей,м,копейка,копейки,копеек,м,2";
    
    //Заказ-наряд
    ТД = Новый ТабличныйДокумент;
    Если СсылкаНаОбъект.ВидРемонта = Справочники.ВидыРемонта.НайтиПоНаименованию("Гарантия завода",Истина,) Тогда
    Макет = ПолучитьМакет("Гарантийный");
    //ШАПКА
    Если Найти(СсылкаНаОбъект.ПодразделениеКомпании.Наименование,"MAZDA")>0 Тогда
    ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
    ИначеЕсли Найти(СсылкаНаОбъект.ПодразделениеКомпании.Наименование,"SUZUKI")>0 Тогда
    ОбластьМакета = Макет.ПолучитьОбласть("Шапка1");
    КонецЕсли;
    
    ОбластьМакета.Параметры.Контрагент = СсылкаНаОбъект.Заказчик;
    
    ОбластьМакета.Параметры.АдресКонтрагентаФактический = киПолучитьПредставлениеКИ(СсылкаНаОбъект.Заказчик, Справочники.ВидыКонтактнойИнформации.АдресЮридический);
    Если ОбластьМакета.Параметры.АдресКонтрагентаФактический = "" Тогда
    ОбластьМакета.Параметры.АдресКонтрагентаФактический = киПолучитьПредставлениеКИ(СсылкаНаОбъект.Заказчик, Справочники.ВидыКонтактнойИнформации.АдресПочтовый);
    КонецЕсли;
    Если ОбластьМакета.Параметры.АдресКонтрагентаФактический = "" Тогда
    ОбластьМакета.Параметры.АдресКонтрагентаФактический = киПолучитьПредставлениеКИ(СсылкаНаОбъект.Заказчик, Справочники.ВидыКонтактнойИнформации.АдресФактический);
    КонецЕсли;
    
    ОбластьМакета.Параметры.Номер = СсылкаНаОбъект.Номер;
    ОбластьМакета.Параметры.ДатаПриема = СсылкаНаОбъект.ДатаНачала;
    ОбластьМакета.Параметры.ДатаВыдачи = СсылкаНаОбъект.Датаокончания;
    ОбластьМакета.Параметры.ВидЗаказа = СсылкаНаОбъект.ВидРемонта;
    
    ОбластьМакета.Параметры.ТелефонКонтрагентаДомашний = киПолучитьПредставлениеКИ(СсылкаНаОбъект.Заказчик, Справочники.ВидыКонтактнойИнформации.ТелефонКонтактный);
    ОбластьМакета.Параметры.АвтомобильНомернойЗнак = СсылкаНаОбъект.Автомобиль.ПолучитьОбъект().ЧтениеЗначенияРегистраСведения(Перечисления.ДополнительнаяИнформацияАвтомобилей.ГосНомер,СсылкаНаОбъект.ДатаСоздания);
    ОбластьМакета.Параметры.АвтомобильТип = СсылкаНаОбъект.Автомобиль.Модель;
    ОбластьМакета.Параметры.АвтомобильVIN = СсылкаНаОбъект.Автомобиль.VIN;
    
    ОбластьМакета.Параметры.АвтомобильДатаПродажи = СсылкаНаОбъект.Автомобиль.ДатаНачалаГарантии;
    ОбластьМакета.Параметры.Пробег=СокрЛП(СсылкаНаОбъект.Автомобиль.ПолучитьОбъект().ЧтениеЗначенияРегистраСведения(Перечисления.ДополнительнаяИнформацияАвтомобилей.Пробег,СсылкаНаОбъект.ДатаСоздания));
    ОбластьМакета.Параметры.АвтомобильМодельИНомерДвигателя = Строка(СсылкаНаОбъект.Автомобиль.Модель) + "  " + Строка(СсылкаНаОбъект.Автомобиль.НомерДвигателя);
    ОбластьМакета.Параметры.МастерКонсультант = СсылкаНаОбъект.Мастер;
    
    ТД.АвтоМасштаб = Истина;
    ТД.Вывести(ОбластьМакета);
    НДСОбщий = 0;
    
    Для Каждого ВидРаботы Из Перечисления.ВидыРабот Цикл
    Услуги = СформироватьЗапросПоУслугам(СсылкаНаОбъект,ВидРаботы);
    Товары = СформироватьЗапросПоТоварам(СсылкаНаОбъект,ВидРаботы);
    Если Товары.Итог("Сумма") = 0 И Услуги.Итог("Сумма") = 0 Тогда
    Продолжить;
    КонецЕсли;
    ОбластьМакета = Макет.ПолучитьОбласть("ВидРаботы");
    ОбластьМакета.Параметры.ВидРаботы = ВидРаботы;
    ТД.Вывести(ОбластьМакета);
    Если Услуги.Количество()>0 Тогда
    ТД.Вывести(Макет.ПолучитьОбласть("УслугиШапка"));
    ОбластьМакета = Макет.ПолучитьОбласть("УслугиСтрока");
    Для Каждого Услуга Из Услуги Цикл
    ОбластьМакета.Параметры.Заполнить(Услуга);
    ЗапросИсполнителей = Новый Запрос;
    ЗапросИсполнителей.Текст = "ВЫБРАТЬ
    | ЗаказНарядИсполнители.Исполнитель
    |ИЗ
    | Документ.ЗаказНаряд.Исполнители КАК ЗаказНарядИсполнители
    |ГДЕ
    | ЗаказНарядИсполнители.Ссылка = &Ссылка
    | И ЗаказНарядИсполнители.ИдентификаторРаботы = &ИдентификаторРаботы";
    
    ЗапросИсполнителей.УстановитьПараметр("Ссылка", СсылкаНаОбъект.Ссылка);
    ЗапросИсполнителей.УстановитьПараметр("ИдентификаторРаботы", Услуга.ИдентификаторРаботы);
    ВыборкаИсполнителей = ЗапросИсполнителей.Выполнить().Выбрать();
    
    Если ВыборкаИсполнителей.Количество()=1 Тогда
    ВыборкаИсполнителей.Следующий();
    ОбластьМакета.Параметры.Сотрудник = ВыборкаИсполнителей.Исполнитель;
    ИначеЕсли ВыборкаИсполнителей.Количество()>1 Тогда
    СтрокаИсполнителей="";
    Пока ВыборкаИсполнителей.Следующий() Цикл
    СтрокаИсполнителей = СтрокаИсполнителей + ВыборкаИсполнителей.исполнитель + ", ";
    КонецЦикла;
    СтрокаИсполнителей=Лев(СтрокаИсполнителей,(СтрДлина(СтрокаИсполнителей)-2));
    ОбластьМакета.Параметры.Сотрудник=СтрокаИсполнителей;
    КонецЕсли;
    
    ТД.Вывести(ОбластьМакета);
    КонецЦикла;
    ОбластьМакета = Макет.ПолучитьОбласть("УслугиПодвал");
    ОбластьМакета.Параметры.Количество = Услуги.Итог("Количество");
    ТД.Вывести(ОбластьМакета);
    КонецЕсли;
    Если Товары.Количество()>0 Тогда
    ТД.Вывести(Макет.ПолучитьОбласть("ТоварыШапка"));
    ОбластьМакета = Макет.ПолучитьОбласть("ТоварыСтрока");
    Для Каждого Товар Из Товары Цикл
    ОбластьМакета.Параметры.Заполнить(Товар);
    ТД.Вывести(ОбластьМакета);
    КонецЦикла;
    ОбластьМакета = Макет.ПолучитьОбласть("ТоварыПодвал");
    ОбластьМакета.Параметры.Количество = Товары.Итог("Количество");
    ТД.Вывести(ОбластьМакета);
    КонецЕсли;
    НДСОбщий = НДСОбщий + Услуги.Итог("СуммаНДС")+Товары.Итог("СуммаНДС");
    
    КонецЦикла;
    
    
    ОбластьМакета = Макет.ПолучитьОбласть("Подвал");
    Если Найти(СсылкаНаОбъект.ПодразделениеКомпании.Наименование,"MAZDA")>0 Тогда
    ОбластьМакета.Параметры.Вендор = "ООО «Мазда Мотор Рус» (Россия, 125171 Москва, Ленинградское шоссе, д. 16А, строение 2)";
    ОбластьМакета.Параметры.ТоварныйЗнак = "MAZDA";
    ИначеЕсли Найти(СсылкаНаОбъект.ПодразделениеКомпании.Наименование,"SUZUKI")>0 Тогда
    ОбластьМакета.Параметры.Вендор = "ООО ""Сузуки Мотор Рус"" (119435, г. Москва,Саввинская набережная,15)";
    ОбластьМакета.Параметры.ТоварныйЗнак = "SUZUKI";
    КонецЕсли;
    
    
    ОбластьМакета.Параметры.ОбращениеКлиента = СсылкаНаОбъект.ПричинаОбращения;
    ОбластьМакета.Параметры.Комментарии = СсылкаНаОбъект.Комментарий;
    ОбластьМакета.Параметры.АвтомобильРекомендации = СсылкаНаОбъект.Рекомендации;
    ОбластьМакета.Параметры.МастерКонсультант=СсылкаНаОбъект.Мастер;
    ОбластьМакета.Параметры.ПодписывающееЛицо=СсылкаНаОбъект.Заказчик;
    
    ТД.Вывести(ОбластьМакета);
    ТД.АвтоМасштаб = Истина;
    ТД.ОтображатьСетку = Ложь;
    ТД.ОтображатьЗаголовки = Ложь;
    ТД.Показать("Заказ - Наряд",,Истина);
    
    Иначе
    
    Макет = ПолучитьМакет("НеГарантийный");
    //ШАПКА
    Если Найти(СсылкаНаОбъект.ПодразделениеКомпании.Наименование,"MAZDA")>0 Тогда
    ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
    ИначеЕсли Найти(СсылкаНаОбъект.ПодразделениеКомпании.Наименование,"SUZUKI")>0 Тогда
    ОбластьМакета = Макет.ПолучитьОбласть("Шапка1");
    КонецЕсли;
    
    ОбластьМакета.Параметры.Заказчик = СсылкаНаОбъект.Заказчик;
    ОбластьМакета.Параметры.АдресЗаказчикаФактический = киПолучитьПредставлениеКИ(СсылкаНаОбъект.Заказчик, Справочники.ВидыКонтактнойИнформации.АдресФактический);
    Если ОбластьМакета.Параметры.АдресЗаказчикаФактический = "" Тогда
    ОбластьМакета.Параметры.АдресЗаказчикаФактический = киПолучитьПредставлениеКИ(СсылкаНаОбъект.Заказчик, Справочники.ВидыКонтактнойИнформации.АдресПочтовый);
    КонецЕсли;
    Если ОбластьМакета.Параметры.АдресЗаказчикаФактический = "" Тогда
    ОбластьМакета.Параметры.АдресЗаказчикаФактический = киПолучитьПредставлениеКИ(СсылкаНаОбъект.Заказчик, Справочники.ВидыКонтактнойИнформации.АдресЮридический);
    ОбластьМакета.Параметры.Email = киПолучитьПредставлениеКИ(СсылкаНаОбъект.Контрагент, справочники.ВидыКонтактнойИнформации.ТелефонМобильный);
    КонецЕсли;
    
    ОбластьМакета.Параметры.Контрагент = СсылкаНаОбъект.Заказчик;
    ОбластьМакета.Параметры.АдресКонтрагентаФактический = киПолучитьПредставлениеКИ(СсылкаНаОбъект.Заказчик, Справочники.ВидыКонтактнойИнформации.АдресЮридический);
    Если ОбластьМакета.Параметры.АдресКонтрагентаФактический = "" Тогда
    ОбластьМакета.Параметры.АдресКонтрагентаФактический = киПолучитьПредставлениеКИ(СсылкаНаОбъект.Заказчик, Справочники.ВидыКонтактнойИнформации.АдресПочтовый);
    КонецЕсли;
    Если ОбластьМакета.Параметры.АдресКонтрагентаФактический = "" Тогда
    ОбластьМакета.Параметры.АдресКонтрагентаФактический = киПолучитьПредставлениеКИ(СсылкаНаОбъект.Заказчик, Справочники.ВидыКонтактнойИнформации.АдресФактический);
    КонецЕсли;
    
    ОбластьМакета.Параметры.Номер = СсылкаНаОбъект.Номер;
    ОбластьМакета.Параметры.ДатаПриема = СсылкаНаОбъект.ДатаНачала;
    ОбластьМакета.Параметры.ДатаВыдачи = СсылкаНаОбъект.Датаокончания;
    ОбластьМакета.Параметры.ВидЗаказа = СсылкаНаОбъект.ВидРемонта;
    
    ОбластьМакета.Параметры.ТелефонКонтрагентаДомашний = киПолучитьПредставлениеКИ(СсылкаНаОбъект.Заказчик, Справочники.ВидыКонтактнойИнформации.ТелефонКонтактный);
    
    
    
    ОбластьМакета.Параметры.АвтомобильНомернойЗнак = СсылкаНаОбъект.Автомобиль.ПолучитьОбъект().ЧтениеЗначенияРегистраСведения(Перечисления.ДополнительнаяИнформацияАвтомобилей.ГосНомер,СсылкаНаОбъект.ДатаСоздания);
    ОбластьМакета.Параметры.АвтомобильТип = СсылкаНаОбъект.Автомобиль.Модель;
    ОбластьМакета.Параметры.АвтомобильVIN = СсылкаНаОбъект.Автомобиль.VIN;
    ОбластьМакета.Параметры.СуммаДокумента = СсылкаНаОбъект.СуммаДокумента;
    ОбластьМакета.Параметры.АвтомобильДатаПродажи = СсылкаНаОбъект.Автомобиль.ДатаНачалаГарантии;
    
    ОбластьМакета.Параметры.Пробег=СокрЛП(СсылкаНаОбъект.Автомобиль.ПолучитьОбъект().ЧтениеЗначенияРегистраСведения(Перечисления.ДополнительнаяИнформацияАвтомобилей.Пробег,СсылкаНаОбъект.ДатаСоздания));
    ОбластьМакета.Параметры.АвтомобильМодельИНомерДвигателя = Строка(СсылкаНаОбъект.Автомобиль.Модель) + "  " + Строка(СсылкаНаОбъект.Автомобиль.НомерДвигателя);
    ОбластьМакета.Параметры.МастерКонсультант = СсылкаНаОбъект.Мастер;
    
    ТД.АвтоМасштаб = Истина;
    ТД.Вывести(ОбластьМакета);
    
    
    НДСОбщий=0;
    
    Для Каждого ВидРаботы Из Перечисления.ВидыРабот Цикл
    Услуги = СформироватьЗапросПоУслугам(СсылкаНаОбъект,ВидРаботы);
    Товары = СформироватьЗапросПоТоварам(СсылкаНаОбъект,ВидРаботы);
    Если Товары.Итог("Сумма") = 0 И Услуги.Итог("Сумма") = 0 Тогда
    Продолжить;
    КонецЕсли;
    ОбластьМакета = Макет.ПолучитьОбласть("ВидРаботы");
    ОбластьМакета.Параметры.ВидРаботы = ВидРаботы;
    ТД.Вывести(ОбластьМакета);
    ТД.Вывести(Макет.ПолучитьОбласть("УслугиШапка"));
    ОбластьМакета = Макет.ПолучитьОбласть("УслугиСтрока");
    Для Каждого Услуга Из Услуги Цикл
    ОбластьМакета.Параметры.Заполнить(Услуга);
    ЗапросИсполнителей = Новый Запрос;
    ЗапросИсполнителей.Текст = "ВЫБРАТЬ
    | ЗаказНарядИсполнители.Исполнитель
    |ИЗ
    | Документ.ЗаказНаряд.Исполнители КАК ЗаказНарядИсполнители
    |ГДЕ
    | ЗаказНарядИсполнители.Ссылка = &Ссылка
    | И ЗаказНарядИсполнители.ИдентификаторРаботы = &ИдентификаторРаботы";
    
    ЗапросИсполнителей.УстановитьПараметр("Ссылка", СсылкаНаОбъект.Ссылка);
    ЗапросИсполнителей.УстановитьПараметр("ИдентификаторРаботы", Услуга.ИдентификаторРаботы);
    ВыборкаИсполнителей = ЗапросИсполнителей.Выполнить().Выбрать();
    
    Если ВыборкаИсполнителей.Количество()=1 Тогда
    ВыборкаИсполнителей.Следующий();
    ОбластьМакета.Параметры.Сотрудник = ВыборкаИсполнителей.Исполнитель;
    ИначеЕсли ВыборкаИсполнителей.Количество()>1 Тогда
    СтрокаИсполнителей="";
    Пока ВыборкаИсполнителей.Следующий() Цикл
    СтрокаИсполнителей = СтрокаИсполнителей + ВыборкаИсполнителей.исполнитель + ", ";
    КонецЦикла;
    СтрокаИсполнителей=Лев(СтрокаИсполнителей,(СтрДлина(СтрокаИсполнителей)-2));
    ОбластьМакета.Параметры.Сотрудник=СтрокаИсполнителей;
    КонецЕсли;
    
    ТД.Вывести(ОбластьМакета);
    КонецЦикла;
    ОбластьМакета = Макет.ПолучитьОбласть("УслугиПодвал");
    ОбластьМакета.Параметры.Количество = Услуги.Итог("Количество");
    ОбластьМакета.Параметры.Сумма = Услуги.Итог("Сумма");
    ТД.Вывести(ОбластьМакета);
    ТД.Вывести(Макет.ПолучитьОбласть("ТоварыШапка"));
    ОбластьМакета = Макет.ПолучитьОбласть("ТоварыСтрока");
    Для Каждого Товар Из Товары Цикл
    ОбластьМакета.Параметры.Заполнить(Товар);
    ТД.Вывести(ОбластьМакета);
    КонецЦикла;
    ОбластьМакета = Макет.ПолучитьОбласть("ТоварыПодвал");
    ОбластьМакета.Параметры.Количество = Товары.Итог("Количество");
    ОбластьМакета.Параметры.Сумма = Товары.Итог("Сумма");
    ТД.Вывести(ОбластьМакета);
    НДСОбщий = НДСОбщий + Услуги.Итог("СуммаНДС")+Товары.Итог("СуммаНДС");
    КонецЦикла;
    
    
    
    ОбластьМакета = Макет.ПолучитьОбласть("Подвал");
    
    //MAZDA/SUZUKI Вендор
    Если Найти(СсылкаНаОбъект.ПодразделениеКомпании.Наименование,"MAZDA")>0 Тогда
    ОбластьМакета.Параметры.Вендор = "ООО «Мазда Мотор Рус» (Россия, 125171 Москва, Ленинградское шоссе, д. 16А, строение 2)";
    ОбластьМакета.Параметры.ТоварныйЗнак = "MAZDA";
    ИначеЕсли Найти(СсылкаНаОбъект.ПодразделениеКомпании.Наименование,"SUZUKI")>0 Тогда
    ОбластьМакета.Параметры.Вендор = "ООО ""Сузуки Мотор Рус"" (119435, г. Москва,Саввинская набережная,15)";
    ОбластьМакета.Параметры.ТоварныйЗнак = "SUZUKI";
    КонецЕсли;
    
    ОбластьМакета.Параметры.СуммаПрописью =Строка(СсылкаНаОбъект.СуммаДокумента)+" ("+Строка(ЧислоПрописью(СсылкаНаОбъект.СуммаДокумента,ФормСтрока,ПарПредмета));
    ОбластьМакета.Параметры.СуммаНДСПрописью =Строка(НДСОбщий)+" ("+Строка(ЧислоПрописью(НДСОбщий,ФормСтрока,ПарПредмета));
    ОбластьМакета.Параметры.ОбращениеКлиента = СсылкаНаОбъект.ПричинаОбращения;
    ОбластьМакета.Параметры.Комментарии = СсылкаНаОбъект.Комментарий;
    ОбластьМакета.Параметры.АвтомобильРекомендации = СсылкаНаОбъект.Рекомендации;
    ОбластьМакета.Параметры.МастерКонсультант=СсылкаНаОбъект.Мастер;
    ОбластьМакета.Параметры.ПодписывающееЛицо=СсылкаНаОбъект.Заказчик;
    
    ТД.Вывести(ОбластьМакета);
    ТД.АвтоМасштаб = Истина;
    ТД.ОтображатьСетку = Ложь;
    ТД.ОтображатьЗаголовки = Ложь;
    ТД.Показать("Заказ - Наряд",,Истина);
    КонецЕсли;
    
    //АКТ ПРИЕМА ПЕРЕДАЧИ ВЫПОЛНЕНИХ РАБОТ
    
    ТД = Новый ТабличныйДокумент;
    Макет = ПолучитьМакет("Акт");
    //ШАПКА
    Если Найти(СсылкаНаОбъект.ПодразделениеКомпании.Наименование,"MAZDA")>0 Тогда
    ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
    ИначеЕсли Найти(СсылкаНаОбъект.ПодразделениеКомпании.Наименование,"SUZUKI")>0 Тогда
    ОбластьМакета = Макет.ПолучитьОбласть("Шапка1");
    КонецЕсли;
    
    ОбластьМакета.Параметры.Заказчик = СсылкаНаОбъект.Заказчик;
    ОбластьМакета.Параметры.АдресЗаказчикаФактический = киПолучитьПредставлениеКИ(СсылкаНаОбъект.Заказчик, Справочники.ВидыКонтактнойИнформации.АдресФактический);
    ОбластьМакета.Параметры.Email = киПолучитьПредставлениеКИ(СсылкаНаОбъект.Контрагент, справочники.ВидыКонтактнойИнформации.ТелефонМобильный);
    Если ОбластьМакета.Параметры.АдресЗаказчикаФактический = "" Тогда
    ОбластьМакета.Параметры.АдресЗаказчикаФактический = киПолучитьПредставлениеКИ(СсылкаНаОбъект.Заказчик, Справочники.ВидыКонтактнойИнформации.АдресПочтовый);
    КонецЕсли;
    Если ОбластьМакета.Параметры.АдресЗаказчикаФактический = "" Тогда
    ОбластьМакета.Параметры.АдресЗаказчикаФактический = киПолучитьПредставлениеКИ(СсылкаНаОбъект.Заказчик, Справочники.ВидыКонтактнойИнформации.АдресЮридический);
    КонецЕсли;
    
    ОбластьМакета.Параметры.Контрагент = СсылкаНаОбъект.Заказчик;
    ОбластьМакета.Параметры.АдресКонтрагентаФактический = киПолучитьПредставлениеКИ(СсылкаНаОбъект.Заказчик, Справочники.ВидыКонтактнойИнформации.АдресЮридический);
    Если ОбластьМакета.Параметры.АдресКонтрагентаФактический = "" Тогда
    ОбластьМакета.Параметры.АдресКонтрагентаФактический = киПолучитьПредставлениеКИ(СсылкаНаОбъект.Заказчик, Справочники.ВидыКонтактнойИнформации.АдресПочтовый);
    КонецЕсли;
    Если ОбластьМакета.Параметры.АдресКонтрагентаФактический = "" Тогда
    ОбластьМакета.Параметры.АдресКонтрагентаФактический = киПолучитьПредставлениеКИ(СсылкаНаОбъект.Заказчик, Справочники.ВидыКонтактнойИнформации.АдресФактический);
    КонецЕсли;
    
    ОбластьМакета.Параметры.Номер = СсылкаНаОбъект.Номер;
    ОбластьМакета.Параметры.ДатаПриема = СсылкаНаОбъект.ДатаНачала;
    ОбластьМакета.Параметры.ДатаВыдачи = СсылкаНаОбъект.Датаокончания;
    ОбластьМакета.Параметры.ВидЗаказа = СсылкаНаОбъект.ВидРемонта;
    ОбластьМакета.Параметры.ДатаФормат = Формат(СсылкаНаОбъект.ДатаНачала,"ДЛФ=D");
    
    
    ОбластьМакета.Параметры.АвтомобильНомернойЗнак = СсылкаНаОбъект.Автомобиль.ПолучитьОбъект().ЧтениеЗначенияРегистраСведения(Перечисления.ДополнительнаяИнформацияАвтомобилей.ГосНомер,СсылкаНаОбъект.ДатаСоздания);
    ОбластьМакета.Параметры.АвтомобильТип = СсылкаНаОбъект.Автомобиль.Модель;
    ОбластьМакета.Параметры.АвтомобильVIN = СсылкаНаОбъект.Автомобиль.VIN;
    ОбластьМакета.Параметры.СуммаДокумента = СсылкаНаОбъект.СуммаДокумента;
    ЗапросДатаПродажи = Новый Запрос;
    ЗапросДатаПродажи.Текст = "ВЫБРАТЬ
    | ПродажиАвтомобилей.Период
    |ИЗ
    | РегистрНакопления.ПродажиАвтомобилей КАК ПродажиАвтомобилей
    |ГДЕ
    | ПродажиАвтомобилей.Автомобиль.Ссылка = &Ссылка";
    ЗапросДатаПродажи.УстановитьПараметр("Ссылка",СсылкаНаОбъект.Автомобиль);
    Выборка = ЗапросДатаПродажи.Выполнить().Выбрать();
    Если Выборка.Количество()<>0 Тогда
    Выборка.Следующий();
    ОбластьМакета.Параметры.АвтомобильДатаПродажи=Выборка.Период;
    КонецЕсли;
    
    ОбластьМакета.Параметры.Пробег=СокрЛП(СсылкаНаОбъект.Автомобиль.ПолучитьОбъект().ЧтениеЗначенияРегистраСведения(Перечисления.ДополнительнаяИнформацияАвтомобилей.Пробег,СсылкаНаОбъект.ДатаСоздания));
    ОбластьМакета.Параметры.МастерКонсультант = СсылкаНаОбъект.Мастер;
    ТД.Вывести(ОбластьМакета);
    
    НДСОбщий=0;СтоимостьРабот = 0;НДСРабот = 0;СтоимостьЗЧ = 0;НДСЗЧ = 0;
    
    Для Каждого ВидРаботы Из Перечисления.ВидыРабот Цикл
    Услуги = СформироватьЗапросПоУслугам(СсылкаНаОбъект,ВидРаботы);
    Товары = СформироватьЗапросПоТоварам(СсылкаНаОбъект,ВидРаботы);
    Если Товары.Итог("Сумма") = 0 И Услуги.Итог("Сумма") = 0 Тогда
    Продолжить;
    КонецЕсли;
    ОбластьМакета = Макет.ПолучитьОбласть("ВидРаботы");
    ОбластьМакета.Параметры.ВидРаботы = ВидРаботы;
    ТД.Вывести(ОбластьМакета);
    ТД.Вывести(Макет.ПолучитьОбласть("УслугиШапка"));
    ОбластьМакета = Макет.ПолучитьОбласть("УслугиСтрока");
    Для Каждого Услуга Из Услуги Цикл
    ОбластьМакета.Параметры.Заполнить(Услуга);
    ЗапросИсполнителей = Новый Запрос;
    ЗапросИсполнителей.Текст = "ВЫБРАТЬ
    | ЗаказНарядИсполнители.Исполнитель
    |ИЗ
    | Документ.ЗаказНаряд.Исполнители КАК ЗаказНарядИсполнители
    |ГДЕ
    | ЗаказНарядИсполнители.Ссылка = &Ссылка
    | И ЗаказНарядИсполнители.ИдентификаторРаботы = &ИдентификаторРаботы";
    
    ЗапросИсполнителей.УстановитьПараметр("Ссылка", СсылкаНаОбъект.Ссылка);
    ЗапросИсполнителей.УстановитьПараметр("ИдентификаторРаботы", Услуга.ИдентификаторРаботы);
    ВыборкаИсполнителей = ЗапросИсполнителей.Выполнить().Выбрать();
    
    Если ВыборкаИсполнителей.Количество()=1 Тогда
    ВыборкаИсполнителей.Следующий();
    ОбластьМакета.Параметры.Сотрудник = ВыборкаИсполнителей.Исполнитель;
    ИначеЕсли ВыборкаИсполнителей.Количество()>1 Тогда
    СтрокаИсполнителей="";
    Пока ВыборкаИсполнителей.Следующий() Цикл
    СтрокаИсполнителей = СтрокаИсполнителей + ВыборкаИсполнителей.исполнитель + ", ";
    КонецЦикла;
    СтрокаИсполнителей=Лев(СтрокаИсполнителей,(СтрДлина(СтрокаИсполнителей)-2));
    ОбластьМакета.Параметры.Сотрудник=СтрокаИсполнителей;
    КонецЕсли;
    
    ТД.Вывести(ОбластьМакета);
    КонецЦикла;
    ОбластьМакета = Макет.ПолучитьОбласть("УслугиПодвал");
    ОбластьМакета.Параметры.Количество = Услуги.Итог("Количество");
    ОбластьМакета.Параметры.Сумма = Услуги.Итог("Сумма");
    ТД.Вывести(ОбластьМакета);
    ТД.Вывести(Макет.ПолучитьОбласть("ТоварыШапка"));
    ОбластьМакета = Макет.ПолучитьОбласть("ТоварыСтрока");
    Для Каждого Товар Из Товары Цикл
    ОбластьМакета.Параметры.Заполнить(Товар);
    ТД.Вывести(ОбластьМакета);
    КонецЦикла;
    ОбластьМакета = Макет.ПолучитьОбласть("ТоварыПодвал");
    ОбластьМакета.Параметры.Количество = Товары.Итог("Количество");
    ОбластьМакета.Параметры.Сумма = Товары.Итог("Сумма");
    ТД.Вывести(ОбластьМакета);
    НДСОбщий = НДСОбщий + Услуги.Итог("СуммаНДС")+Товары.Итог("СуммаНДС");
    СтоимостьРабот = СтоимостьРабот + Услуги.Итог("Сумма");
    НДСРабот = НДСРабот + Услуги.Итог("СуммаНДС");
    СтоимостьЗЧ = СтоимостьЗЧ + Товары.Итог("Сумма");
    НДСЗЧ = НДСЗЧ + Товары.Итог("СуммаНДС");
    КонецЦикла;
    
    ОбластьМакета = Макет.ПолучитьОбласть("Подвал1");
    ОбластьМакета.Параметры.СтоимостьРабот = СтоимостьРабот;
    ОбластьМакета.Параметры.НДСРабот = НДСРабот;
    ОбластьМакета.Параметры.СтоимостьЗЧ = СтоимостьЗЧ;
    ОбластьМакета.Параметры.НДСЗЧ = НДСЗЧ;
    ОбластьМакета.Параметры.СтоимостьОбщая = СсылкаНаОбъект.СуммаДокумента;
    ОбластьМакета.Параметры.НДСОбщий = НДСОбщий;
    ОбластьМакета.Параметры.СуммаПрописью =Строка(СсылкаНаОбъект.СуммаДокумента)+" ("+Строка(ЧислоПрописью(СсылкаНаОбъект.СуммаДокумента,ФормСтрока,ПарПредмета));
    ОбластьМакета.Параметры.СуммаНДСПрописью =Строка(НДСОбщий)+" ("+Строка(ЧислоПрописью(НДСОбщий,ФормСтрока,ПарПредмета));
    ТД.Вывести(ОбластьМакета);
    Если СсылкаНаОбъект.ВидРемонта.Наименование <> "Гарантийный" Тогда
    ОбластьМакета = Макет.ПолучитьОбласть("НеГарантия");
    ТД.Вывести(ОбластьМакета);
    КонецЕсли;
    ОбластьМакета = Макет.ПолучитьОбласть("Подвал2");
    ОбластьМакета.Параметры.ПодписывающееЛицо=СсылкаНаОбъект.Заказчик;
    ОбластьМакета.Параметры.МастерКонсультант=СсылкаНаОбъект.Мастер;
    ТД.Вывести(ОбластьМакета);
    ТД.АвтоМасштаб = Истина;
    ТД.ОтображатьСетку = Ложь;
    ТД.ОтображатьЗаголовки = Ложь;
    ТД.Показать("АКТ ПРИЕМА ПЕРЕДАЧИ ВЫПОЛНЕНИХ РАБОТ",,Ложь);
    
    КонецФункции
  2. Максим
    Offline

    Максим Опытный в 1С

    Регистрация:
    28 фев 2008
    Сообщения:
    684
    Симпатии:
    7
    Баллы:
    29
    А у вас какие мысли по этому поводу? Где хранится эл. адрес?
  3. TopicStarter Overlay
    litome
    Offline

    litome

    Регистрация:
    22 сен 2012
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Предположительно там же где и "АдресФактическийКонтрагент" и "ТелефонКонтрагентаДомашний" В справочники контрагентов,в табличном поле. Только как он представлен в базе?
    Запрос | ЭлектронныйАдрес.Представление КАК ЭлектронныйАдресКонтрагентаРабочий,
    не работает.
  4. Максим
    Offline

    Максим Опытный в 1С

    Регистрация:
    28 фев 2008
    Сообщения:
    684
    Симпатии:
    7
    Баллы:
    29
    РегистрСведений.КонтактнаяИнформация
    Там хранится "АдресФактическийКонтрагент". Если "АдресФактическийКонтрагент" отображается в форме элемента справочника контрагенты, это вовсе не означает, что адрес является реквизитом справочника.
    А где же может хранится эл. адрес? Как вы думаете?
  5. TopicStarter Overlay
    litome
    Offline

    litome

    Регистрация:
    22 сен 2012
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    РегистрСведений.КонтактнаяИнформация.АдресЭлектроннойПочты ?
  6. Максим
    Offline

    Максим Опытный в 1С

    Регистрация:
    28 фев 2008
    Сообщения:
    684
    Симпатии:
    7
    Баллы:
    29
    Ну, да в этом же регистре, только смотрите:
    Код:
      |  ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.КонтактнаяИнформация КАК ТелефонСлужебный
    |  ПО РеализацияТоваровУслуг.Заказчик = ТелефонСлужебный.Объект
    |   И (ТелефонСлужебный.Тип = &Телефон)
    |   И (ТелефонСлужебный.Вид = &Служебный)
    Чтобы получить служебный телефон делается отбор в связи, по измерениям "тип" и "вид", это для того чтобы получить телефон служебный, а не другую информацию по этому контрагенту (Посмотрите структуру регистра КонтактнаяИнформация). Вы должны сделать по аналогии.

Поделиться этой страницей