8.х подскажите ...

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем noname, 31 июл 2008.

  1. TopicStarter Overlay
    noname
    Offline

    noname

    Регистрация:
    21 май 2008
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    Подскажите, для колонок Количество и Цена нужно создать обработчик события ПриИзменении, в котором вызвать процедуру РассчитатьСумму() из Общего модуля РаботаСДокументами

    Код Общего модуля РаботаСДокументами:
    Код:
    Процедура РассчитатьСумму(СтрокаТабличнойЧасти) Экспорт
    
    СтрокаТабличнойЧасти.Сумма = СтрокаТабличнойЧасти.Количество * СтрокаТабличнойЧасти.Цена;
    
    КонецПроцедуры
    
    
    Затем жму на поле количество два раза, вызываю свойство ПриИзменении и пишу код:

    Код:
    Процедура ПереченьНоменклатурыКоличествоПриИзменении(Элемент)
    
    СтрокаТабличнойЧасти = ЭлементыФормы.Номенклатура.ТекущиеДанные;
    РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
    
    КонецПроцедуры
    
    

    На ошибки проверяю - все хорошо, но когда проверяю в режиме предприятия выдает: Поле объекта Номенклатура не обнаружено.

    Смысл в том, что при изменении количества и цены Сумма считалась автоматически ...

    Скриншот прилагается ...

    Вложения:

    • Untitled_1.jpg
      Untitled_1.jpg
      Размер файла:
      125,4 КБ
      Просмотров:
      74
  2. AlexFF
    Offline

    AlexFF Разбирающийся

    Регистрация:
    6 мар 2007
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    26
    Код:
    Процедура ПереченьНоменклатурыКоличествоПриИзменении(Элемент)
    
    СтрокаТабличнойЧасти = ЭлементыФормы.ПереченьНоменклатуры.ТекущиеДанные;
    РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
    
    КонецПроцедуры
    
    
    
  3. TopicStarter Overlay
    noname
    Offline

    noname

    Регистрация:
    21 май 2008
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    доперло теперь в чем косяк,

    у меня было так:

    Код:
    Процедура Пере[b]чн[/b]ьНоменклатурыКоличествоПриИзменении(Элемент)
    СтрокаТабличнойЧасти = ЭлементыФормы.Пере[b]чен[/b]ьНоменклатуры.ТекущиеДанные;
    РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
    
    КонецПроцедуры
    
    
Похожие темы
  1. jhlk
    Ответов:
    1
    Просмотров:
    747
  2. Сергей5791
    Ответов:
    15
    Просмотров:
    973
  3. Вольный
    Ответов:
    1
    Просмотров:
    297
Загрузка...

Поделиться этой страницей