8.х Подскажите по табличному полю документа

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем sam441, 20 ноя 2009.

  1. TopicStarter Overlay
    sam441
    Offline

    sam441

    Регистрация:
    24 авг 2009
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Заранее скажу поиском пользовался, но до конца не разобрался, думаю знающему человеку не составит труда ответить. Вообщем имеется документ "Поступление товаров и услуг", в табличной части документа на вкладке товары не заполнено поле "Ед." Пытаюсь его заполнить, но не могу понять как обращаться к табличной части, вот код:

    Код:
    Выборка=Документы.ПоступлениеТоваровУслуг.Выбрать();
    Пока Выборка.Следующий() Цикл
    Элемент=Выборка.ПолучитьОбъект();
    Для Каждого Текущаястрока  Из Выборка.Товары Цикл
    ЕдИзмер=Текущаястрока.Номенклатура.БазоваяЕдиницаИзмерения;
    Сообщить(Элемент.Номер+" "+ЕдИзмер);
    Текущаястрока.ЕдиницаИзмерения=ЕдИзмер;
    КонецЦикла;    
    Элемент.Записать();
    КонецЦикла;
    
    
    
    На этапе Текущая строка.... выпадает ошибка:"Поле объекта недоступно для записи (ЕдиницаИзмерения)". При выполнении значения выводятся верно, но как записать их в поле табличной части документа не пойму, заранее спасибо

    Путем научного тыка удалось избавиться от ошибки путем замены строки
    Код:
    Для Каждого Текущаястрока  Из Выборка.Товары Цикл
    
    на
    Код:
    Для Каждого Текущаястрока  Из Элемент.Товары Цикл
    
    , но данные все равно не заносятся..
  2. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.565
    Симпатии:
    716
    Баллы:
    204
  3. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.638
    Симпатии:
    948
    Баллы:
    204
    Посмотри типы у Единицы измерения и базовойЕдиницы измерения. У единицы СправочникЕдиницы измерения , а у базовой Справочник.КлассификаторЕдИзмерений
  4. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    Конфигурация какая? И проверьте в конфигураторе как реквизмит называется. Код примерно такое будет:
    Код:
    // выборка документов
    Выборка=Документы.ПоступлениеТоваровУслуг.Выбрать();
    // объод выборки
    Пока Выборка.Следующий() Цикл
    // получаем документ, чтобы его изменять
    ДокументОбъект = Выборка.ПолучитьОбъект();
    // обходим строки объекта, полученного для изменения
    Для Каждого СтрокаДокумента Из ДокументОбъект.Товары Цикл
    // заполняем единицу измерения для БП
    СтрокаДокумент.ЕдиницаИзмерения = СтрокаДокумента.Номенклатура.БазоваяЕдиницаИзмерения;
    // или для УТ
    СтрокаДокумент.ЕдиницаИзмерения = СтрокаДокумента.Номенклатура.ЕдиницаХраненияОстатков;
    КонецЦикла;  
    
    ДокументОбъект.Записать();
    
    КонецЦикла;
    

Поделиться этой страницей