7.7 Подскажите как поменять вывод данных р/с

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Sanyh, 24 дек 2012.

  1. TopicStarter Overlay
    Sanyh
    Offline

    Sanyh Опытный в 1С

    Регистрация:
    27 сен 2012
    Сообщения:
    83
    Симпатии:
    0
    Баллы:
    26
    Есть внешний отчет в нем прописаны вывод данных р/с, так вот он выводит данные р/с основного, а мне надо переделать чтобы выводились данные из документа релазиции
    это блок текущий, выводит основной банкоский счет
    Код:
     ПлательщикНаПечать = "";
    Если ФлагПлательщика=1 Тогда
    Если ВариантОтправки=1 Тогда
    СчетКонтрагента = "";
    СчетКонтрагента = Константа.ОсновнойБанковскийСчет;
    ГрузополучательАдрес=СокрЛП(Константа.НаименованиеОрганизации);
    глДобавитьРеквизит(ГрузополучательАдрес, ", ", глПредставлениеАдреса(Константа.АдресОрганизации));
    Если ПустоеЗначение(СчетКонтрагента) = 0 Тогда
    глДобавитьРеквизит(ГрузополучательАдрес, ", р/с ", СокрЛП(СчетКонтрагента.Номер) + " в " + СчетКонтрагента.БанкОрганизации);
    глДобавитьРеквизит(ГрузополучательАдрес, ", БИК ", СокрЛП(СчетКонтрагента.БанкОрганизации.Код));
    глДобавитьРеквизит(ГрузополучательАдрес, ", корр/с ", СчетКонтрагента.БанкОрганизации.КоррСчет);
    КонецЕсли;
    ПлательщикНаПечать=ГрузополучательАдрес;
    Иначе
    Если ПустоеЗначение(Грузоотправитель)=0 Тогда
    СчетКонтрагента = "";
    СчетКонтрагента = глРасчетныйСчетКонтрагента(Грузоотправитель);
    ГрузополучательАдрес = СокрЛП(Грузоотправитель.ПолнНаименование)+", "+СокрЛП(Грузоотправитель.ЮридическийАдрес);
    Если ПустоеЗначение(СчетКонтрагента) = 0 Тогда
    глДобавитьРеквизит(ГрузополучательАдрес, ", р/с ", СокрЛП(СчетКонтрагента.Номер) + " в " + СчетКонтрагента.БанкОрганизации);
    глДобавитьРеквизит(ГрузополучательАдрес, ", БИК ", СокрЛП(СчетКонтрагента.БанкОрганизации.Код));
    глДобавитьРеквизит(ГрузополучательАдрес, ", корр/с ", СчетКонтрагента.БанкОрганизации.КоррСчет);
    КонецЕсли;
    ПлательщикНаПечать=ГрузополучательАдрес;
    КонецЕсли;
    КонецЕсли;
    ИначеЕсли ФлагПлательщика=2 Тогда
    Если ВариантПолучения=1 Тогда
    СчетКонтрагента = "";
    СчетКонтрагента = Константа.ОсновнойБанковскийСчет;
    ГрузополучательАдрес=СокрЛП(Константа.НаименованиеОрганизации);
    глДобавитьРеквизит(ГрузополучательАдрес, ", ", глПредставлениеАдреса(Константа.АдресОрганизации));
    Если ПустоеЗначение(СчетКонтрагента) = 0 Тогда
    глДобавитьРеквизит(ГрузополучательАдрес, ", р/с ", СокрЛП(СчетКонтрагента.Номер) + " в " + СчетКонтрагента.БанкОрганизации);
    глДобавитьРеквизит(ГрузополучательАдрес, ", БИК ", СокрЛП(СчетКонтрагента.БанкОрганизации.Код));
    глДобавитьРеквизит(ГрузополучательАдрес, ", корр/с ", СчетКонтрагента.БанкОрганизации.КоррСчет);
    КонецЕсли;
    ПлательщикНаПечать=ГрузополучательАдрес;
    Иначе
    Если ПустоеЗначение(Грузополучатель)=0 Тогда
    СчетКонтрагента = "";
    СчетКонтрагента = глРасчетныйСчетКонтрагента(Грузополучатель);
    ГрузополучательАдрес = СокрЛП(Грузополучатель.ПолнНаименование)+", "+СокрЛП(Грузополучатель.ЮридическийАдрес);
    Если ПустоеЗначение(СчетКонтрагента) = 0 Тогда
    глДобавитьРеквизит(ГрузополучательАдрес, ", р/с ", СокрЛП(СчетКонтрагента.Номер) + " в " + СчетКонтрагента.БанкОрганизации);
    глДобавитьРеквизит(ГрузополучательАдрес, ", БИК ", СокрЛП(СчетКонтрагента.БанкОрганизации.Код));
    глДобавитьРеквизит(ГрузополучательАдрес, ", корр/с ", СчетКонтрагента.БанкОрганизации.КоррСчет);
    КонецЕсли;
    ПлательщикНаПечать=ГрузополучательАдрес;
    КонецЕсли;
    КонецЕсли;
    Иначе
    Если ПустоеЗначение(Плательщик)=0 Тогда
    СчетКонтрагента = "";
    СчетКонтрагента = глРасчетныйСчетКонтрагента(Плательщик);
    ГрузополучательАдрес = СокрЛП(Плательщик.ПолнНаименование)+", "+СокрЛП(Плательщик.ЮридическийАдрес);
    Если ПустоеЗначение(СчетКонтрагента) = 0 Тогда
    глДобавитьРеквизит(ГрузополучательАдрес, ", р/с ", СокрЛП(СчетКонтрагента.Номер) + " в " + СчетКонтрагента.БанкОрганизации);
    глДобавитьРеквизит(ГрузополучательАдрес, ", БИК ", СокрЛП(СчетКонтрагента.БанкОрганизации.Код));
    глДобавитьРеквизит(ГрузополучательАдрес, ", корр/с ", СчетКонтрагента.БанкОрганизации.КоррСчет);
    КонецЕсли;
    ПлательщикНаПечать=ГрузополучательАдрес;
    КонецЕсли;
    КонецЕсли;
    на форме Документ.Реализация нашол:
    Код:
    глПредставлениеРасчСчета(Контекст)
    СчетКонтрагента = Константа.ОсновнойБанковскийСчет;
    нужно заменить на
    СчетКонтрагента = глПредставлениеРасчСчета(Контекст);

    так чтоли?
  2. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    >а мне надо переделать чтобы выводились данные из документа релазиции

    т.е. у тебя этот счет явно задан (т.е. выбирается) на форме дока?
  3. TopicStarter Overlay
    Sanyh
    Offline

    Sanyh Опытный в 1С

    Регистрация:
    27 сен 2012
    Сообщения:
    83
    Симпатии:
    0
    Баллы:
    26
    это документ TTН который автоматически заполняется на основании документа реализации, но в данный момент реквизиты банка берутся не из документа реализации а из справочника основного расчетного счета и получается что везде один банк стоит. поэтому надо переделать чтобы реквизиты тоже брались из документа реализации
  4. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    нужно изначально проще "писать", чтобы потом было проще дописывать.
    Код:
    Процедура ЗаполнитьНекиеРеквизиты(СчетКонтрагента,Контр = "")
    
    Если Контр = "" Тогда
    КонтрАдрес = СокрЛП(Константа.НаименованиеОрганизации);
    глДобавитьРеквизит(КонтрАдрес, ", ", глПредставлениеАдреса(Константа.АдресОрганизации));
    Иначе
    КонтрАдрес = СокрЛП(Контр.ПолнНаименование)+", "+СокрЛП(Контр.ЮридическийАдрес)
    КонецЕсли;
    
    
    Если ПустоеЗначение(СчетКонтрагента) = 0 Тогда
    глДобавитьРеквизит(КонтрАдрес, ", р/с ", СокрЛП(СчетКонтрагента.Номер) + " в " + СчетКонтрагента.БанкОрганизации);
    глДобавитьРеквизит(КонтрАдрес, ", БИК ", СокрЛП(СчетКонтрагента.БанкОрганизации.Код));
    глДобавитьРеквизит(КонтрАдрес, ", корр/с ", СчетКонтрагента.БанкОрганизации.КоррСчет);
    КонецЕсли;
    
    ПлательщикНаПечать=КонтрАдрес;
    
    КонецПроцедуры
    Процедура Осн()
    
    ПлательщикНаПечать = "";
    Если ФлагПлательщика=1 Тогда
    Если ВариантОтправки=1 Тогда
    ЗаполнитьНекиеРеквизиты(Константа.ОсновнойБанковскийСчет);
    Иначе
    Если ПустоеЗначение(Грузоотправитель)=0 Тогда
    ЗаполнитьНекиеРеквизиты(глРасчетныйСчетКонтрагента(Грузоотправитель),Грузоотправитель);
    КонецЕсли;
    КонецЕсли;
    ИначеЕсли ФлагПлательщика=2 Тогда
    Если ВариантПолучения=1 Тогда
    ЗаполнитьНекиеРеквизиты(Константа.ОсновнойБанковскийСчет);
    Иначе
    Если ПустоеЗначение(Грузополучатель)=0 Тогда
    ЗаполнитьНекиеРеквизиты(глРасчетныйСчетКонтрагента(Грузополучатель),Грузополучатель);
    КонецЕсли;
    КонецЕсли;
    Иначе
    Если ПустоеЗначение(Плательщик)=0 Тогда
    ЗаполнитьНекиеРеквизиты(глРасчетныйСчетКонтрагента(Плательщик),Плательщик);
    КонецЕсли;
    КонецЕсли;
    
    КонецПроцедуры
    если речь идет о вашей организации, тогда подмена идет тут вместо "ЗаполнитьНекиеРеквизиты(Константа.ОсновнойБанковскийСчет)" указываем что-то типа "ЗаполнитьНекиеРеквизиты(ДокРеализация.РеквизитБанкСчет)"
  5. TopicStarter Overlay
    Sanyh
    Offline

    Sanyh Опытный в 1С

    Регистрация:
    27 сен 2012
    Сообщения:
    83
    Симпатии:
    0
    Баллы:
    26
    переписать эту часть как вы указали все в блоке?
  6. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    я просто на две процедуры все разбил
  7. TopicStarter Overlay
    Sanyh
    Offline

    Sanyh Опытный в 1С

    Регистрация:
    27 сен 2012
    Сообщения:
    83
    Симпатии:
    0
    Баллы:
    26
    Код:
    <<?>>Процедура ЗаполнитьНекиеРеквизиты(СчетКонтрагента,Контр = "")
    {F:\base\EXTFORMS\TN_2012.ERT(1784)}: Ожидается ключевое слово 'КонецПроцедуры' ('EndProcedure')
  8. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    не туда воткнули, смотрите тело модуля! процедура не может находиться внутри другой процедуры или функции
  9. TopicStarter Overlay
    Sanyh
    Offline

    Sanyh Опытный в 1С

    Регистрация:
    27 сен 2012
    Сообщения:
    83
    Симпатии:
    0
    Баллы:
    26
    Код:
    Перем Кат, ФП, ПБИ, НН, Сумма, ЗП, ПТ, Help, ИФ, Тмр, ННН, Н, Н0,ННН0;Перем Email, WWW, СтрокаТек, Настройка;Перем ТекущийСлой,Конфа,ПутьКбазе,ФлагМодифицированности,ФлагМодифицированностиТаб,ФлагНовый, НачалоИнтервала, КонецИнтервала,ФайлДБФ;Перем УжеУстановлен;Перем МенюВыбора;Перем СписокКолонок;Перем ВидДок;Процедура УстановкаДополнительныеВозможности()Если Вопрос("Установить программу печати транспортных накладных"+РазделительСтрок  +"в ''Дополнительные возможности'' (меню ''Сервис'')?",4)=7 Тогда  Возврат;КонецЕсли;ПутьЕРТ = "";ФайлЕРТ  = "";РасположениеФайла(ПутьЕРТ, ФайлЕРТ);Копируем=КаталогИБ()+"ExtForms\";Ошибка=0;Если ФС.СуществуетФайл(ПутьЕРТ+ФайлЕРТ)=1 ТогдаИначе  Ошибка=1;  Предупреждение("Не могу найти файл "+ФайлЕРТ+"!");КонецЕсли;Если ФС.СуществуетФайл(Копируем)=1 ТогдаИначе  Ошибка=1;  Предупреждение("Не могу найти каталог ''ExtForms'' в каталоге базы!");КонецЕсли;Если Ошибка=1 Тогда  Сообщить("Не могу установить!");  Сообщить("Обратитесь за помощью к разработчику по e-mail: buh77@aaanet.ru");  Возврат;Иначе   ФС.КопироватьФайл(ПутьЕРТ+ФайлЕРТ,Копируем+ФайлЕРТ,0);  ДлинаФайлаЕРТ=СтрДлина(ФайлЕРТ);  ФайлЕФД=Лев(ФайлЕРТ,(ДлинаФайлаЕРТ-3))+"efd";   ТекстЕФД=СоздатьОбъект("Текст");  ТекстЕФД.КодоваяСтраница(0);  ТекстЕФД.ДобавитьСтроку("Название=. Учет и печать транспортных накладных (действуют с 13.03.2012)");	    ТекстЕФД.Записать(Копируем+ФайлЕФД);  ТекстЕФД="";   Сообщить("Программа успешно установлена!");  Сообщить("Для работы с программой выберите пункт меню ''Сервис'' и в нем пункт ''Дополнительные возможности''");  Сообщить("В открывшемся списке внешних программ выберите ''Учет и печать транспортных накладных (действуют с 13.03.2012)''");КонецЕсли;	  КонецПроцедурыПроцедура УстановитьВидимостьКолонок()Перем ПредставлениеКолонки;СписокСпрятать="";Если ТипЗначенияСтр(СписокКолонок) = "СписокЗначений" Тогда	 Если СписокКолонок.РазмерСписка()=0 Тогда  Иначе   ЕстьПервыйСпрятать=0;   Для ё=1 По СписокКолонок.РазмерСписка() Цикл    ИмяКолонки = СписокКолонок.ПолучитьЗначение(ё,ПредставлениеКолонки);    Если Найти(ПредставлениеКолонки,"v")=0 Тогда	 Если ЕстьПервыйСпрятать=0 Тогда		 СписокСпрятать = СписокСпрятать + ИмяКолонки;	  ЕстьПервыйСпрятать=1;	 Иначе	  СписокСпрятать = СписокСпрятать +","+ ИмяКолонки;	 КонецЕсли;    КонецЕсли;	  КонецЦикла;  КонецЕсли;КонецЕсли;Если ПустаяСтрока(СписокСпрятать)=0 Тогда	 ТаблицаДвижений.ВидимостьКолонки(СписокСпрятать,0,);КонецЕсли;КонецПроцедурыПроцедура Колонки()Перем ПредставлениеКолонки;Если ТипЗначенияСтр(СписокКолонок) = "СписокЗначений" Тогда	 Если СписокКолонок.РазмерСписка()=0 Тогда  Иначе   зн=""; поз="";   Пока СписокКолонок.ВыбратьЗначение(зн,,поз,,1)=1 Цикл    СписокКолонок.ПолучитьЗначение(поз,ПредставлениеКолонки);    Если Найти(ПредставлениеКолонки,"v")=0 Тогда	 НовоеПредставление = СтрЗаменить(ПредставлениеКолонки,"[  ]","[v]");	 Показать = 1;    Иначе	 НовоеПредставление = СтрЗаменить(ПредставлениеКолонки,"[v]","[  ]");	 Показать = 0;    КонецЕсли;    СписокКолонок.УстановитьЗначение(поз,зн,НовоеПредставление,);    ТаблицаДвижений.ВидимостьКолонки(зн,Показать,);   КонецЦикла;  КонецЕсли;КонецЕсли;КонецПроцедурыФункция ФИО(ПолноеИмя)Перем Фамилия, ИмяОтчество, Имя, Отчество;Перем ПозицияПервогоПробела, ПозицияВторогоПробела;ПозицияПервогоПробела = Найти(ПолноеИмя, " ");Если (ПозицияПервогоПробела = 0) или (Найти(ПолноеИмя, ".")>0) Тогда  Возврат ПолноеИмя;Иначе  Фамилия = Лев(ПолноеИмя, ПозицияПервогоПробела);  ИмяОтчество = Сред(ПолноеИмя, ПозицияПервогоПробела+1);  ИмяОтчество = СокрЛ(ИмяОтчество);  Имя = Лев(ИмяОтчество, 1)+".";  ПозицияВторогоПробела = Найти(ИмяОтчество, " ");  Если ПозицияВторогоПробела = 0 Тогда   Возврат Фамилия+Имя;  Иначе   Отчество = Сред(ИмяОтчество, ПозицияВторогоПробела+1);   Отчество = СокрЛ(Отчество);   Отчество = Лев(Отчество, 1)+".";   Возврат Фамилия+Имя+Отчество;  КонецЕсли;КонецЕсли;КонецФункцииПроцедура ЗначенияПоУмолчаниюСохранитьИсх()СохранитьЗначение("ВыводитьНомерИДатуИсх",ВыводитьНомерИДату+1);//СохранитьЗначение("ВыводитьНомерИДатуВх",ВыводитьНомерИДату+1);СохранитьЗначение("ФлагПеревозчикаИсх",ФлагПеревозчика);//СохранитьЗначение("ФлагПеревозчикаВх",ФлагПеревозчика);СохранитьЗначение("ФлагПлательщикаИсх",ФлагПлательщика);КонецПроцедурыПроцедура ЗначенияПоУмолчаниюВосстановитьИсх()ВидДок=ВосстановитьЗначение("ВидДокИсх");Если ПустоеЗначение(ВидДок)=1 Тогда  ВидДок = 1;КонецЕсли;//ВидДок=ВосстановитьЗначение("ВидДокВх");//Если ПустоеЗначение(ВидДок)=1 Тогда// ВидДок = 1;//КонецЕсли;ВыводитьНомерИДату_=ВосстановитьЗначение("ВыводитьНомерИДатуИсх");Если ПустоеЗначение(ВыводитьНомерИДату_)=1 Тогда  ВыводитьНомерИДату = 1;Иначе  ВыводитьНомерИДату = ВыводитьНомерИДату_-1;КонецЕсли;//ВыводитьНомерИДату_=ВосстановитьЗначение("ВыводитьНомерИДатуВх");//Если ПустоеЗначение(ВыводитьНомерИДату_)=1 Тогда// ВыводитьНомерИДату = 1;//Иначе// ВыводитьНомерИДату = ВыводитьНомерИДату_-1;//КонецЕсли;ФлагПеревозчика=ВосстановитьЗначение("ФлагПеревозчикаИсх");Если ПустоеЗначение(ФлагПеревозчика)=1 Тогда  ФлагПеревозчика = 1;КонецЕсли;ФлагПлательщика=ВосстановитьЗначение("ФлагПлательщикаИсх");Если ПустоеЗначение(ФлагПлательщика)=1 Тогда  ФлагПлательщика = 1;КонецЕсли;КонецПроцедурыФункция ДатьТаблицуВыбора(Колонки,КолонкаОтбора,ЗначениеОтбора="")Перем Стр;    тз = СоздатьОбъект("ТаблицаЗначений");Если ТаблицаДвижений.КоличествоСтрок()=0 ТогдаИначе  ТаблицаДвижений.Выгрузить(тз,,,Колонки);  Если ПустоеЗначение(ЗначениеОтбора)=0 Тогда   тз.ПолучитьПараметрыКолонки(КолонкаОтбора,Стр,,,,,,);   ё=тз.КоличествоСтрок();   Пока ё<>0 Цикл	   Если Стр = "Строка" Тогда	    ЗначениеОтбора = СокрЛП(ЗначениеОтбора);	 ЗначениеВтз = СокрЛП(тз.ПолучитьЗначение(ё,КолонкаОтбора));    Иначе	 ЗначениеВтз = тз.ПолучитьЗначение(ё,КолонкаОтбора);    КонецЕсли;	   Если ЗначениеОтбора = ЗначениеВтз Тогда    Иначе	 тз.УдалитьСтроку(ё);    КонецЕсли;		  ё=ё-1;   КонецЦикла;  КонецЕсли;КонецЕсли;Если тз.КоличествоСтрок()=0 ТогдаИначе	 тз.Свернуть(Колонки,"");  тз.Сортировать(Колонки);  Если ПустоеЗначение(тз.ПолучитьЗначение(1,КолонкаОтбора))=1 Тогда	  тз.УдалитьСтроку(1);  КонецЕсли;КонецЕсли;Возврат тз;КонецФункцииПроцедура ЗаполнитьГрузоотправителя()//Сначала ищем по таблицеЕсли ТаблицаДвижений.КоличествоСтрок()=0 ТогдаИначе  КолонкаОтбора = "";  Если ВариантОтправки=1 Тогда	  КолонкаОтбора = "ВариантОтправки";   ЗначениеОтбора = ВариантОтправки;  Иначе   Если ПустоеЗначение(Грузоотправитель)=0 Тогда    КолонкаОтбора = "Грузоотправитель";    ЗначениеОтбора = Грузоотправитель;   КонецЕсли;  КонецЕсли;  Если ПустоеЗначение(КолонкаОтбора)=0 Тогда   ё=ТаблицаДвижений.КоличествоСтрок();   Пока ё<>0 Цикл	   ЗначениеСравнения = ТаблицаДвижений.ПолучитьЗначение(ё,КолонкаОтбора);    Если ЗначениеСравнения = ЗначениеОтбора Тогда		    //Грузоотправитель = ТаблицаДвижений.ПолучитьЗначение(ё,"Грузоотправитель");	 Отпустил = СокрЛП(ТаблицаДвижений.ПолучитьЗначение(ё,"Отпустил"));	 ТелефонГрузоотправителя = СокрЛП(ТаблицаДвижений.ПолучитьЗначение(ё,"ТелефонГрузоотправителя"));	 ПунктПогрузки = СокрЛП(ТаблицаДвижений.ПолучитьЗначение(ё,"ПунктПогрузки"));	 Если ФлагПеревозчика=1 Тогда		 ЛицоПеревозчика = ТаблицаДвижений.ПолучитьЗначение(ё,"ЛицоПеревозчика");	  ТелефонПеревозчика = СокрЛП(ТаблицаДвижений.ПолучитьЗначение(ё,"ТелефонПеревозчика"));	  Водитель = СокрЛП(ТаблицаДвижений.ПолучитьЗначение(ё,"Водитель"));	  ТелефонВодителя = СокрЛП(ТаблицаДвижений.ПолучитьЗначение(ё,"ТелефонВодителя"));	  АмМарка = СокрЛП(ТаблицаДвижений.ПолучитьЗначение(ё,"АмМарка"));	  АМГосНомер = СокрЛП(ТаблицаДвижений.ПолучитьЗначение(ё,"АМГосНомер"));	 КонецЕсли;			   Прервать;    КонецЕсли;		  ё=ё-1;   КонецЦикла;  КонецЕсли;КонецЕсли;Если ПустоеЗначение(ПунктПогрузки)=1 Тогда  Если ВариантОтправки=1 Тогда   Если ПустоеЗначение(Константа.ПочтовыйАдресОрганизации)=0 Тогда	   ПунктПогрузки=СокрЛП(глПредставлениеАдреса(Константа.ПочтовыйАдресОрганизации));   Иначе    ПунктПогрузки=СокрЛП(глПредставлениеАдреса(Константа.АдресОрганизации));   КонецЕсли;  Иначе   Если ПустоеЗначение(Грузоотправитель)=0 Тогда    Если ПустоеЗначение(Грузоотправитель.ПочтовыйАдрес)=0 Тогда	    ПунктПогрузки=СокрЛП(глПредставлениеАдреса(Грузоотправитель.ПочтовыйАдрес));    Иначе	 ПунктПогрузки=СокрЛП(глПредставлениеАдреса(Грузоотправитель.ЮридическийАдрес));    КонецЕсли;   КонецЕсли;  КонецЕсли;КонецЕсли;КонецПроцедурыПроцедура ЗаполнитьГрузополучателя()//Сначала ищем по таблицеЕсли ТаблицаДвижений.КоличествоСтрок()=0 ТогдаИначе  КолонкаОтбора = "";  Если ВариантПолучения=1 Тогда	  КолонкаОтбора = "ВариантПолучения";   ЗначениеОтбора = ВариантПолучения;  Иначе   Если ПустоеЗначение(Грузополучатель)=0 Тогда    КолонкаОтбора = "Грузополучатель";    ЗначениеОтбора = Грузополучатель;   КонецЕсли;  КонецЕсли;  Если ПустоеЗначение(КолонкаОтбора)=0 Тогда   ё=ТаблицаДвижений.КоличествоСтрок();   Пока ё<>0 Цикл	   ЗначениеСравнения = ТаблицаДвижений.ПолучитьЗначение(ё,КолонкаОтбора);    Если ЗначениеСравнения = ЗначениеОтбора Тогда		    //Грузополучатель = ТаблицаДвижений.ПолучитьЗначение(ё,"Грузополучатель");	 Принял = СокрЛП(ТаблицаДвижений.ПолучитьЗначение(ё,"Принял"));	 ТелефонГрузополучателя = СокрЛП(ТаблицаДвижений.ПолучитьЗначение(ё,"ТелефонГрузополучателя"));	 ПунктРазгрузки = СокрЛП(ТаблицаДвижений.ПолучитьЗначение(ё,"ПунктРазгрузки"));	 Если ФлагПеревозчика=2 Тогда		 ЛицоПеревозчика = ТаблицаДвижений.ПолучитьЗначение(ё,"ЛицоПеревозчика");	  ТелефонПеревозчика = СокрЛП(ТаблицаДвижений.ПолучитьЗначение(ё,"ТелефонПеревозчика"));	  Водитель = СокрЛП(ТаблицаДвижений.ПолучитьЗначение(ё,"Водитель"));	  ТелефонВодителя = СокрЛП(ТаблицаДвижений.ПолучитьЗначение(ё,"ТелефонВодителя"));	  АмМарка = СокрЛП(ТаблицаДвижений.ПолучитьЗначение(ё,"АмМарка"));	  АМГосНомер = СокрЛП(ТаблицаДвижений.ПолучитьЗначение(ё,"АМГосНомер"));	 КонецЕсли;			   Прервать;    КонецЕсли;		  ё=ё-1;   КонецЦикла;  КонецЕсли;КонецЕсли;Если ПустоеЗначение(ПунктРазгрузки)=1 Тогда  Если ВариантПолучения=1 Тогда   Если ПустоеЗначение(Константа.ПочтовыйАдресОрганизации)=0 Тогда	   ПунктРазгрузки=СокрЛП(глПредставлениеАдреса(Константа.ПочтовыйАдресОрганизации));   Иначе    ПунктРазгрузки=СокрЛП(глПредставлениеАдреса(Константа.АдресОрганизации));   КонецЕсли;  Иначе   Если ПустоеЗначение(Грузополучатель)=0 Тогда    Если ПустоеЗначение(Грузополучатель.ПочтовыйАдрес)=0 Тогда	    ПунктРазгрузки=СокрЛП(глПредставлениеАдреса(Грузополучатель.ПочтовыйАдрес));    Иначе	 ПунктРазгрузки=СокрЛП(глПредставлениеАдреса(Грузополучатель.ЮридическийАдрес));    КонецЕсли;   КонецЕсли;  КонецЕсли;КонецЕсли;КонецПроцедурыПроцедура ЗаполнитьГруз()КонецПроцедурыПроцедура ЗаполнитьПеревозчика()Если ТаблицаДвижений.КоличествоСтрок()=0 ТогдаИначе  КолонкаОтбора = "";  Если ПустоеЗначение(Перевозчик)=0 Тогда   КолонкаОтбора = "Перевозчик";   ЗначениеОтбора = Перевозчик;  КонецЕсли;  Если ПустоеЗначение(КолонкаОтбора)=0 Тогда   ё=ТаблицаДвижений.КоличествоСтрок();   Пока ё<>0 Цикл	   ЗначениеСравнения = ТаблицаДвижений.ПолучитьЗначение(ё,КолонкаОтбора);    Если ЗначениеСравнения = ЗначениеОтбора Тогда		    ЛицоПеревозчика = ТаблицаДвижений.ПолучитьЗначение(ё,"ЛицоПеревозчика");	 ТелефонПеревозчика = СокрЛП(ТаблицаДвижений.ПолучитьЗначение(ё,"ТелефонПеревозчика"));	 Водитель = СокрЛП(ТаблицаДвижений.ПолучитьЗначение(ё,"Водитель"));	 ТелефонВодителя = СокрЛП(ТаблицаДвижений.ПолучитьЗначение(ё,"ТелефонВодителя"));	 АмМарка = СокрЛП(ТаблицаДвижений.ПолучитьЗначение(ё,"АмМарка"));	 АМГосНомер = СокрЛП(ТаблицаДвижений.ПолучитьЗначение(ё,"АМГосНомер"));			   Прервать;    КонецЕсли;		  ё=ё-1;   КонецЦикла;  КонецЕсли;КонецЕсли;КонецПроцедурыПроцедура ПриНачалеВыбораЗначения(ИдентЭлементаДиалога, ФлагСтандартнойОбработки)Перем ВыбЗнач,Стр;зн="";поз="";Если (ИдентЭлементаДиалога = "Грузоотправитель") или(ИдентЭлементаДиалога = "Отпустил") или(ИдентЭлементаДиалога = "Грузополучатель") или(ИдентЭлементаДиалога = "Принял") или(ИдентЭлементаДиалога = "ИмяГруза") или(ИдентЭлементаДиалога = "Перевозчик") или(ИдентЭлементаДиалога = "ЛицоПеревозчика") или(ИдентЭлементаДиалога = "Водитель") или(ИдентЭлементаДиалога = "АмМарка") Тогда   ФлагСтандартнойОбработки = 0;  Если МенюВыбора.выбратьЗначение(зн,,поз,,1)=1 тогда	  Если (ИдентЭлементаДиалога = "Грузоотправитель") или   (ИдентЭлементаДиалога = "Грузополучатель") или   (ИдентЭлементаДиалога = "Перевозчик") Тогда    Если поз=1 Тогда	 Если ВвестиЗначение(ВыбЗнач,"Выберите Контрагента","Справочник.Контрагенты")=1 Тогда	  Если ВыбЗнач.ЭтоГруппа()=0 Тогда	   ФлагМодифицированности=1;		  Если ИдентЭлементаДиалога = "Грузоотправитель" Тогда			  Грузоотправитель = ВыбЗнач;	    ЗаполнитьГрузоотправителя();	   ИначеЕсли ИдентЭлементаДиалога = "Грузополучатель" Тогда	    Грузополучатель = ВыбЗнач;	    ЗаполнитьГрузополучателя();	   ИначеЕсли ИдентЭлементаДиалога = "Перевозчик" Тогда		   Перевозчик = ВыбЗнач;	    ЗаполнитьПеревозчика();		  КонецЕсли;	  КонецЕсли;	 КонецЕсли;    Иначе		    Если ИдентЭлементаДиалога = "Грузоотправитель" Тогда		   Колонки = "Грузоотправитель,Отпустил,ТелефонГрузоотправителя,ПунктПогрузки";	  Если ФлагПеревозчика=1 Тогда		  Колонки = Колонки + ",ЛицоПеревозчика,ТелефонПеревозчика,Водитель,ТелефонВодителя,АмМарка,АМГосНомер";	  КонецЕсли;	  ТабВыбора = ДатьТаблицуВыбора(Колонки,"Грузоотправитель");	  Если ТабВыбора.КоличествоСтрок()=0 Тогда	  Иначе	   Если ТабВыбора.ВыбратьСтроку(Стр,"Выберите строку с подходящими реквизитами")=1 Тогда		   Грузоотправитель = ТабВыбора.ПолучитьЗначение(Стр,"Грузоотправитель");	    Отпустил = СокрЛП(ТабВыбора.ПолучитьЗначение(Стр,"Отпустил"));	    ТелефонГрузоотправителя = СокрЛП(ТабВыбора.ПолучитьЗначение(Стр,"ТелефонГрузоотправителя"));	    ПунктПогрузки = СокрЛП(ТабВыбора.ПолучитьЗначение(Стр,"ПунктПогрузки"));	    Если ФлагПеревозчика=1 Тогда		    ЛицоПеревозчика = ТабВыбора.ПолучитьЗначение(Стр,"ЛицоПеревозчика");		 ТелефонПеревозчика = СокрЛП(ТабВыбора.ПолучитьЗначение(Стр,"ТелефонПеревозчика"));		 Водитель = СокрЛП(ТабВыбора.ПолучитьЗначение(Стр,"Водитель"));		 ТелефонВодителя = СокрЛП(ТабВыбора.ПолучитьЗначение(Стр,"ТелефонВодителя"));		 АмМарка = СокрЛП(ТабВыбора.ПолучитьЗначение(Стр,"АмМарка"));		 АМГосНомер = СокрЛП(ТабВыбора.ПолучитьЗначение(Стр,"АМГосНомер"));	    КонецЕсли;	   КонецЕсли;	  КонецЕсли;		  ИначеЕсли ИдентЭлементаДиалога = "Грузополучатель" Тогда	  Колонки = "Грузополучатель,Принял,ТелефонГрузополучателя,ПунктРазгрузки";	  Если ФлагПеревозчика=2 Тогда		  Колонки = Колонки + ",ЛицоПеревозчика,ТелефонПеревозчика,Водитель,ТелефонВодителя,АмМарка,АМГосНомер";	  КонецЕсли;	  ТабВыбора = ДатьТаблицуВыбора(Колонки,"Грузополучатель");	  Если ТабВыбора.КоличествоСтрок()=0 Тогда	  Иначе	   Если ТабВыбора.ВыбратьСтроку(Стр,"Выберите строку с подходящими реквизитами")=1 Тогда		   Грузополучатель = ТабВыбора.ПолучитьЗначение(Стр,"Грузополучатель");	    Принял = СокрЛП(ТабВыбора.ПолучитьЗначение(Стр,"Принял"));	    ТелефонГрузополучателя = СокрЛП(ТабВыбора.ПолучитьЗначение(Стр,"ТелефонГрузополучателя"));	    ПунктРазгрузки = СокрЛП(ТабВыбора.ПолучитьЗначение(Стр,"ПунктРазгрузки"));	    Если ФлагПеревозчика=2 Тогда		    ЛицоПеревозчика = ТабВыбора.ПолучитьЗначение(Стр,"ЛицоПеревозчика");		 ТелефонПеревозчика = СокрЛП(ТабВыбора.ПолучитьЗначение(Стр,"ТелефонПеревозчика"));		 Водитель = СокрЛП(ТабВыбора.ПолучитьЗначение(Стр,"Водитель"));		 ТелефонВодителя = СокрЛП(ТабВыбора.ПолучитьЗначение(Стр,"ТелефонВодителя"));		 АмМарка = СокрЛП(ТабВыбора.ПолучитьЗначение(Стр,"АмМарка"));		 АМГосНомер = СокрЛП(ТабВыбора.ПолучитьЗначение(Стр,"АМГосНомер"));	    КонецЕсли;	   КонецЕсли;	  КонецЕсли;		  ИначеЕсли ИдентЭлементаДиалога = "Перевозчик" Тогда	  Колонки = "Перевозчик";	  Если ФлагПеревозчика=3 Тогда		  Колонки = Колонки + ",ЛицоПеревозчика,ТелефонПеревозчика,Водитель,ТелефонВодителя,АмМарка,АМГосНомер";	  КонецЕсли;	  ТабВыбора = ДатьТаблицуВыбора(Колонки,"Перевозчик");	  Если ТабВыбора.КоличествоСтрок()=0 Тогда	  Иначе	   Если ТабВыбора.ВыбратьСтроку(Стр,"Выберите строку с подходящими реквизитами")=1 Тогда		   Перевозчик = ТабВыбора.ПолучитьЗначение(Стр,"Перевозчик");	    Если ФлагПеревозчика=3 Тогда		    ЛицоПеревозчика = ТабВыбора.ПолучитьЗначение(Стр,"ЛицоПеревозчика");		 ТелефонПеревозчика = СокрЛП(ТабВыбора.ПолучитьЗначение(Стр,"ТелефонПеревозчика"));		 Водитель = СокрЛП(ТабВыбора.ПолучитьЗначение(Стр,"Водитель"));		 ТелефонВодителя = СокрЛП(ТабВыбора.ПолучитьЗначение(Стр,"ТелефонВодителя"));		 АмМарка = СокрЛП(ТабВыбора.ПолучитьЗначение(Стр,"АмМарка"));		 АМГосНомер = СокрЛП(ТабВыбора.ПолучитьЗначение(Стр,"АМГосНомер"));	    КонецЕсли;	   КонецЕсли;	  КонецЕсли;			 КонецЕсли;	    КонецЕсли;   ИначеЕсли (ИдентЭлементаДиалога = "Отпустил") или   (ИдентЭлементаДиалога = "Принял") или   (ИдентЭлементаДиалога = "ЛицоПеревозчика") или   (ИдентЭлементаДиалога = "Водитель") Тогда    Если поз=1 Тогда	 Если ВвестиЗначение(ВыбЗнач,"Выберите Сотрудника","Справочник.Сотрудники")=1 Тогда	  Если ВыбЗнач.ЭтоГруппа()=0 Тогда	   ФлагМодифицированности=1;		  Если ИдентЭлементаДиалога = "Отпустил" Тогда			  Отпустил = ФИО(ВыбЗнач.Наименование);	    ТелефонГрузоотправителя = ВыбЗнач.Должность;	   ИначеЕсли ИдентЭлементаДиалога = "Принял" Тогда	    Принял = ФИО(ВыбЗнач.Наименование);	    ТелефонГрузополучателя = ВыбЗнач.Должность;	   ИначеЕсли ИдентЭлементаДиалога = "ЛицоПеревозчика" Тогда		   ЛицоПеревозчика = ВыбЗнач.Наименование;	    ТелефонПеревозчика = ВыбЗнач.Должность;	   ИначеЕсли ИдентЭлементаДиалога = "Водитель" Тогда		   Водитель = ВыбЗнач.Наименование;		  КонецЕсли;	  КонецЕсли;	 КонецЕсли;    Иначе	    Если ИдентЭлементаДиалога = "Отпустил" Тогда		   ТабВыбора = ДатьТаблицуВыбора("Отпустил,ТелефонГрузоотправителя","Отпустил");	  Если ТабВыбора.КоличествоСтрок()=0 Тогда	  Иначе	   сз = СоздатьОбъект("СписокЗначений");			 ТабВыбора.ВыбратьСтроки();	   Пока ТабВыбора.ПолучитьСтроку()=1 Цикл		   сз.ДобавитьЗначение(СокрЛП(ТабВыбора.Отпустил)+" (тел. "+СокрЛП(ТабВыбора.ТелефонГрузоотправителя)+")");	   КонецЦикла;	   зн="";поз="";	   Если сз.выбратьЗначение(зн,,поз,,1)=1 тогда	    ФлагМодифицированности=1;	    Отпустил = СокрЛП(ТабВыбора.ПолучитьЗначение(поз,"Отпустил"));	    ТелефонГрузоотправителя = СокрЛП(ТабВыбора.ПолучитьЗначение(поз,"ТелефонГрузоотправителя"));	   КонецЕсли;	  КонецЕсли;		  ИначеЕсли ИдентЭлементаДиалога = "Принял" Тогда		   ТабВыбора = ДатьТаблицуВыбора("Принял,ТелефонГрузополучателя","Принял");	  Если ТабВыбора.КоличествоСтрок()=0 Тогда	  Иначе	   сз = СоздатьОбъект("СписокЗначений");			 ТабВыбора.ВыбратьСтроки();	   Пока ТабВыбора.ПолучитьСтроку()=1 Цикл		   сз.ДобавитьЗначение(СокрЛП(ТабВыбора.Принял)+" (тел. "+СокрЛП(ТабВыбора.ТелефонГрузополучателя)+")");	   КонецЦикла;	   зн="";поз="";	   Если сз.выбратьЗначение(зн,,поз,,1)=1 тогда	    ФлагМодифицированности=1;	    Принял = СокрЛП(ТабВыбора.ПолучитьЗначение(поз,"Принял"));	    ТелефонГрузополучателя = СокрЛП(ТабВыбора.ПолучитьЗначение(поз,"ТелефонГрузополучателя"));	   КонецЕсли;	  КонецЕсли;	 ИначеЕсли ИдентЭлементаДиалога = "ЛицоПеревозчика" Тогда		   ТабВыбора = ДатьТаблицуВыбора("ЛицоПеревозчика,ТелефонПеревозчика","ЛицоПеревозчика");	  Если ТабВыбора.КоличествоСтрок()=0 Тогда	  Иначе	   сз = СоздатьОбъект("СписокЗначений");			 ТабВыбора.ВыбратьСтроки();	   Пока ТабВыбора.ПолучитьСтроку()=1 Цикл		   сз.ДобавитьЗначение(СокрЛП(ТабВыбора.ЛицоПеревозчика)+" (тел. "+СокрЛП(ТабВыбора.ТелефонПеревозчика)+")");	   КонецЦикла;	   зн="";поз="";	   Если сз.выбратьЗначение(зн,,поз,,1)=1 тогда	    ФлагМодифицированности=1;	    ЛицоПеревозчика = СокрЛП(ТабВыбора.ПолучитьЗначение(поз,"ЛицоПеревозчика"));	    ТелефонПеревозчика = СокрЛП(ТабВыбора.ПолучитьЗначение(поз,"ТелефонПеревозчика"));	   КонецЕсли;	  КонецЕсли;		  ИначеЕсли ИдентЭлементаДиалога = "Водитель" Тогда		   ТабВыбора = ДатьТаблицуВыбора("Водитель,ТелефонВодителя","Водитель");	  Если ТабВыбора.КоличествоСтрок()=0 Тогда	  Иначе	   сз = СоздатьОбъект("СписокЗначений");			 ТабВыбора.ВыбратьСтроки();	   Пока ТабВыбора.ПолучитьСтроку()=1 Цикл		   сз.ДобавитьЗначение(СокрЛП(ТабВыбора.Водитель)+" (тел. "+СокрЛП(ТабВыбора.ТелефонВодителя)+")");	   КонецЦикла;	   зн="";поз="";	   Если сз.выбратьЗначение(зн,,поз,,1)=1 тогда	    ФлагМодифицированности=1;	    Водитель = СокрЛП(ТабВыбора.ПолучитьЗначение(поз,"Водитель"));	    ТелефонВодителя = СокрЛП(ТабВыбора.ПолучитьЗначение(поз,"ТелефонВодителя"));	   КонецЕсли;	  КонецЕсли;			 КонецЕсли;    КонецЕсли;   ИначеЕсли (ИдентЭлементаДиалога = "ИмяГруза") Тогда    Если поз=1 Тогда	 Если ВидДок=1 Тогда	  Если ВвестиЗначение(ВыбЗнач,"Выберите Номенклатуру","Справочник.Номенклатура")=1 Тогда	   Если ВыбЗнач.ЭтоГруппа()=0 Тогда	    ФлагМодифицированности=1;	    ИмяГруза_ = ?(ПустоеЗначение(ВыбЗнач.ПолнНаименование)=1,СокрЛП(ВыбЗнач.Наименование),СокрЛП(ВыбЗнач.ПолнНаименование));	    Если ПустоеЗначение(ИмяГруза)=1 Тогда		 ИмяГруза = ИмяГруза_;	    Иначе		 Если Вопрос("Добавить наименование груза к существующему?", "Да+Нет") = "Да" Тогда		  ИмяГруза = СокрЛП(ИмяГруза)+"; "+ИмяГруза_;		 Иначе		  ИмяГруза = ИмяГруза_;		 КонецЕсли;	    КонецЕсли;	   КонецЕсли;	  КонецЕсли;	 Иначе	  Если ВвестиЗначение(ВыбЗнач,"Выберите Материал","Справочник.Материалы")=1 Тогда	   Если ВыбЗнач.ЭтоГруппа()=0 Тогда	    ФлагМодифицированности=1;	    Если ПустоеЗначение(ИмяГруза)=1 Тогда		    ИмяГруза = СокрЛП(ВыбЗнач.Наименование);	    Иначе		 Если Вопрос("Добавить наименование груза к существующему?", "Да+Нет") = "Да" Тогда		  ИмяГруза = СокрЛП(ИмяГруза)+"; "+СокрЛП(ВыбЗнач.Наименование);		 Иначе		  ИмяГруза = СокрЛП(ВыбЗнач.Наименование);		 КонецЕсли;	    КонецЕсли;	   КонецЕсли;	  КонецЕсли;	 КонецЕсли;    Иначе	 ТабВыбора = ДатьТаблицуВыбора("ИмяГруза,Упаковка,СпособМассы,Документ2","ИмяГруза");	 Если ТабВыбора.КоличествоСтрок()=0 Тогда	 Иначе	  Если ТабВыбора.ВыбратьСтроку(Стр,"Выберите груз")=1 Тогда		  ИмяГруза = СокрЛП(ТабВыбора.ПолучитьЗначение(Стр,"ИмяГруза"));	   Упаковка = СокрЛП(ТабВыбора.ПолучитьЗначение(Стр,"Упаковка"));	   СпособМассы = СокрЛП(ТабВыбора.ПолучитьЗначение(Стр,"СпособМассы"));	   Документ2 = СокрЛП(ТабВыбора.ПолучитьЗначение(Стр,"Документ2"));	  КонецЕсли;	 КонецЕсли;    КонецЕсли;   ИначеЕсли (ИдентЭлементаДиалога = "АмМарка") Тогда    Если поз=1 Тогда	 Если ВвестиЗначение(ВыбЗнач,"Выберите Автомобиль","Справочник.ОсновныеСредства")=1 Тогда	  Если ВыбЗнач.ЭтоГруппа()=0 Тогда	   ФлагМодифицированности=1;		  АмМарка = СокрЛП(ВыбЗнач.Наименование);	  КонецЕсли;	 КонецЕсли;    Иначе	 ТабВыбора = ДатьТаблицуВыбора("АмМарка,АМГосНомер","АмМарка");	 Если ТабВыбора.КоличествоСтрок()=0 Тогда	 Иначе	  сз = СоздатьОбъект("СписокЗначений");		   ТабВыбора.ВыбратьСтроки();	  Пока ТабВыбора.ПолучитьСтроку()=1 Цикл		  сз.ДобавитьЗначение(СокрЛП(ТабВыбора.АмМарка)+" ("+СокрЛП(ТабВыбора.АМГосНомер)+")");	  КонецЦикла;	  зн="";поз="";	  Если сз.выбратьЗначение(зн,,поз,,1)=1 тогда	   ФлагМодифицированности=1;	   АмМарка = СокрЛП(ТабВыбора.ПолучитьЗначение(поз,"АмМарка"));	   АМГосНомер = СокрЛП(ТабВыбора.ПолучитьЗначение(поз,"АМГосНомер"));	  КонецЕсли;	 КонецЕсли;    КонецЕсли;   КонецЕсли;    КонецЕсли;Иначе  Если ИдентЭлементаДиалога = "ПунктПогрузки" Тогда   ТабВыбора = ДатьТаблицуВыбора("ПунктПогрузки","ПунктПогрузки");   Если ТабВыбора.КоличествоСтрок()=0 Тогда   Иначе    сз = СоздатьОбъект("СписокЗначений");    ТабВыбора.Выгрузить(сз,,,"ПунктПогрузки");	   зн="";поз="";    Если сз.выбратьЗначение(зн,,поз,,1)=1 тогда	 ФлагМодифицированности=1;	 ПунктПогрузки = зн;    КонецЕсли;   КонецЕсли;  ИначеЕсли ИдентЭлементаДиалога = "ПунктРазгрузки" Тогда   ТабВыбора = ДатьТаблицуВыбора("ПунктРазгрузки","ПунктРазгрузки");   Если ТабВыбора.КоличествоСтрок()=0 Тогда   Иначе    сз = СоздатьОбъект("СписокЗначений");    ТабВыбора.Выгрузить(сз,,,"ПунктРазгрузки");	   зн="";поз="";    Если сз.выбратьЗначение(зн,,поз,,1)=1 тогда	 ФлагМодифицированности=1;	 ПунктРазгрузки = зн;    КонецЕсли;   КонецЕсли;  ИначеЕсли ИдентЭлементаДиалога = "Упаковка" Тогда   ТабВыбора = ДатьТаблицуВыбора("Упаковка","Упаковка");   Если ТабВыбора.КоличествоСтрок()=0 Тогда   Иначе    сз = СоздатьОбъект("СписокЗначений");    ТабВыбора.Выгрузить(сз,,,"Упаковка");	   зн="";поз="";    Если сз.выбратьЗначение(зн,,поз,,1)=1 тогда	 ФлагМодифицированности=1;	 Упаковка = зн;    КонецЕсли;   КонецЕсли;  ИначеЕсли ИдентЭлементаДиалога = "СпособМассы" Тогда   ТабВыбора = ДатьТаблицуВыбора("СпособМассы","СпособМассы");   Если ТабВыбора.КоличествоСтрок()=0 Тогда   Иначе    сз = СоздатьОбъект("СписокЗначений");    ТабВыбора.Выгрузить(сз,,,"СпособМассы");	   зн="";поз="";    Если сз.выбратьЗначение(зн,,поз,,1)=1 тогда	 ФлагМодифицированности=1;	 СпособМассы = зн;    КонецЕсли;   КонецЕсли;  ИначеЕсли ИдентЭлементаДиалога = "Документ2" Тогда   ТабВыбора = ДатьТаблицуВыбора("Документ2","Документ2");   Если ТабВыбора.КоличествоСтрок()=0 Тогда   Иначе    сз = СоздатьОбъект("СписокЗначений");    ТабВыбора.Выгрузить(сз,,,"Документ2");	   зн="";поз="";    Если сз.выбратьЗначение(зн,,поз,,1)=1 тогда	 ФлагМодифицированности=1;	 Документ2 = зн;    КонецЕсли;   КонецЕсли;  КонецЕсли;КонецЕсли;КонецПроцедурыФункция ПоискЭлементаПоКоду(Тип,Код)Спр=СоздатьОбъект("Справочник."+Тип);Если Спр.НайтиПоКоду(Код)=1 Тогда  Возврат Спр.ТекущийЭлемент();Иначе  Возврат "";КонецЕсли;КонецФункцииФункция ПоискДокумента(Тип,Код,Д)Док1=СоздатьОбъект("Документ."+Тип);Если Док1.НайтиПоНомеру(Код,Д)=1 Тогда  Возврат Док1.ТекущийДокумент();Иначе  Возврат "";КонецЕсли;КонецФункцииФункция ФРМ(ЧислЗнач)						  РезСтрока = СокрЛ(Формат(ЧислЗнач, "Ч015.2.'"));РезСтрока = РезСтрока + " руб.";Возврат РезСтрока;КонецФункцииПроцедура НазначитьТипДок()Если ВидДок = 1 Тогда  Форма.Док.НазначитьТип("Документ.Реализация",,);Иначе  Форма.Док.НазначитьТип("Документ.ОтпускМатериаловНаСторону",,);КонецЕсли;КонецПроцедурыПроцедура ВидимостьРеквизитовГрузоотправитель()Если ВариантОтправки=1 Тогда  Грузоотправитель="";  Форма.Грузоотправитель.Видимость(0);Иначе  Форма.Грузоотправитель.Видимость(1);КонецЕсли;КонецПроцедурыПроцедура ВидимостьРеквизитовГрузополучатель()Если ВариантПолучения=1 Тогда  Грузополучатель="";  Форма.Грузополучатель.Видимость(0);Иначе  Форма.Грузополучатель.Видимость(1);КонецЕсли;КонецПроцедурыПроцедура ВидимостьРеквизитовПеревозчик()Если ФлагПеревозчика=3 Тогда  Форма.Перевозчик.Видимость(1);Иначе  Перевозчик="";  Форма.Перевозчик.Видимость(0);КонецЕсли;КонецПроцедурыПроцедура ВидимостьРеквизитовПлательщик()Если ФлагПлательщика=3 Тогда  Форма.Плательщик.Видимость(1);Иначе  Плательщик="";  Форма.Плательщик.Видимость(0);КонецЕсли;КонецПроцедурыПроцедура ЗаполнитьЧек()Если ПустоеЗначение(Док)=0 Тогда   Дат = Док.ДатаДок;  Если Док.Вид() = "Реализация" Тогда   Если ПустоеЗначение(Док.Грузоотправитель)=1 Тогда    ВариантОтправки=1;   Иначе    ВариантОтправки=0;	   Грузоотправитель=Док.Грузоотправитель;   КонецЕсли;   ВариантПолучения=0;   Если ПустоеЗначение(Док.Грузополучатель)=1 Тогда    Грузополучатель=Док.Контрагент;   Иначе    Грузополучатель=Док.Грузополучатель;   КонецЕсли;  Иначе   ВариантОтправки=1;   Грузоотправитель="";   ВариантПолучения=0;   Грузополучатель=Док.Контрагент;  КонецЕсли;  Отпустил = "";  ТелефонГрузоотправителя = "";  ПунктПогрузки = "";  ДатаПогрузки = Строка(Док.ДатаДок);   ЗаполнитьГрузоотправителя();   Принял = "";  ТелефонГрузополучателя = "";  ПунктРазгрузки = "";  ДатаРазгрузки = Строка(Док.ДатаДок);  ЗаполнитьГрузополучателя();   ВидимостьРеквизитовГрузоотправитель();  ВидимостьРеквизитовГрузополучатель();   ИмяГруза_="";  Вес_=0;   Если Док.ВыбратьСтроки()=1 Тогда	  Пока Док.ПолучитьСтроку()=1 Цикл	   Если Док.Вид()="Реализация" Тогда	 ИмяГруза_ = ИмяГруза_ + ?(ПустаяСтрока(Док.Номенклатура.ПолнНаименование) = 1, СокрЛП(Док.Номенклатура.Наименование), СокрЛП(Док.Номенклатура.ПолнНаименование))+"; "    ИначеЕсли Док.Вид()="ОтпускМатериаловНаСторону" Тогда	 ИмяГруза_ = ИмяГруза_ + СокрЛП(Док.Материал.Наименование) +"; "    КонецЕсли;	   ЕдИзм_="";    Количество_=0;    Если Док.Вид()="ОтпускМатериаловНаСторону" Тогда	 ЕдИзм_=СокрЛП(Док.Материал.ЕдиницаИзмерения.Наименование);	    Количество_ = Док.КоличествоОтпущено;    ИначеЕсли Док.Вид()="Реализация" Тогда	 ЕдИзм_=СокрЛП(Док.Номенклатура.ЕдиницаИзмерения.Наименование);	 Количество_ = Док.Количество;    КонецЕсли;	   Если (ЕдИзм_="кг") или (ЕдИзм_="кг.") Тогда	    Вес_=Вес_+Количество_;    ИначеЕсли (ЕдИзм_="т") или (ЕдИзм_="т.") Тогда	 Вес_=Вес_+Количество_*1000;    КонецЕсли;		 КонецЦикла;  КонецЕсли;   ИмяГруза=ИмяГруза_;  Вес=Вес_;   СтоимостьГруза=Док.Итог("Сумма");   Документ1_="Торг-12 № "+СокрЛП(глПреобразоватьНомерДок(Док.НомерДок, 0, 0))+" от "+Док.ДатаДок;  Документ11_="";  //ДокПодч = СоздатьОбъект("Документ");  //Если ДокПодч.ВыбратьПодчиненныеДокументы(НачМесяца(Док.ДатаДок),КонМесяца(Док.ДатаДок),Док) = 1 Тогда  // Пока ДокПодч.ПолучитьДокумент() = 1 Цикл  //  Если (ДокПодч.Вид() = "СчетФактура") Тогда  //   Если ДокПодч.ПометкаУдаления()=1 Тогда  //    Продолжить;  //   КонецЕсли;  //   Документ11_="; Счет-фактура № "+СокрЛП(глПреобразоватьНомерДок(ДокПодч.НомерДок, 0, 0))+" от "+ДокПодч.ДатаДок;  //	  Прервать;  //  КонецЕсли;  // КонецЦикла;  //КонецЕсли;  Документ1=Документ1_+Документ11_;КонецЕсли;КонецПроцедурыПроцедура ОчиститьДок()Док="";КонецПроцедурыПроцедура ОткрытьДокумент()Если ПустоеЗначение(Док) = 0 Тогда  ОткрытьФорму(Док);КонецЕсли;КонецПроцедурыПроцедура ОНастройке()Т = СоздатьОбъект("Текст");Т.ДобавитьСтроку("");Т.ДобавитьСтроку(" Эта настройка является условно-бесплатной и предназначена для использования ");Т.ДобавитьСтроку(" в конфигурациях 1С:Предприятия 7.7;");Т.ДобавитьСтроку(" Проверить работоспособность настройки вы можете в течении "+ПБИ+" календарных дней после");Т.ДобавитьСтроку(" первого открытия.");Т.ДобавитьСтроку("");Т.ДобавитьСтроку(" Стоимость настройки составляет "+Сумма+" руб.");Т.ДобавитьСтроку(" Оплату можно произвести платёжным поручением с расчётного счета.");Т.ДобавитьСтроку(" Счёт на оплату со всеми необходимыми реквизитами будет сформирован по окончании");Т.ДобавитьСтроку(" тестового периода работы настройки.");Т.ДобавитьСтроку(" Информацию об оплате отправьте на e-mail: "+Email);Т.ДобавитьСтроку(" Настройка высылается сразу после поступления денег на расчетный счет");Т.ДобавитьСтроку(" на указанный Вами электронный адрес.");Т.ДобавитьСтроку("");Т.ДобавитьСтроку("");Т.Показать(" О настройке");КонецПроцедурыПроцедура Помощь()КонецПроцедурыФункция ПТ()Р=ПТ;Р1=Help;Т=Сред(Р1,7,1);НДТ=Сред(Р,11,4);НДТ=НДТ+Сред(Р1,5,2);НПТ=Сред(Р,8,3);ПТ=НДТ+Т+НПТ;Возврат ПТ;КонецФункцииФункция ПД(а)Если ФС.СуществуетФайл(ИФ)=0 Тогда  Форма.Закрыть();КонецЕсли;Тк=СоздатьОбъект("Текст");Тк.Открыть(ФС.ТекКаталог()+Симв(92)+ИФ);Стр=СокрЛП(Тк.ПолучитьСтроку(Число(НН)));Год="20"+Сред(Стр,9,2);Мес=Сред(Стр,6,2);Чис=Сред(Стр,3,2);Секунд=Сред(Стр,18,2);Если а=1 Тогда	 Значение=(Дата(Год,Мес,Чис)+ПБИ);ИначеЕсли а=2 Тогда  Значение=Мес+Чис+Секунд+НН;Иначе  М=Число(Мес);  Ч=Число(Чис);  Ск=Число(Секунд);  Мт=Число(НН);  Значение=(73*М)*(2003*Ч)+Ск-Мт;КонецЕсли;Возврат Значение;КонецФункцииПроцедура Счет()    ОргНаПечать=СокрЛП(Константа.НаименованиеОрганизации);Таб = СоздатьОбъект("Таблица");Таб.ИсходнаяТаблица("Таблица1");Таб.Опции(0,0,0,0);Таб.ВывестиСекцию("Счет");Таб.ТолькоПросмотр(1);Таб.Показать("Счёт на оплату","");КонецПроцедурыФункция ПС()Ц="";Получить = Число(Симв(51)+Симв(54)+Симв(53));Для с=1 По Получить Цикл  Ц=Ц+Симв(32);КонецЦикла;Возврат Ц;КонецФункцииПроцедура П()Если ФС.СуществуетФайл(ИФ)=0 Тогда  Форма.Закрыть();КонецЕсли;р=0;Счет();КонецПроцедурыПроцедура Рг()П();КонецПроцедурыПроцедура З()Если СтрДлина(ННН0)>0 Тогда  Если ФС.СуществуетФайл(ИФ)=0 Тогда   Тк=СоздатьОбъект("Текст");   ФП=Симв(48);   СохранитьЗначение(Н0, "1");	  Рг = ПС()+ФП+"/"+Строка(ТекущаяДата())+"/"+Строка(ТекущееВремя())+"/"+НН;   Для а=1 по Число(НН) Цикл	   Тк.ДобавитьСтроку(" ");   КонецЦикла;   Тк.ЗаменитьСтроку(Число(НН),Рг);   Тк.Записать(ФС.ТекКаталог()+Симв(92)+ИФ);  Иначе   Тк=СоздатьОбъект("Текст");   Тк.Открыть(ФС.ТекКаталог()+Симв(92)+ИФ);   Если Тк.КоличествоСтрок()<Число(НН) Тогда    ФП=Симв(48);    СохранитьЗначение(Н0, "2");	   Рг= ПС()+ФП+"/"+Строка(ТекущаяДата())+"/"+Строка(ТекущееВремя())+"/"+НН;    Для а=1 по (Число(НН)-Тк.КоличествоСтрок()) Цикл	    Тк.ДобавитьСтроку(" ");    КонецЦикла;    Тк.ЗаменитьСтроку(Число(НН),Рг);    Тк.Записать(ФС.ТекКаталог()+Симв(92)+ИФ);   Иначе    Стр=Тк.ПолучитьСтроку(Число(НН));    д = СтрДлина(ПС());    Если Не ((Сред(Стр,д,1)=Симв(32)) и ((Сред(Стр,д+1,1)=Симв(48)) или (Сред(Стр,д+1,1)=Симв(49)) или (Сред(Стр,д+1,1)=Симв(50)))) Тогда	 ФП=Симв(48);	 СохранитьЗначение(Н0, "3");	    Рг = ПС()+ФП+"/"+Строка(ТекущаяДата())+"/"+Строка(ТекущееВремя())+"/"+НН;	 Тк.ЗаменитьСтроку(Число(НН),Рг);	 Тк.Записать(ФС.ТекКаталог()+Симв(92)+ИФ);    КонецЕсли;   КонецЕсли;  КонецЕсли;  ФП=Симв(48);	 Рг();  Возврат;КонецЕсли;Если ПустоеЗначение(ННН) = 1 Тогда	 СохранитьЗначение(Н, НН);  Если ФС.СуществуетФайл(ИФ)=0 Тогда   Тк=СоздатьОбъект("Текст");   ФП=Симв(49);	  Рг = ПС()+ФП+"/"+Строка(ТекущаяДата())+"/"+Строка(ТекущееВремя())+"/"+НН;   Для а=1 по Число(НН) Цикл	   Тк.ДобавитьСтроку(" ");   КонецЦикла;   Тк.ЗаменитьСтроку(Число(НН),Рг);   Тк.Записать(ФС.ТекКаталог()+Симв(92)+ИФ);   ОНастройке();   Помощь();  ИначеЕсли ФС.СуществуетФайл(ИФ)=1 Тогда   Тк=СоздатьОбъект("Текст");   Тк.Открыть(ФС.ТекКаталог()+Симв(92)+ИФ);   Если Тк.КоличествоСтрок()<Число(НН) Тогда    ФП=Симв(49);	   Рг= ПС()+ФП+"/"+Строка(ТекущаяДата())+"/"+Строка(ТекущееВремя())+"/"+НН;    Для а=1 по (Число(НН)-Тк.КоличествоСтрок()) Цикл	    Тк.ДобавитьСтроку(" ");    КонецЦикла;    Тк.ЗаменитьСтроку(Число(НН),Рг);    Тк.Записать(ФС.ТекКаталог()+Симв(92)+ИФ);    ОНастройке();    Помощь();   Иначе    Стр=СокрЛП(Тк.ПолучитьСтроку(Число(НН)));    Если СтрДлина(Стр)=0 Тогда	 ФП=Симв(49);	    Рг = ПС()+ФП+"/"+Строка(ТекущаяДата())+"/"+Строка(ТекущееВремя())+"/"+НН;	 Тк.ЗаменитьСтроку(Число(НН),Рг);	 Тк.Записать(ФС.ТекКаталог()+Симв(92)+ИФ);	 ОНастройке();	 Помощь();    Иначе	 ФП=Лев(Стр,1);	   Если ФП=Симв(49) Тогда	  Если ПД(1)<=ТекущаяДата() Тогда	   СтрНов=ПС()+Симв(48)+Прав(Стр,21);			 Тк.ЗаменитьСтроку(Число(НН),СтрНов);	   Тк.Записать(ФС.ТекКаталог()+Симв(92)+ИФ);	   ФП=Симв(48);	   СохранитьЗначение(Н0, "4");	  КонецЕсли;		   Если ФП=Симв(48) Тогда		  Рг();	  КонецЕсли;	 ИначеЕсли ФП=Симв(48) Тогда	  СохранитьЗначение(Н0, "5");		 Рг();	 КонецЕсли;    КонецЕсли;   КонецЕсли;  КонецЕсли;Иначе  Если ФС.СуществуетФайл(ИФ)=0 Тогда   Тк=СоздатьОбъект("Текст");   ФП=Симв(48);   СохранитьЗначение(Н0, "6");	  Рг = ПС()+ФП+"/"+Строка(ТекущаяДата())+"/"+Строка(ТекущееВремя())+"/"+НН;   Для а=1 по Число(НН) Цикл	   Тк.ДобавитьСтроку(" ");   КонецЦикла;   Тк.ЗаменитьСтроку(Число(НН),Рг);   Тк.Записать(ФС.ТекКаталог()+Симв(92)+ИФ);	  Рг();  Иначе   Тк=СоздатьОбъект("Текст");   Тк.Открыть(ФС.ТекКаталог()+Симв(92)+ИФ);   Если Тк.КоличествоСтрок()<Число(НН) Тогда    ФП=Симв(48);    СохранитьЗначение(Н0, "7");	   Рг= ПС()+ФП+"/"+Строка(ТекущаяДата())+"/"+Строка(ТекущееВремя())+"/"+НН;    Для а=1 по (Число(НН)-Тк.КоличествоСтрок()) Цикл	    Тк.ДобавитьСтроку(" ");    КонецЦикла;    Тк.ЗаменитьСтроку(Число(НН),Рг);    Тк.Записать(ФС.ТекКаталог()+Симв(92)+ИФ);	   Рг();   Иначе    Стр=Тк.ПолучитьСтроку(Число(НН));    д = СтрДлина(ПС());    Если Не ((Сред(Стр,д,1)=Симв(32)) и ((Сред(Стр,д+1,1)=Симв(48)) или (Сред(Стр,д+1,1)=Симв(49)) или (Сред(Стр,д+1,1)=Симв(50)))) Тогда	 ФП=Симв(48);	 СохранитьЗначение(Н0, "8");	    Рг = ПС()+ФП+"/"+Строка(ТекущаяДата())+"/"+Строка(ТекущееВремя())+"/"+НН;	 Тк.ЗаменитьСтроку(Число(НН),Рг);	 Тк.Записать(ФС.ТекКаталог()+Симв(92)+ИФ);	    Рг();    Иначе	 Строчка = СокрЛП(Стр);	 ФП=Лев(Строчка,1);	 Если ФП=Симв(49) Тогда	  Если ПД(1)<=ТекущаяДата() Тогда	   СтрНов=ПС()+Симв(48)+Прав(Стр,21);			 Тк.ЗаменитьСтроку(Число(НН),СтрНов);	   Тк.Записать(ФС.ТекКаталог()+Симв(92)+ИФ);	   ФП=Симв(48);	   СохранитьЗначение(Н0, "9");	  КонецЕсли;		   Если ФП=Симв(48) Тогда		  Рг();	  КонецЕсли;	 ИначеЕсли ФП=Симв(48) Тогда	  СохранитьЗначение(Н0, "10");		 Рг();	 КонецЕсли;    КонецЕсли;   КонецЕсли;  КонецЕсли;КонецЕсли;КонецПроцедурыПроцедура Слои()Форма.ИспользоватьЗакладки(1);Если Форма.Закладки.НайтиЗначение(1)=0 Тогда	 Форма.Закладки.ДобавитьЗначение(1, "Лицевая сторона");КонецЕсли;Если Форма.Закладки.НайтиЗначение(2)=0 Тогда	 Форма.Закладки.ДобавитьЗначение(2, "Оборотная сторона");КонецЕсли;Форма.Закладки.ТекущаяСтрока(1);Форма.ИспользоватьСлой("Лист,ЛистО",2);ВидимостьРеквизитовГрузоотправитель();ВидимостьРеквизитовГрузополучатель();КонецПроцедурыПроцедура ПриВыбореЗакладки(НомерЗакладки,ЗначениеЗакладки)    Если ЗначениеЗакладки=2 Тогда	    Форма.ИспользоватьСлой("Оборот,ЛистО",2);  ВидимостьРеквизитовПеревозчик();  ВидимостьРеквизитовПлательщик();    ИначеЕсли ЗначениеЗакладки=1 Тогда  Форма.ИспользоватьСлой("Лист,ЛистО",2);  ВидимостьРеквизитовГрузоотправитель();  ВидимостьРеквизитовГрузополучатель();КонецЕсли;КонецПроцедурыПроцедура Позиционирование(Запись)НомСтр=0;ТаблицаДвижений.Сортировать("Дат,Ном");Если ТаблицаДвижений.НайтиЗначение(Запись,НомСтр,"НомерЗаписи")=1 Тогда  ТаблицаДвижений.ТекущаяСтрока(НомСтр);Иначе	 ТаблицаДвижений.ТекущаяСтрока(ТаблицаДвижений.КоличествоСтрок());КонецЕсли;КонецПроцедурыПроцедура ЗаполнитьСтрокуТаблицыДвижений(База)ТаблицаДвижений.Дат = База.dat;ТаблицаДвижений.Ном = База.nom;Если База.viddok = 1 Тогда	 ВидДокумента = "Реализация";Иначе  ВидДокумента = "ОтпускМатериаловНаСторону";КонецЕсли;ТаблицаДвижений.Основание=ПоискДокумента(ВидДокумента,База.nomdok,База.datdok);ТаблицаДвижений.ВариантОтправки = База.varotp;ТаблицаДвижений.Грузоотправитель = ПоискЭлементаПоКоду("Контрагенты",База.gruzotp);ТаблицаДвижений.Отпустил = База.otpustil;ТаблицаДвижений.ТелефонГрузоотправителя = База.otpu_tel;ТаблицаДвижений.ПунктПогрузки = База.pogr;ТаблицаДвижений.ВариантПолучения = База.varpol;ТаблицаДвижений.Грузополучатель = ПоискЭлементаПоКоду("Контрагенты",База.gruzpol);ТаблицаДвижений.Принял = База.prinyal;ТаблицаДвижений.ТелефонГрузополучателя = База.prin_tel;ТаблицаДвижений.ПунктРазгрузки = База.razgr;ТаблицаДвижений.ИмяГруза = База.gruz;ТаблицаДвижений.Упаковка = База.upakovka;ТаблицаДвижений.СпособМассы = База.opr_mass;ТаблицаДвижений.Вес = База.ves;ТаблицаДвижений.СтоимостьГруза = База.summa;ТаблицаДвижений.Документ2 = База.dok_2;ТаблицаДвижений.ФлагПеревозчика = База.flagper;    ТаблицаДвижений.Перевозчик = ПоискЭлементаПоКоду("Контрагенты",База.perevoz);ТаблицаДвижений.ЛицоПеревозчика = База.lico;ТаблицаДвижений.ТелефонПеревозчика = База.lico_tel;ТаблицаДвижений.Водитель = База.voditel;ТаблицаДвижений.ТелефонВодителя = База.vodi_tel;ТаблицаДвижений.АмМарка = База.ammarka;ТаблицаДвижений.АМГосНомер = База.amnomer;ТаблицаДвижений.СуммаТУ = База.summa_tu;ТаблицаДвижений.НомерЗаписи = База.НомерЗаписи();КонецПроцедурыПроцедура ЗаполнитьТаблицу(База,Запись="")ТаблицаДвижений.УдалитьСтроки();Если База.КоличествоЗаписей()>0 Тогда  Строчка=База.Первая();  Пока Строчка=1 Цикл	 Если (База.dat>=НачалоИнтервала) и (База.dat<=КонецИнтервала) Тогда	   ТаблицаДвижений.НоваяСтрока();    ЗаполнитьСтрокуТаблицыДвижений(База);    //ТаблицаДвижений.Дат = База.dat;    //ТаблицаДвижений.Ном = База.nom;    //ТаблицаДвижений.Грузополучатель = ПоискЭлементаПоКоду("Контрагенты",База.gruzpol);    //ТаблицаДвижений.Сумма = База.summa;    //ТаблицаДвижений.НомерЗаписи = База.НомерЗаписи();	  КонецЕсли;   Строчка=База.Следующая();   Если Строчка=0 тогда    прервать;   КонецЕсли;  КонецЦикла;КонецЕсли;Если ПустоеЗначение(Запись)=1 Тогда  ТаблицаДвижений.Сортировать("Дат,Ном");  Если ТаблицаДвижений.КоличествоСтрок()>0 Тогда   ТаблицаДвижений.ТекущаяСтрока(ТаблицаДвижений.КоличествоСтрок());  КонецЕсли;Иначе   Позиционирование(Запись); КонецЕсли;Форма.Заголовок("Журнал учета транспортных накладных ("+НачалоИнтервала+"-"+КонецИнтервала+")",0);КонецПроцедурыПроцедура ИзменитьИнтервал()НИ=НачалоИнтервала;КИ=КонецИнтервала;ИзменитьИнтервал=0;ВвестиДату(НИ,"Введите дату начала интервала видимости журнала.");ВвестиДату(КИ,"Введите дату конца интервала видимости журнала.");Если НИ>КИ Тогда	 Предупреждение("Дата начала интервала не может быть больше даты конца интервала!");  Возврат;КонецЕсли;Если НИ=НачалоИнтервала ТогдаИначе	 НачалоИнтервала=НИ;  ИзменитьИнтервал=1;КонецЕсли;Если КИ=КонецИнтервала ТогдаИначе	 КонецИнтервала=КИ;  ИзменитьИнтервал=1;КонецЕсли;Если ИзменитьИнтервал=1 Тогда   База=СоздатьОбъект("XBase");  База.КодоваяСтраница(1);   Если ФС.СуществуетФайл(ФайлДБФ)=1 Тогда   База.ОткрытьФайл(ФайлДБФ,,0);   ЗаполнитьТаблицу(База);   База.ЗакрытьФайл();  КонецЕсли;КонецЕсли;Активизировать("ТаблицаДвижений",);КонецПроцедурыПроцедура Очистка()Док="";Грузоотправитель="";Отпустил="";ТелефонГрузоотправителя="";ПунктПогрузки="";ДатаПогрузки="";Грузополучатель="";Принял="";ТелефонГрузополучателя="";ПунктРазгрузки="";ДатаРазгрузки="";ИмяГруза="";Упаковка="";СпособМассы="";Мест=0;Вес=0;Размер="";Объем=0;СтоимостьГруза=0;Документ1="";Документ2="";Перевозчик="";ЛицоПеревозчика="";ТелефонПеревозчика="";Водитель="";ТелефонВодителя="";//НомерПЛ="";АмМарка="";АМГосНомер="";СуммаТУ=0;Плательщик="";КонецПроцедурыПроцедура Сохранить(Очистить=1)База=СоздатьОбъект("XBase");База.КодоваяСтраница(1);Если ФС.СуществуетФайл(ФайлДБФ)=1 Тогда  База.ОткрытьФайл(ФайлДБФ,,0);   Если ФлагНовый=1 Тогда	  База.Добавить();  Иначе   База.Перейти(ТаблицаДвижений.НомерЗаписи);  КонецЕсли;	 База.УстановитьЗначениеПоля("nom",Ном);  База.УстановитьЗначениеПоля("dat",Дат);  База.УстановитьЗначениеПоля("v_nomdat",ВыводитьНомерИДату);   База.УстановитьЗначениеПоля("viddok",ВидДок);  База.УстановитьЗначениеПоля("nomdok",?(ПустоеЗначение(Док)=0,СокрЛП(Док.НомерДок),""));  База.УстановитьЗначениеПоля("datdok",?(ПустоеЗначение(Док)=0,Док.ДатаДок,""));   База.УстановитьЗначениеПоля("varotp",ВариантОтправки);  База.УстановитьЗначениеПоля("gruzotp",?(ПустоеЗначение(Грузоотправитель)=0,СокрЛП(Грузоотправитель.Код),""));  База.УстановитьЗначениеПоля("otpustil",Отпустил);  База.УстановитьЗначениеПоля("otpu_tel",ТелефонГрузоотправителя);  База.УстановитьЗначениеПоля("pogr",ПунктПогрузки);  База.УстановитьЗначениеПоля("dat_pogr",ДатаПогрузки);   База.УстановитьЗначениеПоля("varpol",ВариантПолучения);  База.УстановитьЗначениеПоля("gruzpol",?(ПустоеЗначение(Грузополучатель)=0,СокрЛП(Грузополучатель.Код),""));  База.УстановитьЗначениеПоля("prinyal",Принял);  База.УстановитьЗначениеПоля("prin_tel",ТелефонГрузополучателя);  База.УстановитьЗначениеПоля("razgr",ПунктРазгрузки);  База.УстановитьЗначениеПоля("dat_razg",ДатаРазгрузки);   База.УстановитьЗначениеПоля("gruz",ИмяГруза);  База.УстановитьЗначениеПоля("upakovka",Упаковка);  База.УстановитьЗначениеПоля("opr_mass",СпособМассы);  База.УстановитьЗначениеПоля("mest",Мест);  База.УстановитьЗначениеПоля("ves",Вес);  База.УстановитьЗначениеПоля("razmer",Размер);  База.УстановитьЗначениеПоля("obyem",Объем);  База.УстановитьЗначениеПоля("summa",СтоимостьГруза);  База.УстановитьЗначениеПоля("dok_1",Документ1);  База.УстановитьЗначениеПоля("dok_2",Документ2);   База.УстановитьЗначениеПоля("flagper",ФлагПеревозчика);  База.УстановитьЗначениеПоля("perevoz",?(ПустоеЗначение(Перевозчик)=0,СокрЛП(Перевозчик.Код),""));  База.УстановитьЗначениеПоля("lico",ЛицоПеревозчика);  База.УстановитьЗначениеПоля("lico_tel",ТелефонПеревозчика);   База.УстановитьЗначениеПоля("voditel",Водитель);  База.УстановитьЗначениеПоля("vodi_tel",ТелефонВодителя);  //База.УстановитьЗначениеПоля("vodit_pl",НомерПЛ);   База.УстановитьЗначениеПоля("ammarka",АмМарка);  База.УстановитьЗначениеПоля("amnomer",АмГосНомер);  База.УстановитьЗначениеПоля("summa_tu",СуммаТУ);   База.УстановитьЗначениеПоля("flagpl",ФлагПлательщика);  База.УстановитьЗначениеПоля("plat_tr",?(ПустоеЗначение(Плательщик)=0,СокрЛП(Плательщик.Код),""));	 База.Записать();   Если ФлагНовый=1 Тогда   ТаблицаДвижений.НоваяСтрока();   ЗаполнитьСтрокуТаблицыДвижений(База);   Если (ТаблицаДвижений.Дат>=НачалоИнтервала) и (ТаблицаДвижений.Дат<=КонецИнтервала) Тогда    Позиционирование(ТаблицаДвижений.НомерЗаписи);   Иначе    Если ТаблицаДвижений.Дат<НачалоИнтервала Тогда	    НачалоИнтервала=ТаблицаДвижений.Дат;    ИначеЕсли ТаблицаДвижений.Дат>КонецИнтервала Тогда	 КонецИнтервала=ТаблицаДвижений.Дат;    КонецЕсли;    ЗаполнитьТаблицу(База, ТаблицаДвижений.НомерЗаписи);   КонецЕсли;  Иначе   ЗаполнитьСтрокуТаблицыДвижений(База);  КонецЕсли;   ЗначенияПоУмолчаниюСохранитьИсх();  ФлагМодифицированности=0;  ФлагНовый=0;   База.ЗакрытьФайл();КонецЕсли;КонецПроцедурыФункция НовыйНомер(База="")Если База="" Тогда	 БазаОткрыта=0;Иначе  БазаОткрыта=1;КонецЕсли;НГ=НачГода(Дат);КГ=КонГода(Дат);    сз=создатьОбъект("СписокЗначений");Если БазаОткрыта=0 Тогда  База=СоздатьОбъект("XBase");  База.КодоваяСтраница(1);  База.ОткрытьФайл(ФайлДБФ,,0);КонецЕсли;База=СоздатьОбъект("XBase");База.КодоваяСтраница(1);База.ОткрытьФайл(ФайлДБФ,,0); Если База.КоличествоЗаписей()>0 Тогда  Строчка=База.Первая();  Пока Строчка=1 Цикл	 Если (База.dat>=НГ) и (База.dat<=КГ) Тогда	   сз.ДобавитьЗначение(База.nom);   КонецЕсли;   Строчка=База.Следующая();   Если Строчка=0 тогда    прервать;   КонецЕсли;  КонецЦикла;  сз.Сортировать(1,);  Если сз.РазмерСписка()=0 Тогда	  Возврат 1;  Иначе   Возврат (сз.ПолучитьЗначение(1,)+1);  КонецЕсли;Иначе  Возврат 1;КонецЕсли;Если БазаОткрыта=0 Тогда  База.ЗакрытьФайл();КонецЕсли;КонецФункцииПроцедура Новый()Очистка();ЗначенияПоУмолчаниюВосстановитьИсх();НазначитьТипДок();Слои();ФлагНовый=1;ФлагМодифицированности=1;Форма.Заголовок("ТН - Новый",0);ТекущийСлой="Лист";Дат= РабочаяДата();Ном=НовыйНомер();КонецПроцедурыПроцедура Открыть(ФлагОткКоп)Если ТаблицаДвижений.ТекущаяСтрока()=0 ТогдаИначе   База=СоздатьОбъект("XBase");  База.КодоваяСтраница(1);   Если ФС.СуществуетФайл(ФайлДБФ)=1 Тогда   База.ОткрытьФайл(ФайлДБФ,,0);    Очистка();   ТекущийСлой="Лист";   Если ФлагОткКоп=1 Тогда    ФлагНовый=0;    База.Перейти(ТаблицаДвижений.НомерЗаписи);    Дат = База.dat;    Ном = База.nom;    Форма.Заголовок("ТН - "+Ном,0);   Иначе    ФлагНовый=1;    ФлагМодифицированности=1;    ФлагМодифицированностиТаб=1;    Форма.Заголовок("ТН - Новый",0);    Дат=РабочаяДата();    Ном=НовыйНомер(База);    База.Перейти(ТаблицаДвижений.НомерЗаписи);   КонецЕсли;   ВидДок=База.viddok;   ВидДокумента = "Реализация";   Если ВидДок = 2 Тогда    ВидДокумента = "ОтпускМатериаловНаСторону";   КонецЕсли;   НазначитьТипДок();   Док=ПоискДокумента(ВидДокумента,База.nomdok,База.datdok);	 ВыводитьНомерИДату=База.v_nomdat;	 ВариантОтправки=База.varotp;   ВидимостьРеквизитовГрузоотправитель();   Грузоотправитель=ПоискЭлементаПоКоду("Контрагенты",База.gruzotp);   Отпустил=База.otpustil;   ТелефонГрузоотправителя=База.otpu_tel;   ПунктПогрузки=База.pogr;   ДатаПогрузки=База.dat_pogr;	 ВариантПолучения=База.varpol;   ВидимостьРеквизитовГрузополучатель();   Грузополучатель=ПоискЭлементаПоКоду("Контрагенты",База.gruzpol);   Принял=База.prinyal;   ТелефонГрузополучателя=База.prin_tel;   ПунктРазгрузки=База.razgr;   ДатаРазгрузки=База.dat_razg;	 ИмяГруза=База.gruz;   Упаковка=База.upakovka;   СпособМассы=База.opr_mass;   Мест=База.mest;   Вес=База.ves;   Размер=База.razmer;   Объем=База.obyem;   СтоимостьГруза=База.summa;   Документ1=База.dok_1;   Документ2=База.dok_2;   ФлагПеревозчика=База.flagper;   Перевозчик=ПоискЭлементаПоКоду("Контрагенты",База.perevoz);   ЛицоПеревозчика=База.lico;   ТелефонПеревозчика=База.lico_tel;	 Водитель=База.voditel;   ТелефонВодителя=База.vodi_tel;   //НомерПЛ=База.vodit_pl;   АмМарка=База.ammarka;   АмГосНомер=База.amnomer;	 СуммаТУ=База.summa_tu;	 ФлагПлательщика=База.flagpl;   Плательщик=ПоискЭлементаПоКоду("Контрагенты",База.plat_tr);	 Слои();	 База.ЗакрытьФайл();  КонецЕсли; КонецЕсли;КонецПроцедурыПроцедура УдалитьСтроку()Если ТаблицаДвижений.ТекущаяСтрока()=0 ТогдаИначе   Если Вопрос("Удалить ТН?",4)=6 Тогда   НомСтр=ТаблицаДвижений.НомерСтроки;	 База=СоздатьОбъект("XBase");   База.КодоваяСтраница(1);	 Если ФС.СуществуетФайл(ФайлДБФ)=1 Тогда    База.ОткрытьФайл(ФайлДБФ,,0);    База.Перейти(ТаблицаДвижений.НомерЗаписи);    База.Удалить();    База.Записать();    База.ЗакрытьФайл();   КонецЕсли;	 ТаблицаДвижений.УдалитьСтроку();   Если ТаблицаДвижений.КоличествоСтрок()>=НомСтр Тогда	   ТаблицаДвижений.ТекущаяСтрока(НомСтр);   ИначеЕсли ТаблицаДвижений.КоличествоСтрок()>0 Тогда    ТаблицаДвижений.ТекущаяСтрока(ТаблицаДвижений.КоличествоСтрок());   КонецЕсли;   Активизировать("ТаблицаДвижений",);  КонецЕсли;КонецЕсли;КонецПроцедурыФункция ДатьНашуФирмуНаПечать()Если СтрДлина(СокрЛП(Константа.ИННОрганизации)) = 12 Тогда  ФизЛицоНаПечать=СокрЛП(Константа.НаименованиеОрганизации)+"; адрес: "+СокрЛП(глПредставлениеАдреса(Константа.ПочтовыйАдресОрганизации))+"; тел. "+СокрЛП(Константа.ТелефоныОрганизации);  ЮрЛицоНаПечать="";Иначе  ФизЛицоНаПечать="";  ЮрЛицоНаПечать=СокрЛП(Константа.НаименованиеОрганизации)+"; адрес: "+СокрЛП(глПредставлениеАдреса(Константа.ПочтовыйАдресОрганизации))+"; тел. "+СокрЛП(Константа.ТелефоныОрганизации);КонецЕсли;сз = СоздатьОбъект("СписокЗначений");сз.ДобавитьЗначение(ФизЛицоНаПечать);сз.ДобавитьЗначение(ЮрЛицоНаПечать);Возврат сз;КонецФункцииФункция ДатьКонтрагентаНаПечать(Контр)ФизЛицоНаПечать="";ЮрЛицоНаПечать="";Если ПустоеЗначение(Контр)=0 Тогда  Если Контр.ВидКонтрагента = Перечисление.ВидыКонтрагентов.ЧастноеЛицо Тогда   ФизЛицоНаПечать=СокрЛП(Контр.ПолнНаименование)+"; адрес: "+СокрЛП(глПредставлениеАдреса(Контр.ПочтовыйАдрес))+"; тел. "+СокрЛП(Контр.Телефоны);   ЮрЛицоНаПечать="";  Иначе   ФизЛицоНаПечать="";   ЮрЛицоНаПечать=СокрЛП(Контр.ПолнНаименование)+"; адрес: "+СокрЛП(глПредставлениеАдреса(Контр.ПочтовыйАдрес))+"; тел. "+СокрЛП(Контр.Телефоны);  КонецЕсли;КонецЕсли;сз = СоздатьОбъект("СписокЗначений");сз.ДобавитьЗначение(ФизЛицоНаПечать);сз.ДобавитьЗначение(ЮрЛицоНаПечать);Возврат сз;КонецФункцииФункция ДатьГрузоотправителяНаПечать()Если ВариантОтправки = 1 Тогда  сз = ДатьНашуФирмуНаПечать();Иначе  сз = ДатьКонтрагентаНаПечать(Грузоотправитель);КонецЕсли;Возврат сз;КонецФункцииФункция ДатьГрузополучателяНаПечать()Если ВариантПолучения = 1 Тогда  сз = ДатьНашуФирмуНаПечать();Иначе  сз = ДатьКонтрагентаНаПечать(Грузополучатель);КонецЕсли;Возврат сз;КонецФункцииПроцедура Печать14(Таб="")Если ПустоеЗначение(Таб)=1 Тогда  Таб = СоздатьОбъект("Таблица");  Таб.ИсходнаяТаблица("Таблица");  ОбеСтороны=0;Иначе  Таб.НоваяСтраница();  ОбеСтороны=1;КонецЕсли;//Таб = СоздатьОбъект("Таблица");//Таб.ИсходнаяТаблица("Таблица");ПеревозчикФизЛицоНаПечать = "";ПеревозчикЮрЛицоНаПечать = "";СписокПеревозчикаНаПечать=СоздатьОбъект("СписокЗначений");Если ФлагПеревозчика=1 Тогда	 СписокПеревозчикаНаПечать = ДатьГрузоотправителяНаПечать();  ПеревозчикПодписьНаПечать = ?(ВариантОтправки = 1,СокрЛП(Константа.НаименованиеОрганизации),СокрЛП(Грузоотправитель.ПолнНаименование));ИначеЕсли ФлагПеревозчика=2 Тогда  СписокПеревозчикаНаПечать = ДатьГрузополучателяНаПечать();  ПеревозчикПодписьНаПечать = ?(ВариантПолучения = 1,СокрЛП(Константа.НаименованиеОрганизации),СокрЛП(Грузополучатель.ПолнНаименование));ИначеЕсли ФлагПеревозчика=3 Тогда  СписокПеревозчикаНаПечать = ДатьКонтрагентаНаПечать(Перевозчик);  ПеревозчикПодписьНаПечать = СокрЛП(Перевозчик.ПолнНаименование);КонецЕсли;Если СписокПеревозчикаНаПечать.РазмерСписка() = 2 Тогда  ПеревозчикФизЛицоНаПечать = СписокПеревозчикаНаПечать.ПолучитьЗначение(1);  ПеревозчикЮрЛицоНаПечать = СписокПеревозчикаНаПечать.ПолучитьЗначение(2);КонецЕсли;ЛицоПеревозчикаНаПечать = СокрЛП(ЛицоПеревозчика)+?(ПустаяСтрока(ТелефонПеревозчика)=1,"",", тел. "+СокрЛП(ТелефонПеревозчика));ВодительНаПечать = СокрЛП(Водитель)+?(ПустаяСтрока(ТелефонВодителя)=1,"",", тел. "+СокрЛП(ТелефонВодителя));//НомерПЛНаПечать = НомерПЛ;АмМаркаНаПечать = АмМарка;АМГосНомерНаПечать = АМГосНомер;СуммаТУНаПечать = ?(СуммаТУ=0,"",""+ФРМ(СуммаТУ));Если ВариантОтправки = 1 Тогда	 ГрузоотправительПодписьНаПечать = СокрЛП(Константа.НаименованиеОрганизации);Иначе  ГрузоотправительПодписьНаПечать = СокрЛП(Грузоотправитель.ПолнНаименование);КонецЕсли;//ГрузоотправительПодписьНаПечать = ГрузоотправительПодписьНаПечать + РазделительСтрок+Формат(Дат ,"Д (0)ДДММГГГГ")+"   "+СокрЛП(Отпустил);//ПеревозчикПодписьНаПечать = ПеревозчикПодписьНаПечать + РазделительСтрок+Формат(Дат ,"Д (0)ДДММГГГГ")+"   "+СокрЛП(ЛицоПеревозчика);//Если ВариантОтправки = 1 Тогда//    ГрузоотправительПодписьНаПечать = СокрЛП(Константа.НазваниеОрганизации);//Иначе// ГрузоотправительПодписьНаПечать = СокрЛП(Грузоотправитель.ПолнНаименование);//КонецЕсли;//ГрузоотправительПодписьНаПечать = ГрузоотправительПодписьНаПечать + РазделительСтрок+СокрЛП(Отпустил);ПеревозчикПодписьНаПечать = ПеревозчикПодписьНаПечать + РазделительСтрок+ФИО(ЛицоПеревозчика);ДатПодписиНаПечать = Формат(Дат ,"Д (0)ДДММГГГГ");Процедура ЗаполнитьНекиеРеквизиты(СчетКонтрагента,Контр = "")Если Контр = "" Тогда  КонтрАдрес = СокрЛП(Константа.НаименованиеОрганизации);  глДобавитьРеквизит(КонтрАдрес, ", ", глПредставлениеАдреса(Константа.АдресОрганизации));Иначе  КонтрАдрес = СокрЛП(Контр.ПолнНаименование)+", "+СокрЛП(Контр.ЮридическийАдрес)КонецЕсли;Если ПустоеЗначение(СчетКонтрагента) = 0 Тогда  глДобавитьРеквизит(КонтрАдрес, ", р/с ", СокрЛП(СчетКонтрагента.Номер) + " в " + СчетКонтрагента.БанкОрганизации);  глДобавитьРеквизит(КонтрАдрес, ", БИК ", СокрЛП(СчетКонтрагента.БанкОрганизации.Код));  глДобавитьРеквизит(КонтрАдрес, ", корр/с ", СчетКонтрагента.БанкОрганизации.КоррСчет);КонецЕсли;ПлательщикНаПечать=КонтрАдрес;КонецПроцедурыПроцедура Осн()ПлательщикНаПечать = "";Если ФлагПлательщика=1 Тогда  Если ВариантОтправки=1 Тогда   ЗаполнитьНекиеРеквизиты(Константа.ОсновнойБанковскийСчет);  Иначе   Если ПустоеЗначение(Грузоотправитель)=0 Тогда    ЗаполнитьНекиеРеквизиты(глРасчетныйСчетКонтрагента(Грузоотправитель),Грузоотправитель);   КонецЕсли;  КонецЕсли;ИначеЕсли ФлагПлательщика=2 Тогда  Если ВариантПолучения=1 Тогда   ЗаполнитьНекиеРеквизиты(Константа.ОсновнойБанковскийСчет);  Иначе   Если ПустоеЗначение(Грузополучатель)=0 Тогда    ЗаполнитьНекиеРеквизиты(глРасчетныйСчетКонтрагента(Грузополучатель),Грузополучатель);   КонецЕсли;  КонецЕсли;Иначе  Если ПустоеЗначение(Плательщик)=0 Тогда   ЗаполнитьНекиеРеквизиты(глРасчетныйСчетКонтрагента(Плательщик),Плательщик);  КонецЕсли;КонецЕсли;Таб.ВывестиСекцию("Оборот");Таб.Опции(0,0,0,0,"ОпцииПечатиТН2","ОкноТН2");    Таб.ПараметрыСтраницы(1,,,10,10,10,10,10,10,1);Таб.ТолькоПросмотр(0);Если ОбеСтороны=0 Тогда  Таб.Показать("Печать ТН: Оборотная сторона","");Иначе  Таб.Показать("Печать ТН","");КонецЕсли;//Таб.Показать("Печать ТН: Оборотная сторона","");КонецПроцедурыПроцедура Печать13(ОбеСтороны="")Таб = СоздатьОбъект("Таблица");Таб.ИсходнаяТаблица("Таблица");Если ВыводитьНомерИДату=1 Тогда  ДатНаПечать = Формат(Дат ,"Д (0)ДДММММГГГГ");  НомНаПечать = Ном;Иначе  ДатНаПечать = "";  НомНаПечать = "";КонецЕсли;СписокГрузоотправителяНаПечать = ДатьГрузоотправителяНаПечать();ГрузоотправительФизЛицоНаПечать=СписокГрузоотправителяНаПечать.ПолучитьЗначение(1);ГрузоотправительЮрЛицоНаПечать=СписокГрузоотправителяНаПечать.ПолучитьЗначение(2);//ОтпустилНаПечать = СокрЛП(Отпустил)+?(ПустаяСтрока(ТелефонГрузоотправителя)=1,"",", тел. "+СокрЛП(ТелефонГрузоотправителя));СписокГрузополучателяНаПечать = ДатьГрузополучателяНаПечать();ГрузополучательФизЛицоНаПечать=СписокГрузополучателяНаПечать.ПолучитьЗначение(1);ГрузополучательЮрЛицоНаПечать=СписокГрузополучателяНаПечать.ПолучитьЗначение(2);//ПринялНаПечать = СокрЛП(Принял)+?(ПустаяСтрока(ТелефонГрузополучателя)=1,"",", тел. "+СокрЛП(ТелефонГрузополучателя));ИмяГрузаНаПечать = ИмяГруза;МестУпаковкаНаПечать=?(Мест=0,"","Количество мест "+Мест)+?((Мест<>0) и (ПустоеЗначение(Упаковка)=0),", ","")+СокрЛП(Упаковка);ВесРазмерОбъемНаПечать=?(Вес=0,"","Масса "+Вес+" кг. ")+?(ПустоеЗначение(Размер)=1,"","Размеры "+СокрЛП(Размер)+" ")+?(Объем=0,"","Объём "+Объем+" м3");Документ1НаПечать = Документ1;Документ2НаПечать = Документ2;СуммаНаПечать = ?(СтоимостьГруза=0,"",""+ФРМ(СтоимостьГруза)+" ("+Формат(СтоимостьГруза, "ЧПДС")+")");ПунктПогрузкиНаПечать = ПунктПогрузки;ДатаПогрузкиНаПечать = ДатаПогрузки;ПунктРазгрузкиНаПечать = ПунктРазгрузки;ДатаРазгрузкиНаПечать = ДатаРазгрузки;ВесНаПечать = ?(Вес=0,"",""+Вес+" кг. ");МестНаПечать = ?(Мест=0,"",""+Мест);ДолжностьОтпустилНаПечать = СокрЛП(ТелефонГрузоотправителя);ОтпустилНаПечать = СокрЛП(Отпустил);ДолжностьПринялНаПечать = СокрЛП(ТелефонГрузополучателя);ПринялНаПечать = СокрЛП(Принял);ФИОВодительНаПечать = ФИО(Водитель);ВесСпособМассыНаПечать =?(Вес=0,"","Масса груза "+Вес+" кг. ")+?(ПустаяСтрока(СпособМассы)=1,"","Способ определения массы "+СокрЛП(СпособМассы));ДатЗаявкиНаПечать = "";ЛицоПеревозчикаНаПечать = "";ДолжностьПеревозчикаНаПечать = "";Если ФлагПеревозчика = 3 Тогда  ДатЗаявкиНаПечать = Формат(Дат ,"Д (0)ДДММММГГГГ");  ЛицоПеревозчикаНаПечать = СокрЛП(ЛицоПеревозчика);  ДолжностьПеревозчикаНаПечать = СокрЛП(ТелефонПеревозчика);КонецЕсли;Таб.ВывестиСекцию("Лицо");Если ПустоеЗначение(ОбеСтороны) = 1 Тогда  Таб.Опции(0,0,0,0,"ОпцииПечатиТН","ОкноТН");  Таб.ПараметрыСтраницы(1,,,10,10,10,10,10,10,1);  Таб.ТолькоПросмотр(0);  Таб.Показать("Печать ТН: Лицевая сторона","");Иначе  Печать14(Таб);КонецЕсли;//Таб.Опции(0,0,0,0,"ОпцииПечатиТН","ОкноТН");//Таб.ПараметрыСтраницы(1,,,10,10,10,10,10,10,1);//Таб.ТолькоПросмотр(0);//Таб.Показать("Печать ТН: Лицевая сторона","");КонецПроцедурыПроцедура Печать1()Если ФП = Симв(48) Тогда  Рг();  Возврат;КонецЕсли;Меню = СоздатьОбъект("СписокЗначений");Меню.ДобавитьЗначение(1, "Лицевая сторона");Меню.ДобавитьЗначение(2, "Оборотная сторона");Меню.ДобавитьЗначение(3, "Обе стороны");Выбор = "";Меню.ВыбратьЗначение(Выбор,,,,1);Если Выбор = 1 Тогда  Печать13();ИначеЕсли Выбор = 2 Тогда  Печать14();ИначеЕсли Выбор = 3 Тогда  Печать13("Обе стороны");КонецЕсли;КонецПроцедурыПроцедура Печать()Перем ПредставлениеКолонки;Если ФП = Симв(48) Тогда  Рг();  Возврат;КонецЕсли;Если ТаблицаДвижений.КоличествоСтрок()=0 Тогда	 Предупреждение("В журнале нет накладных!");  Возврат;КонецЕсли;Пер=ПериодСтр(НачалоИнтервала,КонецИнтервала);ОргНаПечать=СокрЛП(Константа.НаименованиеОрганизации);Таб = СоздатьОбъект("Таблица");Таб.ИсходнаяТаблица("Журнал");Таб.ПовторятьПриПечатиСтроки(5,5);Таб.ВывестиСекцию("Шапка|Основные");Если ТипЗначенияСтр(СписокКолонок) = "СписокЗначений" Тогда	 Если СписокКолонок.РазмерСписка()=0 Тогда  Иначе   Для ё=1 По СписокКолонок.РазмерСписка() Цикл    ИмяКолонки = СписокКолонок.ПолучитьЗначение(ё,ПредставлениеКолонки);    Если Найти(ПредставлениеКолонки,"v")=0 Тогда    Иначе	 Таб.ПрисоединитьСекцию("Шапка|"+ИмяКолонки);    КонецЕсли;   КонецЦикла;  КонецЕсли;КонецЕсли;ТаблицаДвижений.ВыбратьСтроки();Пока ТаблицаДвижений.ПолучитьСтроку()=1 Цикл  Таб.ВывестиСекцию("Строка|Основные");   Если ТипЗначенияСтр(СписокКолонок) = "СписокЗначений" Тогда	  Если СписокКолонок.РазмерСписка()=0 Тогда   Иначе    Для ё=1 По СписокКолонок.РазмерСписка() Цикл	 ИмяКолонки = СписокКолонок.ПолучитьЗначение(ё,ПредставлениеКолонки);	 Если Найти(ПредставлениеКолонки,"v")=0 Тогда	 Иначе	  Таб.ПрисоединитьСекцию("Строка|"+ИмяКолонки);	 КонецЕсли;    КонецЦикла;   КонецЕсли;  КонецЕсли;КонецЦикла;Таб.ВывестиСекцию("Подвал|Основные");Если ТипЗначенияСтр(СписокКолонок) = "СписокЗначений" Тогда	 Если СписокКолонок.РазмерСписка()=0 Тогда  Иначе   Для ё=1 По СписокКолонок.РазмерСписка() Цикл    ИмяКолонки = СписокКолонок.ПолучитьЗначение(ё,ПредставлениеКолонки);    Если Найти(ПредставлениеКолонки,"v")=0 Тогда    Иначе	 Таб.ПрисоединитьСекцию("Подвал|"+ИмяКолонки);    КонецЕсли;   КонецЦикла;  КонецЕсли;КонецЕсли;Таб.Опции(0,0,0,0,"ЖурналТН","ЖурналТН2");Таб.ТолькоПросмотр(0);//Таб.ПараметрыСтраницы(1,,,20,20,20,20,0,0,1);Таб.ПараметрыСтраницы(,,,10,10,10,10,0,0,1);Таб.Показать("Журнал регистрации ТН","");КонецПроцедурыПроцедура ПриОткрытии()СписокКолонок=ВосстановитьЗначение("СписокКолонок");Форма.Грузоотправитель.ВыборГруппы(0);Форма.Грузополучатель.ВыборГруппы(0);Форма.Перевозчик.ВыборГруппы(0);Форма.Плательщик.ВыборГруппы(0);ННН=ВосстановитьЗначение(Н);ННН0=ВосстановитьЗначение(Н0);ИФ = ПТ();Конфа="У";ИНН=СокрЛ(Лев(Константа.ИННОрганизации,10));НачалоИнтервала=ВосстановитьЗначение("НачалоИнтервала");Если ПустоеЗначение(НачалоИнтервала)=1 Тогда	 НачалоИнтервала=НачГода(РабочаяДата());КонецЕсли;КонецИнтервала=ВосстановитьЗначение("КонецИнтервала");Если ПустоеЗначение(КонецИнтервала)=1 Тогда	 КонецИнтервала=КонГода(РабочаяДата());КонецЕсли;Форма.ИспользоватьСлой("Основной",2);    ТекущийСлой="Основной";ТаблицаДвижений.Очистить();ТаблицаДвижений.НоваяКолонка("Дат", "Дата",,, "Дата",,,2);ТаблицаДвижений.НоваяКолонка("Ном", "Число", 10,0, "Номер",,,2);//ТаблицаДвижений.НоваяКолонка("Грузополучатель", "Справочник.Контрагенты",,,"Грузополучатель",,,1);//ТаблицаДвижений.НоваяКолонка("Сумма", "Число", 15,2, "Сумма",,,2);ТаблицаДвижений.НоваяКолонка("Основание", "Документ",,,"Основание",,,1);ТаблицаДвижений.НоваяКолонка("ВариантОтправки", "Число", 1,0,,,,);ТаблицаДвижений.НоваяКолонка("Грузоотправитель", "Справочник.Контрагенты",,,"Грузоотправитель",,,1);ТаблицаДвижений.НоваяКолонка("Отпустил", "Строка", 50,, "Отпустил",,,1);ТаблицаДвижений.НоваяКолонка("ТелефонГрузоотправителя", "Строка", 50,, "Должность отправителя",,,1);ТаблицаДвижений.НоваяКолонка("ПунктПогрузки", "Строка",80,, "Погрузка",,,1);ТаблицаДвижений.НоваяКолонка("ВариантПолучения", "Число", 1,0,,,,);ТаблицаДвижений.НоваяКолонка("Грузополучатель", "Справочник.Контрагенты",,,"Грузополучатель",,,1);ТаблицаДвижений.НоваяКолонка("Принял", "Строка", 50,, "Принял",,,1);ТаблицаДвижений.НоваяКолонка("ТелефонГрузополучателя", "Строка", 50,, "Должность получателя",,,1);ТаблицаДвижений.НоваяКолонка("ПунктРазгрузки", "Строка",80,, "Разгрузка",,,1);ТаблицаДвижений.НоваяКолонка("ИмяГруза", "Строка",100,, "Груз",,,1);ТаблицаДвижений.НоваяКолонка("Упаковка", "Строка",30,,"",,,);ТаблицаДвижений.НоваяКолонка("СпособМассы", "Строка",30,,"",,,);ТаблицаДвижений.НоваяКолонка("Вес", "Число", 15,3, "Масса",,,2);ТаблицаДвижений.НоваяКолонка("СтоимостьГруза", "Число", 15,2, "Сумма",,,2);ТаблицаДвижений.НоваяКолонка("Документ2", "Строка",100,,"",,,);ТаблицаДвижений.НоваяКолонка("ФлагПеревозчика", "Число", 1,0,,,,);    ТаблицаДвижений.НоваяКолонка("Перевозчик", "Справочник.Контрагенты",,,"Перевозчик",,,1);ТаблицаДвижений.НоваяКолонка("ЛицоПеревозчика", "Строка", 50,, "От перевозчика",,,1);ТаблицаДвижений.НоваяКолонка("ТелефонПеревозчика", "Строка", 50,, "Должность перевозчика",,,1);ТаблицаДвижений.НоваяКолонка("Водитель", "Строка", 50,, "Водитель",,,1);ТаблицаДвижений.НоваяКолонка("ТелефонВодителя", "Строка", 20,, "Тел. водителя",,,1);ТаблицаДвижений.НоваяКолонка("АмМарка", "Строка", 100,, "Автомобиль",,,1);ТаблицаДвижений.НоваяКолонка("АМГосНомер", "Строка", 20,, "Гос. номер",,,1);ТаблицаДвижений.НоваяКолонка("СуммаТУ", "Число", 15,2, "Сумма перевозки",,,2);ТаблицаДвижений.НоваяКолонка("НомерЗаписи", "Число", 10,0,);ТаблицаДвижений.ВидимостьКолонки("ВариантОтправки",0,);ТаблицаДвижений.ВидимостьКолонки("ВариантПолучения",0,);ТаблицаДвижений.ВидимостьКолонки("Упаковка",0,);ТаблицаДвижений.ВидимостьКолонки("СпособМассы",0,);ТаблицаДвижений.ВидимостьКолонки("Документ2",0,);ТаблицаДвижений.ВидимостьКолонки("ФлагПеревозчика",0,);ТаблицаДвижений.ВидимостьКолонки("НомерЗаписи",0,);ТаблицаДвижений.ВидимостьКолонки("ТелефонГрузоотправителя",0,);ТаблицаДвижений.ВидимостьКолонки("ТелефонГрузополучателя",0,);ТаблицаДвижений.ВидимостьКолонки("ТелефонПеревозчика",0,);//СписокКолонок=""; //удалитьЕсли ТипЗначенияСтр(СписокКолонок) = "СписокЗначений" ТогдаИначе	 СписокКолонок = СоздатьОбъект("СписокЗначений");  СписокКолонок.ДобавитьЗначение("Основание","[  ] Документ-основание");  СписокКолонок.ДобавитьЗначение("Грузоотправитель","[  ] Грузоотправитель");  СписокКолонок.ДобавитьЗначение("Отпустил","[  ] Отпустил");  //СписокКолонок.ДобавитьЗначение("ТелефонГрузоотправителя","[  ] Тел. отправителя");  СписокКолонок.ДобавитьЗначение("ПунктПогрузки","[  ] Погрузка");  СписокКолонок.ДобавитьЗначение("Грузополучатель","[v] Грузополучатель");  СписокКолонок.ДобавитьЗначение("Принял","[  ] Принял");  //СписокКолонок.ДобавитьЗначение("ТелефонГрузополучателя","[  ] Тел. получателя");  СписокКолонок.ДобавитьЗначение("ПунктРазгрузки","[  ] Разгрузка");  СписокКолонок.ДобавитьЗначение("ИмяГруза","[  ] Груз");  СписокКолонок.ДобавитьЗначение("Вес","[  ] Масса");  СписокКолонок.ДобавитьЗначение("СтоимостьГруза","[v] Сумма");  СписокКолонок.ДобавитьЗначение("Перевозчик","[  ] Перевозчик");  СписокКолонок.ДобавитьЗначение("ЛицоПеревозчика","[  ] От перевозчика");  //СписокКолонок.ДобавитьЗначение("ТелефонПеревозчика","[  ] Тел. перевозчика");  СписокКолонок.ДобавитьЗначение("Водитель","[  ] Водитель");  СписокКолонок.ДобавитьЗначение("ТелефонВодителя","[  ] Тел. водителя");  СписокКолонок.ДобавитьЗначение("АмМарка","[  ] Автомобиль");  СписокКолонок.ДобавитьЗначение("АМГосНомер","[  ] Гос. номер");  СписокКолонок.ДобавитьЗначение("СуммаТУ","[  ] Сумма перевозки"); КонецЕсли;УстановитьВидимостьКолонок();Путь = "";Имя  = "";РасположениеФайла(Путь, Имя);ФС.УстТекКаталог(Путь);Если ФС.СуществуетФайл(Путь+Конфа+ИНН)=0 Тогда  ФС.СоздатьКаталог(Конфа+ИНН);  сообщить("Создан каталог для хранения базы данных транспортных накладных: "+Путь+Конфа+ИНН);КонецЕсли;ФС.УстТекКаталог(КаталогИБ());З();ФайлДБФ = Путь+Конфа+ИНН+"\"+"tn_u_1.dbf";ПутьКбазе="";Если ФС.СуществуетФайл(Путь+Конфа+ИНН)=1 Тогда  ПутьКбазе=Путь+Конфа+ИНН+"\";КонецЕсли;База=СоздатьОбъект("XBase");База.КодоваяСтраница(1); Если ФС.СуществуетФайл(ФайлДБФ)=0 Тогда   База.ДобавитьПоле("nom",1,8,0);  База.ДобавитьПоле("dat",3,,);  База.ДобавитьПоле("v_nomdat",1,1,0);   База.ДобавитьПоле("viddok",1,1,0);  База.ДобавитьПоле("nomdok",2,10,);  База.ДобавитьПоле("datdok",3,,);  База.ДобавитьПоле("varotp",1,1,0);  База.ДобавитьПоле("gruzotp",2,10,);  База.ДобавитьПоле("otpustil",2,50,);  База.ДобавитьПоле("otpu_tel",2,50,);  База.ДобавитьПоле("pogr",2,80,);  База.ДобавитьПоле("dat_pogr",2,30,);   База.ДобавитьПоле("varpol",1,1,0);  База.ДобавитьПоле("gruzpol",2,10,);  База.ДобавитьПоле("prinyal",2,50,);  База.ДобавитьПоле("prin_tel",2,50,);  База.ДобавитьПоле("razgr",2,80,);  База.ДобавитьПоле("dat_razg",2,30,);   База.ДобавитьПоле("gruz",2,100,);  База.ДобавитьПоле("upakovka",2,30,);  База.ДобавитьПоле("opr_mass",2,30,);  База.ДобавитьПоле("mest",1,5,0);  База.ДобавитьПоле("ves",1,15,3);  База.ДобавитьПоле("razmer",2,20,);  База.ДобавитьПоле("obyem",1,10,1);  База.ДобавитьПоле("summa",1,15,2);  База.ДобавитьПоле("dok_1",2,100,);  База.ДобавитьПоле("dok_2",2,100,);  База.ДобавитьПоле("flagper",1,1,0);  База.ДобавитьПоле("perevoz",2,10,);  База.ДобавитьПоле("lico",2,50,);  База.ДобавитьПоле("lico_tel",2,50,);  База.ДобавитьПоле("voditel",2,50,);  База.ДобавитьПоле("vodi_tel",2,20,);  //База.ДобавитьПоле("vodit_pl",2,40,);   База.ДобавитьПоле("ammarka",2,100,);  База.ДобавитьПоле("amnomer",2,20,);  База.ДобавитьПоле("summa_tu",1,15,2);   База.ДобавитьПоле("flagpl",1,1,0);  База.ДобавитьПоле("plat_tr",2,10,);   База.СоздатьФайл(ФайлДБФ);  База.Записать();  База.ЗакрытьФайл();   сообщить("Создан файл базы данных исходящих транспортных накладных: "+ФайлДБФ);  Форма.Заголовок("Журнал учета ТН ("+НачалоИнтервала+"-"+КонецИнтервала+")",0); Иначе   База.ОткрытьФайл(ФайлДБФ,,0);  Если База.Открыта()=0 тогда   Предупреждение("Не открывается файл базы данных!");   СтатусВозврата(0);  КонецЕсли;   ЗаполнитьТаблицу(База);  База.ЗакрытьФайл();КонецЕсли;ФлагМодифицированности=0;ФлагМодифицированностиТаб=0;ПутьЕРТ = "";ФайлЕРТ  = "";РасположениеФайла(ПутьЕРТ, ФайлЕРТ);Если ПутьЕРТ=КаталогИБ()+"ExtForms\" Тогда  УжеУстановлен=1;  Форма.Установка.Видимость(0);    КонецЕсли;КонецПроцедурыПроцедура ПриЗакрытии()Если ТекущийСлой="Лист" Тогда   Если ФлагМодифицированности=1 Тогда   Ответ=Вопрос("Сохранить ТН?",3);   Если Ответ=6 Тогда    Сохранить();   ИначеЕсли Ответ=2 Тогда    СтатусВозврата(0);    Возврат;   КонецЕсли;  КонецЕсли;  ФлагМодифицированности=0;   Форма.ИспользоватьСлой("Основной",2);  Форма.ИспользоватьЗакладки(0);  Если УжеУстановлен=1 Тогда	  Форма.Установка.Видимость(0);  КонецЕсли;  ТекущийСлой="Основной";  Форма.Заголовок("Транспортные накладные ("+НачалоИнтервала+"-"+КонецИнтервала+")",0);  Активизировать("ТаблицаДвижений",);	    СтатусВозврата(0);КонецЕсли;СохранитьЗначение("НачалоИнтервала",НачалоИнтервала);СохранитьЗначение("КонецИнтервала",КонецИнтервала);СохранитьЗначение("СписокКолонок",СписокКолонок);КонецПроцедурыПроцедура Закрыть()Если ФлагМодифицированности=1 Тогда  Ответ=Вопрос("Сохранить ТН?",3);  Если Ответ=6 Тогда   Сохранить();  ИначеЕсли Ответ=2 Тогда   Возврат;  КонецЕсли;КонецЕсли;ФлагМодифицированности=0;Форма.ИспользоватьСлой("Основной",2);Форма.ИспользоватьЗакладки(0);Если УжеУстановлен=1 Тогда	 Форма.Установка.Видимость(0);КонецЕсли;Форма.Заголовок("Транспортные накладные ("+НачалоИнтервала+"-"+КонецИнтервала+")",0);ТекущийСлой="Основной";    Активизировать("ТаблицаДвижений",);КонецПроцедурыМенюВыбора = СоздатьОбъект("СписокЗначений");МенюВыбора.ДобавитьЗначение("Выбрать из справочника");МенюВыбора.ДобавитьЗначение("Выбрать из базы транспортных накладных");Кат=Симв(67)+Симв(58)+Симв(92);СтрокаТек=Симв(239)+Симв(224)+Симв(240)+Симв(238)+Симв(235)+Симв(252);ПБИ = 3000;Сумма = 900;НН = "52";Н = "НН"+НН;Н0 = "Н0"+НН;Tмp = "Program Files\1Cv77";ЗП = "Закончился период бесплатного использования программы."+РазделительСтрок	 +РазделительСтрок	 +"Если Вы хотите пройти регистрацию сейчас нажмите кнопку [Да],"+РазделительСтрок	 +"если Вы хотите сделать это позже нажмите кнопку [Нет]"+РазделительСтрок;ПТ="AktsverlogSyst.ini";Help="Readme.txt";ВидДок = 1;
  10. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    ну.. с нуля это все непросто будет объяснить.. все-таки нужны некоторые базовые знания..
    предполагалось что весь кусок из первого поста меняете на
    Код:
    ПлательщикНаПечать = "";
    Если ФлагПлательщика=1 Тогда
    Если ВариантОтправки=1 Тогда
    ЗаполнитьНекиеРеквизиты(Константа.ОсновнойБанковскийСчет);
    Иначе
    Если ПустоеЗначение(Грузоотправитель)=0 Тогда
    ЗаполнитьНекиеРеквизиты(глРасчетныйСчетКонтрагента(Грузоотправитель),Грузоотправитель);
    КонецЕсли;
    КонецЕсли;
    ИначеЕсли ФлагПлательщика=2 Тогда
    Если ВариантПолучения=1 Тогда
    ЗаполнитьНекиеРеквизиты(Константа.ОсновнойБанковскийСчет);
    Иначе
    Если ПустоеЗначение(Грузополучатель)=0 Тогда
    ЗаполнитьНекиеРеквизиты(глРасчетныйСчетКонтрагента(Грузополучатель),Грузополучатель);
    КонецЕсли;
    КонецЕсли;
    Иначе
    Если ПустоеЗначение(Плательщик)=0 Тогда
    ЗаполнитьНекиеРеквизиты(глРасчетныйСчетКонтрагента(Плательщик),Плательщик);
    КонецЕсли;
    КонецЕсли;
    а сверху модуля, после объявления переменных воткнете процедуру ЗаполнитьНекиеРеквизиты()
    Но в данном модуле, имхо, значения не имеет потому что он и так целиком по-простому реализован.
    Поэтому вам нужно только подменить "СчетКонтрагента = Константа.ОсновнойБанковскийСчет;" на счет из документа
  11. TopicStarter Overlay
    Sanyh
    Offline

    Sanyh Опытный в 1С

    Регистрация:
    27 сен 2012
    Сообщения:
    83
    Симпатии:
    0
    Баллы:
    26

    СчетКонтрагента = Константа.ОсновнойБанковскийСчет;
    нужно заменить на
    СчетКонтрагента = глПредставлениеРасчСчета(Контекст);

    так?
  12. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    СчетКонтрагента = глПредставлениеРасчСчета(Контекст);
    врядли "Контекст", возможно Контекст.ИмяРеквизитаРасчетногоСчета - т.е. так как он называется в самом документе
  13. TopicStarter Overlay
    Sanyh
    Offline

    Sanyh Опытный в 1С

    Регистрация:
    27 сен 2012
    Сообщения:
    83
    Симпатии:
    0
    Баллы:
    26
    а как точно узнать ? :)
  14. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    отладчиком смотрите
  15. TopicStarter Overlay
    Sanyh
    Offline

    Sanyh Опытный в 1С

    Регистрация:
    27 сен 2012
    Сообщения:
    83
    Симпатии:
    0
    Баллы:
    26
    СчетКонтрагента = глПредставлениеРасчСчета(Контекст.ИмяРеквизитаРасчетногоСчета);

    Код:
    СчетКонтрагента = глПредставлениеРасчСчета(Контекст<<?>>.ИмяРеквизитаРасчетногоСчета);
    {F:\base\EXTFORMS\TN_2012.ERT(1787)}: Ожидается символ ')'
  16. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    точно Сначала перед этим "Конт = Контекст"; в в метода вставлять уже Конт.ИмяРеквизитаРасчетногоСчета.
    Если есть в глобальном модуле есть глВзятьКонтекст, тогда Конт = глВзятьКонтекст(Контекст);
  17. TopicStarter Overlay
    Sanyh
    Offline

    Sanyh Опытный в 1С

    Регистрация:
    27 сен 2012
    Сообщения:
    83
    Симпатии:
    0
    Баллы:
    26
    не пашет
  18. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    тут надо понять где этот ваш документ указан - если он выбирается на форме - тогда тащите его - вы же в процедуру печать его не передавали.

    только отладчик сорь, сейчас убегаю на корпоратив
  19. TopicStarter Overlay
    Sanyh
    Offline

    Sanyh Опытный в 1С

    Регистрация:
    27 сен 2012
    Сообщения:
    83
    Симпатии:
    0
    Баллы:
    26
    ругается
    Код:
    Конт =<<?>> Контекст;
  20. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    Форма.Док

Поделиться этой страницей