8.х Подскажите, как открыть существующий элемент справочника

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем WWW123, 23 фев 2009.

  1. TopicStarter Overlay
    WWW123
    Offline

    WWW123 Опытный в 1С

    Регистрация:
    23 фев 2009
    Сообщения:
    181
    Симпатии:
    0
    Баллы:
    26
    Только не бейте, я не совсем програмист, но надо исправить одну мелочь.
    Короче, надо открыть элемент справочнике, а не вызвать форму нового элемента!

    Код:
    Спр = Справочники.ГражданеПотребители.Выбрать();
    Пока Спр.Следующий() Цикл
    //......
    //......
    //......
    Справочники.ГражданеПотребители.ПолучитьФорму("ФормаЭлемента",Элемент).Открыть();
    //......
    КонецЦикла;
    
    Так, открывается новая форма.

    Прошу помочь, наверное это просто, но помошник и поиск мне не помогли.
  2. Maks21
    Offline

    Maks21

    Регистрация:
    17 сен 2008
    Сообщения:
    32
    Симпатии:
    0
    Баллы:
    1
    я вобще ничего не понял
  3. TopicStarter Overlay
    WWW123
    Offline

    WWW123 Опытный в 1С

    Регистрация:
    23 фев 2009
    Сообщения:
    181
    Симпатии:
    0
    Баллы:
    26
    Попробую объяснить более детально:

    Код:
    Спр = Справочники.ГражданеПотребители.Выбрать();
    Пока Спр.Следующий() Цикл
    Если о_ЗначениеНеЗаполнено(Спр.ЛицевойСчёт) = истина тогда; 
    
    Предупреждение("Найден пустой лицевой счёт");
    
    // Сдесь надо открыть найденный элемент справочника
    
    КонецЕсли;
    
    КонецЦикла;
    
    Если написать:
    Справочники.ГражданеПотребители.ПолучитьФорму("ФормаЭлемента",Элемент).Открыть();
    то открывается форма нового элемента, а мне надо открыть тот элемент на котором "спотыкнулся" цикл, чтобы руками исправить и записать!
  4. Maks21
    Offline

    Maks21

    Регистрация:
    17 сен 2008
    Сообщения:
    32
    Симпатии:
    0
    Баллы:
    1
    Код:
    Спр.ПолучитьФорму("ФормаЭлемента").Открыть();
    
  5. lazy
    Offline

    lazy Модераторы Команда форума Модератор

    Регистрация:
    1 сен 2007
    Сообщения:
    2.127
    Симпатии:
    4
    Баллы:
    29
    2Maks21: Если ничего не поняли, то не нужно об этом сообщать на весь мир. Если каждый пользователь форума напишет в теме, в которой он ничего не понял, что он "ничего не понял" форум рухнет за два дня. Не нужно оставлять бессмысленные сообщения.

    По теме: Обратите внимание, что на данном форуме рекомендуется оформлять код тегом [ code ] .

    Конкретно же по вашей проблеме -
    Код:
     Cправочники.ГражданеПотребители.ПолучитьФорму("ФормаЭлемента",Элемент).Открыть();
    
    
    Никак не связан с выборкой которая идет.
    Код:
     Пока Спр.Следующий() Цикл 
    
    
    Т.е. скорее всего корректный код будет
    Код:
     
    Пока Спр.Следующий() Цикл
    //....
    спр.ПолучитьОбъект().ПолучитьФорму("ФормаЭлемента").Открыть();
    
    
    
  6. TopicStarter Overlay
    WWW123
    Offline

    WWW123 Опытный в 1С

    Регистрация:
    23 фев 2009
    Сообщения:
    181
    Симпатии:
    0
    Баллы:
    26
    Огромнейшее спасибо!!!
    Заработалооо....

Поделиться этой страницей