8.х Подскажите, где поменять название шапки в печатной форме

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем kos_, 22 дек 2011.

  1. TopicStarter Overlay
    kos_
    Offline

    kos_

    Регистрация:
    22 дек 2011
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Подскажите, где поменять название шапки в печатной форме,
    "Управление торговлей для Украины", редакция 2.3.
    Разработка конфигурации: "ABBYY Ukraine", 2003-2009
    (2.3.13.1)
    На печать вывожу заказ покупателя, но нужно чтобы вместо текста "заказ покупателя" было написано "счет-фактура".
  2. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    Имеете в виду заголовок?
    Интересная затея ))
    Счет-фактура - это унифицированная форма. Если Вы неправильно ее оформите (вы ведь хотите заказ покупателя выдать за счет-фактуру), у покупателя могут возникнуть трудности с вычетом по НДС.

    По теме:
    С указанной конфигурацией не знаком.
    Откройте модуль объекта документа, найдите функцию, которая выводит на печать заказ.
    И в этой функции должна быть строка типа:
    Код:
    ОбластьМакета.Параметры.ТекстЗаголовка = ОбщегоНазначения.СформироватьЗаголовокДокумента(Шапка, "Заказ покупателя");
    //Это не точно...Может быть по-другому
    
    
    "Заказ покупателя" поменяете на "Счет-фактура".
  3. TopicStarter Overlay
    kos_
    Offline

    kos_

    Регистрация:
    22 дек 2011
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Только такое нашел

    // Процедура вызывается при нажатии кнопки "Печать" командной панели формы,
    // вызывает печать по умолчанию для формы документа.
    //
    Процедура ОсновныеДействияФормыДействиеПечать(Кнопка)

    УниверсальныеМеханизмы.НапечататьДокументПоУмолчанию(ЭтотОбъект);

    КонецПроцедуры // ОсновныеДействияФормыДействиеПечать()

    // Процедура - обработчик нажатия на кнопку "Печать".
    // Открывает форму выбора печатных форм объекта.
    //
    Процедура ОсновныеДействияФормыПечать(Кнопка)

    УниверсальныеМеханизмы.ОткрытьФормуВыбораПечатныхФормОбъекта(ЭтотОбъект, ЭтаФорма);

    КонецПроцедуры // ОсновныеДействияФормыПечать()
  4. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    Конфигурации этой у меня нет. Точно подсказать не могу...
    Но, да, там же...рядом...Ищите хорошенько...)))

    Функция должна называться как-то типа "ПечатьЗаказа" или "ПечатьДокумента".
  5. TopicStarter Overlay
    kos_
    Offline

    kos_

    Регистрация:
    22 дек 2011
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Нашел! Спасибо.
    Вот тут у меня меняется:

    ОбластьМакета = Макет.ПолучитьОбласть("Заголовок");
    Если Тип = "Счет" Тогда
    Если Шапка.ВидДоговораКонтрагента = Перечисления.ВидыДоговоровКонтрагентов.СКомиссионером Тогда
    ОбластьМакета.Параметры.ТекстЗаголовка = ОбщегоНазначения.СформироватьЗаголовокДокумента(Шапка, НСтр("ru='Список товаров на комиссию по заказу';uk='Список товарів на комісію по замовленню'",КодЯзыкаПечать),КодЯзыкаПечать);
    Иначе
    ОбластьМакета.Параметры.ТекстЗаголовка = ОбщегоНазначения.СформироватьЗаголовокДокумента(Шапка, НСтр("ru='Счет на оплату по заказу';uk='Рахунок на оплату по замовленню'",КодЯзыкаПечать),КодЯзыкаПечать);
    КонецЕсли;
    Иначе
    ОбластьМакета.Параметры.ТекстЗаголовка = ОбщегоНазначения.СформироватьЗаголовокДокумента(Шапка, НСтр("ru='Заказ покупателя';uk='Замовлення покупця'",КодЯзыкаПечать),КодЯзыкаПечать);
    КонецЕсли;
  6. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    Ну попробуйте после последнего "Иначе" заменить
    "Заказ покупателя" на "Счет-фактура" (это по-русски).
    И "Замовлення покупця" замените на ... ... как там "Счет-фактура" на украинском...

    Потом не забудьте нажать F7. Потом уже запускайте режим Предприятие и смотрите.
  7. TopicStarter Overlay
    kos_
    Offline

    kos_

    Регистрация:
    22 дек 2011
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    да, это я знаю, спасибо большое за помошь

Поделиться этой страницей