7.7 подсчет суммы

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Natalia_k, 15 июн 2010.

  1. TopicStarter Overlay
    Natalia_k
    Offline

    Natalia_k Опытный в 1С

    Регистрация:
    8 сен 2009
    Сообщения:
    153
    Симпатии:
    0
    Баллы:
    26
    Всем привет!

    помогите, пожалуйста, вывести итоговую сумму в таблицу Excel.

    Я пишу:
    Код:
    x = 9; //'Задает начало в строке 9
    
    Пока (exc.ActiveSheet.Cells(x, 1).Value <> "Итого") Цикл //' Цикл выполняется до тех пор, пока не найдена строка в первом столбце со словом ИТОГО
    
    //Задаю формат
    exc.ActiveSheet.Cells(x,9).NumberFormat="# ##0,00";
    exc.ActiveSheet.Cells(x,10).NumberFormat="# ##0,00";
    
    
    exc.ActiveSheet.Cells(x, 10).FormulaR1C1 = "=IF(OR(RC[-9]=""51.1"",RC[-9]=""51.2"",RC[-9]=""51.3""),RC[-4]-RC[-1],"""")";
    x = x + 1; //' увеличить значение счетчика на 1, чтобы обработать следующую строку
    если  exc.ActiveSheet.Cells(x, 1).Value = "Итого" тогда 
    exc.ActiveSheet.Cells(x,9).NumberFormat="# ##0,00";
    exc.ActiveSheet.Cells(x,10).NumberFormat="# ##0,00";
    
    exc.ActiveSheet.Cells(x,9).FormulaR1C1 = "=SUM(R[" & 2 - x & "]C:R[-1]C)"
    
    
    
    Как в этой строчке записать сумму итоговую по столбцу внутри таблицы?


    Если я пишу так, то выводятся ошибки:
    Код:
    exc.ActiveSheet.Cells(x,9).FormulaR1C1 = "=SUM(R[" <<?>>& 2 - x"]C:R[-1]C)";  
    
    
    
    : Ожидается ключевое слово 'КонецЕсли' ('EndIf')
    <<?>>КонецЕсли;
    : Ожидается ключевое слово 'КонецЦикла' ('EndDo')
    <<?>>КонецЕсли;
    : Ожидается ключевое слово 'КонецЦикла' ('EndDo')
    <<?>>КонецЕсли;
    : Ожидается ключевое слово 'КонецПроцедуры' ('EndProcedure')


    Помогите, пожалуйста!
    [warn="Внимание!"]
    Пользуемся тегами правильно!
    [/warn]
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Код:
    exc.ActiveSheet.Cells(x,9).FormulaR1C1 = "=SUM(RC["+НачальнаяСтрока+"]:R["+КонечнаяСтрока+"]C["+Колонка+"])"
    
    
    
  3. TopicStarter Overlay
    Natalia_k
    Offline

    Natalia_k Опытный в 1С

    Регистрация:
    8 сен 2009
    Сообщения:
    153
    Симпатии:
    0
    Баллы:
    26

    Спасибо! Разобралась!

    exc.ActiveSheet.Cells(x,9).FormulaR1C1 ="=SUM(R[-"+Строка(x-8)+"]C:R[-3]C)";

    Всё заработало!

Поделиться этой страницей