8.х Подобор Номенклатуры

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем qwertik, 15 сен 2009.

  1. TopicStarter Overlay
    qwertik
    Offline

    qwertik

    Регистрация:
    25 июл 2009
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Помогите пожалуйста новичку.
    Мне нужно организовать учет спецодежды. Имеется документ ВыдачаСпецодежду, нужно:
    1) При выборе ФИО чтобы заполнялись реквизиты пол, подразделение, должность (есть в справочнике СотрудникиОрганизации).
    2) В этом док. есть табличная часть, в которой записываем выданную Спецодежду (точнее выбираем из общего списка склада). Как сделать, чтобы при выборе отображалась не вся номенклатура, а только то что положено для данной должности. Здесь я создал справочник с двумя реквизитами(подразделение/должность и табличной частью-что разрешено для этой должности).
    Может у Кого бала такая задача, помогите.
  2. Elkis
    Offline

    Elkis Опытный в 1С

    Регистрация:
    15 окт 2009
    Сообщения:
    190
    Симпатии:
    1
    Баллы:
    29
    Я бы сделала доп.кнопочку в форме "Добавить по сотруднику" и ручками всё прописала
  3. Elkis
    Offline

    Elkis Опытный в 1С

    Регистрация:
    15 окт 2009
    Сообщения:
    190
    Симпатии:
    1
    Баллы:
    29
    Я тут без работы сижу, пишу всё подряд, чтобы квалификацию не терять. По вашему вопросу вот что написала: Добавила в меню кнопки "Заполнить" ещё один вариант "Добавить по работнику"

    Код:
    Процедура КоманднаяПанельТоварыДобавитьПоРаботнику(Кнопка)
    ВыбранныйСотрудник = Справочники.СотрудникиОрганизаций.ПолучитьФормуВыбора(, ЭтаФорма, ).ОткрытьМодально();
    
    ПереченьСпецодежды = Справочники.Elkis_ПереченьСпецодеждыСотрудников;
    Отбор = Новый Структура("Должность");
    Отбор.Должность = ВыбранныйСотрудник.Должность;
    Выборка = ПереченьСпецодежды.Выбрать(,,Отбор, "Наименование Убыв");
    Пока Выборка.Следующий() Цикл
    Если Выборка.Подразделение = Справочники.ПодразделенияОрганизаций.НайтиПоНаименованию("СТО") Тогда 
    Для Каждого ТекущаяСтрока Из Выборка.Спецодежда Цикл 
    НоваяСтрока = Материалы.Добавить();
    НоваяСтрока.Номенклатура = ТекущаяСтрока.Номенклатура;
    НоваяСтрока.ЕдиницаИзмерения = ТекущаяСтрока.Номенклатура.ЕдиницаХраненияОстатков;
    НоваяСтрока.Количество = ТекущаяСтрока.КоличествоПоНормеВыдачи;
    НоваяСтрока.ФизЛицо = ВыбранныйСотрудник.ФизЛицо;
    НоваяСтрока.НазначениеИспользования= ТекущаяСтрока.Номенклатура.НазначениеИспользования;
    НоваяСтрока.СчетУчетаБУ = ПланыСчетов.Хозрасчетный.СпецоснасткаИСпецодеждаНаСкладе;
    НоваяСтрока.СчетПередачиБУ = ПланыСчетов.Хозрасчетный.СпецоснасткаИСпецодеждаВЭксплуатации;
    НоваяСтрока.Качество = Справочники.Качество.Новый;
    //ЭтотОбъект.Записать();
    КонецЦикла;
    
    Попытка
    Записать();
    Исключение
    Предупреждение("Не удалось записать объект """ + ЭтотОбъект + """
    |" + ОписаниеОшибки(),60);
    КонецПопытки;
    КонецЕсли;
    
    КонецЦикла
    
    КонецПроцедуры
    
    Это самый простой вариант. Есть ещё поинтереснее. Удачи

    [warn=Читайте правила]Используйте тэг
    Код:
    [/warn]

Поделиться этой страницей