8.х Подключиться к Экселю?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем -=ak=-, 4 апр 2007.

  1. TopicStarter Overlay
    -=ak=-
    Offline

    -=ak=- Опытный в 1С

    Регистрация:
    13 фев 2006
    Сообщения:
    107
    Симпатии:
    0
    Баллы:
    26
    Привет всем!

    Мне нужно подключиться к Экселю и прочитать колонку номенклатуры, потом загрузить в документ.
    Есть примерчик как прочитать из экселя?

    Спасибо!
  2. ezzick
    Offline

    ezzick

    Регистрация:
    16 авг 2006
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Вот тут пример работы с Exceleм, вдруг поможет

    Вложения:

  3. TopicStarter Overlay
    -=ak=-
    Offline

    -=ak=- Опытный в 1С

    Регистрация:
    13 фев 2006
    Сообщения:
    107
    Симпатии:
    0
    Баллы:
    26
    Данная обработка не работает с файлами экселя, предлагает выбрать DBF :unsure:
  4. ezzick
    Offline

    ezzick

    Регистрация:
    16 авг 2006
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    можно попробовать просто файл Excel'я сохранить как .DBF
  5. SashaV
    Offline

    SashaV

    Регистрация:
    5 фев 2007
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Примерно....

    XLSФайл-Поле ввода на форме,где указан путь к файлу

    Файл = Excel.Workbooks.Open(СокрЛП(XLSФайл));
    Лист = Файл.Sheets(1);

    LastRow = Excel.Cells(1,1).SpecialCells(11).Row;
    LastColumn = Excel.Cells(1,1).SpecialCells(11).Column;

    НомерКолонкиНоменклатура = 1;

    Для i = 2 По LastRow Цикл
    ОбработкаПрерыванияПользователя();

    НоменклатураВФайле = СокрЛП(Строка (Лист.Cells ,НомерКолонкиНоменклатура).Value));

    СтрокаТабличнойЧасти = ТЗ.Добавить();
    СтрокаТабличнойЧасти.Номенклатура = НоменклатураВФайле ;
    КонецЦикла;

    Excel.Workbooks.Close();
  6. jon
    Offline

    jon Опытный в 1С

    Регистрация:
    4 сен 2006
    Сообщения:
    76
    Симпатии:
    0
    Баллы:
    26
    Ошибка = 0;
    Попытка
    Экс = ПолучитьCOMОбъект("", "Excel.Application");
    Книга=Экс.Workbooks;
    Исключение
    Ошибка = 1;
    Сообщить("Не могу создать объект Excel");
    Возврат;
    КонецПопытки;
    Попытка
    Книга = Книга.OPEN(СокрЛП(Элементыформы.ПутьКФайлу.Значение));
    НомерСтр=0;
    дальше=1;
    СтрНом=СтартоваяСтрока-1;
    Исключение
    Ошибка = 1;
    Сообщить("Не могу открыть файл Excel");
    Возврат;
    КонецПопытки;

    Пока дальше = 1 цикл
    СоСтояние("Закачка исходного файла - выполнено "+СтрНом+" строк");
    СтрНом=СтрНом+1;
    яч0=Экс.Cells(СтрНом,3);//номер платежки
    Если (СтрДлина(СокрЛП(Яч0.Value))=0) Тогда
    Прервать;
    КонецЕсли;
    яч1=Экс.Cells(СтрНом,6);// Тип услуги
    НоваяСтрока.ВидУслуги = СокрЛП(Яч1.Value);
    КонецЦикла;
    Экс.Quit();
  7. B@girusss
    Offline

    B@girusss Опытный в 1С

    Регистрация:
    13 сен 2006
    Сообщения:
    102
    Симпатии:
    0
    Баллы:
    26
    Должно помоч!
    Там перейди к моему сообщению, и скачай...
    Есть такая же для 7.7, могу скинуть...
    http://www.1c-pro.ru/index.php?showtopic=1603

Поделиться этой страницей