8.х Подключение внешней компоненты

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем 1с-ник, 18 май 2017.

  1. TopicStarter Overlay
    1с-ник
    Offline

    1с-ник Профессионал в 1С Заблокирован

    Регистрация:
    5 окт 2014
    Сообщения:
    998
    Симпатии:
    160
    Баллы:
    104
    Есть некий сканер ШК (подключается по wi-fi, тест проходит). Установил для него дрова, в папке с дровами нашёл пресловутую PriceDrv.dll, которую описывают там.
    У меня розничная конфа, запуск в толстом клиенте управляемого приложения.
    Dll-регана!
    [​IMG]
    Подключаю ВК:
    Создаю драйвер (как указано в статье ИС, да и в инструкции этому сканеру) и получаю fail:
    Код:
    Драйвер = Новый("AddIn.PriceChecker");
    [​IMG]
    Перечитал ИТС https://its.1c.ru/db/v838doc#bookmark:dev:TI000001207 по подключениям ВК, перепробовал все варианты - безрезультатно.

    Вложения:

    Последнее редактирование: 18 май 2017
  2. TopicStarter Overlay
    1с-ник
    Offline

    1с-ник Профессионал в 1С Заблокирован

    Регистрация:
    5 окт 2014
    Сообщения:
    998
    Симпатии:
    160
    Баллы:
    104
    Получилось подключить на локальном компе:
    Код:
    Перем Драйвер Экспорт;
    
    &НаСервере
    Процедура ПодключитьВнешнююКомпонентуНаСервере()
          
        Попытка
            ПодключениеВыполнено = ПодключитьВнешнююКомпоненту("PriceDrv.dll", "My", ТипВнешнейКомпоненты.COM);
            Драйвер = Новый("AddIn.My.PriceChecker");
            Сообщить("Подключение успешно!");
        Исключение
            Сообщить(ПодробноеПредставлениеОшибки(ИнформацияОбОшибке()));  
        КонецПопытки;
      
    КонецПроцедуры
    
    А на сервере (терминальное подключение) не получается. Ну, бог с ним, пускай админ разруливает эту ситуёвину.
    Но я всё равно не понимаю, каким образом я смогу обрабатывать события сканера ШК.
    Неужели этой библиотеки достаточно для перехвата событий в соответствующем обработчике модуле формы моей внешней обработки?
    Код:
    &НаКлиенте
    Процедура ВнешнееСобытие(Источник, Событие, Данные)
      
        Если Источник <> "PriceChecker" Тогда
            Возврат;
        КонецЕсли;
      
        Сообщить("Событие перехвачено!", СтатусСообщения.Внимание);
      
        //ШК = СокрЛП(Данные);
        //ТаблицаНоменклатуры = Штрихкодирование.ПолучитьДанныеНоменклатурыПоШтрихкоду(ШК);
      
    КонецПроцедуры
    
    --- Объединение сообщений, 18 май 2017 ---
    Повторюсь: он настроен, "общение" с тестом драйвера проходит, ответы получаю. Но как 1с увидит это я вообще не понимаю.
    Последнее редактирование: 18 май 2017

Поделиться этой страницей